x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Materials from imported projects don't load texture samples

I'm using 4.10.1. Lately i have downloaded 2 different projects from the internet (not marketplace or UE4 sources) and when I open a material, Its texture samples are not assigned (node without a texture), or material instances without parent material. This doesn't happen with all downloaded projects and never happened to me before 4.10. Maybe it's a bug?

Product Version: UE 4.10
Tags:
more ▼

asked Mar 23 '16 at 05:02 AM in Using UE4

avatar image

lolhost
28 5 7 9

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello Lolhost, Gotta say, it sounds fishy to say the least if you dont state where you gotten these files. But since I dont like to think this is a HarrHarr situation, and looking at the information you gave us. (or lack thereof)

Are you sure the projects you downloaded are 4.10 projects? Because if they are not, and you open them, or copy/paste them to a project that can cause a variety of issues.

more ▼

answered Mar 23 '16 at 10:55 AM

avatar image

Luos
9.1k 282 62 327

avatar image lolhost Mar 23 '16 at 06:52 PM

One of the projects is the auto terrain texturer from here https://gumroad.com/12catblack# (and yes, I installed and activated the plugin) and the other is an ocean material from youtube. I know for certain that the ocean project is not 4.10 so that may be the case, but the auto terrain texturer is 4.10 and gave me the worst results (like i said before, materials missing texture samples, material instances missing parent materials, material functions not working at all). I also downloaded the weather and ocean plugin from here https://github.com/UE4-OceanProject/OceanProject/tree/4.10 and it gave no problems at all.

avatar image DrewCarter101 Feb 18 '17 at 09:55 AM

I have the same problem as well with any pack I install, whether it is downloaded from the internet or added from the launcher, even some of the materials from the blueprint do this. Whenever I try to use the material or a mesh, it changes to the grey checkered box pattern. Restarting the engine brings them back but whenever I try to use them the same thing happens. I found out that the texture samples aren't assigned (node without a texture) but whenever i fix them manually by adding the textures and reload the engine, the problem just starts all over again

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question