x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to update mesh with new uv channels

Does anyone know what might cause UE4.10 to not update a mesh when overwritten? For example, I imported an fbx object which had bad lightmap uvs in channel 2. I checked the uvs in UE4 and they were overlapping. I went back to maya, fixed the uvs, saved and over wrote the same file in the UE4 content directory. UE4 reported a change. I then checked the model again in Ue4 but the uvs never updated. I tried reimporting the model, but the uvs still did not update. I double checked in maya and they were fine. I then exported another version of the same model from maya into the same folder in the contents directory structure. When I viewed these uvs in UE4, they are now clean. Strange.

Does UE4 cache some of this data? I even restarted UE4 but still get the same issue with the original file. I have my workaround but just want to know why this might be occurring? Any ideas?

Product Version: UE 4.10
Tags:
more ▼

asked Mar 24 '16 at 11:32 PM in Using UE4

avatar image

Haskellf
91 7 12 23

avatar image Haskellf Mar 24 '16 at 11:45 PM

I found if I delete the associated .uasset file and re-import the mesh, then it updates properly.

avatar image [HP] Sep 18 '16 at 10:59 PM

I'm having this bug myself, it's the most annoying thing. I wish these basic things worked correctly in UE4. Indeed, the only way to fix this, is to delete the .usasset and reimport all over.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question