x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

When I drag something into my scene, instead of saying "compiling shaders", it freezes the UE editor until it's done.

Video: https://dl.dropboxusercontent.com/u/65017464/ShareX/2016/03/1500.mp4 (it streams, you don't have to download).

Reddit discussion: https://www.reddit.com/r/unrealengine/comments/4c141u/when_i_drag_something_into_my_scene_instead_of/

Happens in both 4.10 & 4.11 preview 8. Wasn't happening before I reinstalled my OS a few weeks ago. Problem persisted for a while now but I wasn't using UE so I didn't do anything about it at the time. Before I reinstalled, the shader workers appeared on my task manager and I was still able to use the editor. Now UE freezes and, sometimes when bringing in large items such as trees, crashes the editor (stays responsive for a long time - no bug splats).

Computer: Intel 2500k @ 4.5ghz. 14gb ram. Gtx 760. Windows 10, all drivers updated.

Product Version: UE 4.10
Tags:
more ▼

asked Mar 27 '16 at 11:41 AM in Bug Reports

avatar image

Asusralis
56 6 15 22

avatar image Adam Davis STAFF Mar 28 '16 at 05:38 PM

Hi Asusralis,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?

  • Does this occur with any asset or a specific asset?

avatar image Asusralis Mar 29 '16 at 04:24 PM

Yes. Although it seems to only happen to assets I've never used before regardless of the project I'm in.

Example: I download mesh1. I drag mesh1 into project1: the ue editor freezes. After it's done freezing, I then can drag more mesh1 into the project without ue freezing.

I then go to project2 and add mesh1. If I drag mesh1 into project2, ue will not freeze.

And no, it doesn't occur with any specific asset.

Also, I messed up the video's link I linked in the original post, so the video it points to is unrelated to this post. Sorry about that. I can create another if it would help you with understanding this bug.

Thanks for spending your time to help! This bug really makes ue unusable when I try to import large items. Which is a shame because I'm enjoying it so much.

avatar image Adam Davis STAFF Mar 29 '16 at 04:43 PM

I've attached a test asset, it is one of the base assets from blender. Can you try importing this to see if it gives you the same freeze? If it does not, can you show me a screenshot of one of the assets that are causing problems, specifically, I'd like to see the wireframe of the asset in the asset editor.

link text

testasset.zip (15.9 kB)
avatar image Asusralis Mar 29 '16 at 05:25 PM

Hmm! I created a brand new project and imported it. For some reason ue didn't freeze for that mesh.

Every asset type (i.e meshes, materials, effects, etc) from both starter content and "Open World Demo Collection" freezes my editor.

Here is a wireframe from a random object I chose, "SM_River_Rock_01", from the open world collection provided by Epic.

http://i.imgur.com/6QKKIo3.jpg

EDIT: Actually, I think it (the mesh you provided) didn't seem like it froze because of how small the object was. Small objects make the editor freeze a lot shorter so it has the illusion of it not freezing. But you can still tell because you will still see the editor hang up for a split second. I've tested this with the "basic" shapes that are provided with the starter content.

So, in conclusion, I think it still froze. It just frozen extremely fast so I didn't notice it. If I try to bring a tree I haven't used before from the Open World collection my editor will freeze for like 3+ minutes.

avatar image Adam Davis STAFF Mar 29 '16 at 05:56 PM

How large is the level you are using? How many assets do you already have in it? Looking at that rock, it has ~2000 polygons, whereas the one I provided has significantly less. I believe what you are seeing may be expected, especially if you have a large environment using assets that have higher polycounts, the time it takes to process this information will grow exponentially. If this is the case, you will need to optimize your project to be able to reduce the load times you are seeing.

avatar image Asusralis Mar 29 '16 at 06:35 PM

This happens in 100% blank projects and full projects like in the picture. I made a video for you so you see exactly what I do to reproduce the bug.

Video: https://dl.dropboxusercontent.com/u/65017464/ShareX/2016/03/ue4%20bug.mp4

Skip to 1:43 for the project creating & Open World collection to be done being added to the project. I recorded this to show this was a brand new project.

Skip to 1:55 to see the bug take place.

Skip to 3:15 for the bug to end. I then show how I can add the same object multiple times without the bug happening again.

Skip to 3:35 for the wireframe of the object.

If you need any more information I'll be happy to give it.

Also, please note this is NOT because of my hardware. Ue4 has worked perfectly for me up until I reinstalled my computer. I know for a fact a 2500k @ 4.5 can definitely handle ue4.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

After checking more into what you are seeing, I can confirm that this is most likely caused by the assets in the collection you are using and that this is expected. These assets are all extremely high detailed/high poly and have large photo-scanned textures in the materials. Even with a high spec machine, it will take a lot of time to properly load the assets into the project (the additional project files are 6.5 gbs alone).

more ▼

answered Mar 29 '16 at 08:55 PM

avatar image Asusralis Mar 29 '16 at 09:07 PM

But.. I've told you multiple times this was never like this. It's supposed to say, "compiling shaders" and run on its own thread. There is no way the intended behavior is to freeze the editor.

I've also said multiple times this happens with every asset, be it large or small.

I do not want to sound rude but I don't think you understand what's supposed to happen when you drag something you haven't used before into your scene. A message that says, "Compling shaders" pops up and runs on its own thread. This allows use of the editor while it's doing its thing. This has stopped happening. For some reason the shader compiler is running on the editor's thread. This is an obvious bug.

avatar image Adam Davis STAFF Mar 30 '16 at 06:21 PM

Try creating a new, blank project with only starter content, not the Kite Demo assets. Do you see this occur?

The assets within the Kite Demo are, as stated earlier, extremely detailed. They have 8k photo-scanned textures on top of high poly assets. The rock you linked earlier alone has 2000+ polys, much more than a normal rock asset needs. The behavior you are seeing is absolutely expected with high poly assets using 8k textures. The Compiling Shaders error you are seeing is not an error. Each asset, when used, needs to have its DCC written, which does more than compile shaders. This would explain why you are not seeing just the compile shaders popup occur, it's pausing before it has even had a chance to compile shaders while writing the DCC for the asset due to the sheer size of the content being used.

avatar image Asusralis Mar 31 '16 at 10:52 AM

I've said before this literally happens with every resource. Every single one. From a material to a mesh to a particle. Both big and small. I only used the Open World Collection because it was already downloaded.

Seriously, every resource. Even the small materials that come with the starter contenty freeze the ue for 10+ seconds.

avatar image Adam Davis STAFF Mar 31 '16 at 05:06 PM

I have not been able to reproduce anything unexpected on my end with the steps provided. Do you have any other steps I can take to reproduce this on my end with starter content?

avatar image Asusralis Mar 31 '16 at 06:12 PM

I don't think so. I just reinstalled Windows and ue4 and the problem still persists.

If this means anything: Anytime I reinstall my OS and try to install ue4 I always get a download error. Which forces me to manually download C++ 2008 on my computer. Could I be missing any other redistributables?

I swear it never did this before. It always did what it was supposed to do and have the message "compiling shaders." All other programs work like normal so I'm fairly certain it's ue. I even have an ssd if that would mean anything in terms of speed.

avatar image Adam Davis STAFF Apr 01 '16 at 06:34 PM

Hi Asusralis,

Please download the attached project and try to reproduce it with the assets within the project:

http://www.filedropper.com/ddctest

If it reproduces, please go to the filepath where you unzipped the projects and navigate to the \saved\logs\ folder, zip the entire folder and upload it here so I can take a look. Additionally, you can find information on the DDC and what actions it performs here:

https://docs.unrealengine.com/latest/INT/Engine/Basics/DerivedDataCache/index.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question