x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

TRASHCLASS Compile Error. Unable to override custom events.

I created a class extending from Actor and its called BaseActor. Inside this class i created a custom event which i can override in child classes. From this i extended another class called MasterTower and override that event. No problems till here. Again from MasterTower i extended another class called Core. Inside this class when i try to override the event i get the TRASHCLASS compile error everytime i start the editor. The only workaround for this is to compile the parent class (MasterTower or BaseActor) which makes this error go away.

alt text

Packaging the game also fails due to this error.

alt text

Product Version: UE 4.10
Tags:
more ▼

asked Mar 30 '16 at 05:40 AM in Bug Reports

avatar image

ryanjon2040
1.6k 56 43 93

avatar image Sean L ♦♦ STAFF Mar 30 '16 at 01:59 PM

Hello,

Have you been able to reproduce this following the same steps in a clean project? I have just tried to reproduce it following your steps and have not seen the same behavior.

avatar image ryanjon2040 Mar 30 '16 at 02:37 PM

I will try to reproduce this in a clean project and let you know. I had this issue in one of my other projects too using 4.10. I'll try this on 4.11 preview 8 too.

avatar image Sean L ♦♦ STAFF Mar 30 '16 at 02:42 PM

Thank you. I will continue to test this on my end as well, so let me know once you have results.

avatar image ryanjon2040 Mar 31 '16 at 11:00 AM

Hey Sean..I tried to reproduced this on a clean project but unfortunately i can't. I don't know why its showing in my project only and it happened to one of my other projects too. Maybe this error shows up if you have couple of Blueprints with lots of nodes.

avatar image Sean L ♦♦ STAFF Mar 31 '16 at 02:10 PM

There is a similar issue that was fixed in an internal build. Could you please zip up your project and provide me with a link to Dropbox where I can download it? That way I can test it using our internal build and determine whether the issue has already been resolved.

You can PM me the link on the forums, but please post here to notify me that you have done so as well. Thank you. https://forums.unrealengine.com/member.php?160394-Sean-Flint

avatar image ryanjon2040 Apr 01 '16 at 05:48 AM

Hi Sean...PM sent with project link.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello,

I am marking this topic as resolved for tracking purposes, as we have not heard from you in a few days. If this issue persists, feel free to respond to this thread. For any new issues, please create a new Answerhub topic.

Have a great day

more ▼

answered Apr 18 '16 at 12:55 PM

avatar image

Sean L ♦♦ STAFF
43.5k 485 152 442

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello,

Thank you for providing your project.

After testing the project in our internal build, it seems that the issue that you were experiencing with compiling the core blueprint before the master has been resolved. I was able to compile the Core bp without any issues, even if I did not first compile the other two blueprints.

In the meantime, until this fix is available, the workaround would be to compile the other two blueprints before going to compile Core.

Have a great day

more ▼

answered Apr 01 '16 at 01:12 PM

avatar image

Sean L ♦♦ STAFF
43.5k 485 152 442

avatar image ryanjon2040 Apr 02 '16 at 05:44 AM

Hey Sean,

I upgraded the project to 4.11 and that error no longer occurs :).

avatar image MajinSephiroth Apr 05 '16 at 07:10 PM

Compiling children before parent fixed it in our case on 4.11, thanks Sean!

avatar image ryanjon2040 Apr 06 '16 at 05:30 AM

I can also confirm it. There is no TRASHCLASS error in 4.11. Thank you Epic! :)

avatar image ryanjon2040 Apr 07 '16 at 04:53 AM

Unfortunately i have to re-open this ticket because the error is back and i cant compile new classes extending from another Blueprint after reopening the editor. Same TRASHCLASS error but now editor crashes with this callstack.

alt text

avatar image Sean L ♦♦ STAFF Apr 07 '16 at 02:35 PM

One thing you can try is to take the 4.10 version of the project, delete the Saved and Intermediate folders, and convert that project with those folders stripped out to 4.11.

avatar image ryanjon2040 Apr 08 '16 at 05:43 AM

I don't have the 4.10 version but still i removed Intermediate and Saved folders and started the project but still no luck. Same error and crash. :(

avatar image Sean L ♦♦ STAFF Apr 08 '16 at 01:06 PM

How are you reproducing this crash in your 4.11 project? I still have the project from when you sent it previously, so if you can provide me with repro steps, I can attempt to identify the cause.

Thank you.

avatar image ryanjon2040 Apr 11 '16 at 06:04 AM

Hi Sean,

These are the exact steps i did that caused this crash:

1: Duplicated (Right click -> Duplicate) TowerProjectile class in /Blueprints/Projectiles/ folder.

2: Changed the mesh.

3: Compiled it and saved it.

There was no crash at that moment and i was able to compile and save it. But after closing the editor and opening it, this crash starts happening. And for some strange reason, i cant add any Blueprint scripting to this class (Open Full Blueprint option is gone).

alt text

error.png (62.1 kB)
avatar image Sean L ♦♦ STAFF Apr 11 '16 at 01:29 PM

Hello,

The version of your project that I have does not have a Mesh variable when I'm looking at the Tower Projectile class. Is it possible that you have updated your project since sending it to me a few weeks back? If so, could you send me the updated version?

avatar image ryanjon2040 Apr 13 '16 at 10:44 AM

Hi Sean,

I have PM'ed you on forums the new download link.

avatar image Sean L ♦♦ STAFF Apr 13 '16 at 05:43 PM

Thank you for providing the new version. I have followed the steps above:

  1. Duplicate Tower Projectile

  2. Open the new duplicate and change the mesh

  3. Compile, Save All, Restart Editor

  4. Open the duplicate again and compile

No crash occurred on my end, and I was able to open the full blueprint editor. Are you running version 4.11.1 currently?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question