x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Wininet crashes on editor startup in debug on certain networks

This one is pretty specific. UE4 will crash in debug on startup on my laptop when connected via wifi to a certain network and automatic configuration is enabled in Internet Explorer.

The laptop is running Windows 7 x64.

The crash occurs deep in the bowels of a wininet worker thread processing requests for the HTTP module, I've attached a callstack link text

From my investigation, I'm pretty sure this is actually a bug in Windows itself. Firefox has run into the same thing and has a bugzilla thread going about it here https://bugzilla.mozilla.org/show_bug.cgi?id=854176

None of the code workarounds they suggest work. The only workaround I've found is turning off automatic configuration in Internet Explorer's LAN Settings (on the connections tab).

Product Version: Not Selected
Tags:
callstack.txt (3.2 kB)
more ▼

asked May 05 '14 at 04:30 PM in Installation & Setup

avatar image

solid_angle
97 3 6 10

avatar image Adam Davis STAFF May 06 '14 at 01:35 PM

Hi solid_angle,

Thank you for the report, can you please attach your dxdiag to this as well? Have a great day!

avatar image solid_angle May 06 '14 at 02:04 PM

Here you go

link text

dxdiag.txt (45.1 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

This is not a graphics card problem. It's a crash in windows networking. The two things could not be more unrelated.

The editor runs fine in development, and runs fine if I disable automatic configuration on my LAN settings. It isn't obvious from the dxdiag but my laptop has two GPUs - the intel integrated one for power savings and a geforce 525M which is a DX11 part.

Anyway I just posted this in case anyone else runs into the same issue.

more ▼

answered May 06 '14 at 03:03 PM

avatar image

solid_angle
97 3 6 10

avatar image Adam Davis STAFF May 06 '14 at 03:08 PM

Hi solid_angle,

I apologize for the misunderstanding as I was not aware you had a second GPU. However, as you have said that you are aware of what is causing the issue I will mark this as accepted for the purposes of tracking. Please let us know if you need any further assistance. Have a great day!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi solid_angle,

Unfortunately it looks like your laptop is below the minimum recommended specs for the editor. To run the editor efficiently you need a graphics card that can support directX 11. Here is more information on recommended specs to run th eeditor: https://answers.unrealengine.com/questions/12361/what-are-unreal-engine-4s-system-requirements.html . Have a great day!

more ▼

answered May 06 '14 at 02:44 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question