Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot build project (UBT ERROR)

Hello! I cannot build my project due to some Unreal Build Tool error. I've tried building for both Windows and Android but I get the same UBT error:

 UnrealBuildTool: ERROR: UBT ERROR: Failed to produce item: 'filepath'.exe

I have attached the log file if you would like to take a look at it yourself.

I'm pretty new to Unreal. I've tried restarting Unreal and even my machine.

Product Version: UE 4.9
log.txt (29.5 kB)
more ▼

asked Mar 31 '16 at 03:11 PM in Packaging & Deployment

avatar image

71 6 8 11

avatar image Sean L ♦♦ STAFF Mar 31 '16 at 07:04 PM


  • Are you able to package a clean, blank project successfully?

  • Does this occur if you try upgrading the project to 4.11 and packaging it there?

  • Have you tried deleting your saved and intermediate folders from your project and packaging again?

avatar image Olverine Mar 31 '16 at 10:22 PM

I can build an empty project (or any other project) without problems. I do not currently have any other engine versions installed. Deleting the saved and intermediate folders didn't help either.

avatar image Sean L ♦♦ STAFF Apr 03 '16 at 03:49 PM

Are you working with a blueprint or code project?

avatar image Olverine Apr 03 '16 at 03:59 PM

I have one C++ class as a parent for a couple of blueprints. However, I've been thinking about remaking the class as a blueprint and reparent the child classes. Do you think that would help?

avatar image Sean L ♦♦ STAFF Apr 03 '16 at 04:08 PM

It's worth a shot. It seems like some of the errors that you were getting may have been related to declaring a function in the header file, but not having any implementation of that function in the .cpp. Is that something that you have occurring in your project currently?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Some things to try

  • Fix the redirectors (right click contents -> Fix redirections)

  • There is a warning about a Class none, that may be related to the redirections.

  • Disable most plug-ins

  • Sometimes it's been reported that Blueprints can fail compiling if they have underscore in their files (I have not had that issue personally)

  • Delete Binaries/Saved/Intermediate. Relaunch

  • Try Cook.

hope this helps.

more ▼

answered Apr 04 '16 at 12:22 PM

avatar image

1.8k 66 27 90

avatar image Edregol Jun 01 '17 at 07:55 PM

I upgrade my project from 4.15 to 4.16. Deleting the folders Binaries/Saved/Intermediate did the trick for me. I still had to rebuild the project files(right click on the *.uproject file in your project folder) and I needed to upgrade the *.cs build files to 4.16 standards though. Thanks for the advice!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi. I found a simple solution: execute Epic Laucher as administrator. After deleting Saved, Intermediate and Build folders, moved the project folder to other drive, because long path strings can be a problem for Unreal, I figured out that some administrative issues in Windows can bother. All the best!

more ▼

answered Sep 05 '16 at 05:46 AM

avatar image

Mauricio N. Santos
1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Thank you Keyleeeeee!!!!!!!

more ▼

answered May 27 '18 at 06:53 PM

avatar image

1 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question