x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Turning camera in 4.11 crashes project

Updated to 4.11 just now, converted old 4.10 project. Entire project crashes to hell and back when I try to rotate the camera in the viewport.

Any suggestions?

Product Version: UE 4.11
Tags:
more ▼

asked Mar 31 '16 at 05:16 PM in Bug Reports

avatar image

Xaragoth
26 1 3

avatar image TJ V ♦♦ STAFF Mar 31 '16 at 06:54 PM

Hi Xaragoth,

We just released the official version of 4.11. Could you try converting your project there to see if the issue is still happening.

If it is, please include your Crash Callstack info (Epic ID and Machine ID) and make sure you submit that report. Also include your Crash Logs described here.

How are you turning the camera? Blueprints or code? Please include some screenshots if possible.

avatar image Xaragoth Mar 31 '16 at 07:03 PM

Right mouse button inside the editor viewport - literally instantly crashes if I try to rotate. Not even starting any gameplay or anything.

I converted the project to 4.11 - I also made a new project, migrated all the relevant files to that one and it won't even load the map.

Here's the log from trying to open it: https://dl.dropboxusercontent.com/u/53255048/RotationCrash.log

It works fine in 4.10 without any problems at all.

Edit: Also seeing Texture Streaming Pool Over 15MB in big fat red letters in the corner now.

Edit2: Well, I think this was why it crashed. Streaming Pool set itself to 0 during the update, it seems.

Gonna test some and see if it was the issue.

avatar image Xaragoth Mar 31 '16 at 07:18 PM

Okay, it's NOT why it crashed. Also here's the IDs:

MachineId:9C30F3324AF59D25FFF2AABA90A51BC5 EpicAccountId:c770d1c84083419ca2b19c3badfad534

avatar image TJ V ♦♦ STAFF Apr 01 '16 at 06:56 PM

In the crash log it mentions this same error with many different assets:

[2016.03.31-18.54.13:014][ 0]LogPackageName:Warning: String asset reference "ThroneRoom_Surfaces.Mesh.SM_Jagged_Rock01" is in short form, which is unsupported and -- even if valid -- resolving it will be really slow. Please consider resaving package in order to speed-up loading.

I know there is a lot of them, but try resaving these assets. Maybe resave a batch of them and then check a new crash log to see if they are included.


Do you still have the 4.10.4 version of your project? I'm just making sure that you didn't convert in place or anything.

Unless you need a feature or bug fix from 4.11, you could stay and develop in 4.10.4 for the time being.

avatar image Xaragoth Apr 01 '16 at 09:06 PM

I still have my 4.10.4 ver, yeah. I was hoping to switch to 4.11 since I had some memory leak issues with 4.10 and the new performance improvements. I'll just finish this up in 4.10.4 and then start a new project with 4.11, I guess. It's not that much more to adjust.

But I'll try saving the packages that are out of date. It's quite a bunch indeed. I'll see if that helps, just for future reference :)

avatar image Xaragoth Apr 02 '16 at 04:55 AM

I have managed to nail it down to the foliage actor causing the crash somehow. If I hide it, the level works fine

Not entirely sure how yet, since it works fine in 4.10.4 - any ideas of what changed would be welcome.

Edit: I've managed to narrow it down to the icicles I used inside the cave. I still have no idea why exactly they break UE4.11 though.

Edit2: https://dl.dropboxusercontent.com/u/53255048/CrashLog2.log New log

Edit3: Icicles work fine in other maps. Must be something about the amount of them used in the foliage that UE4.11 can not handle somehow. Any ideas?

Edit4: Crash unrelated to numbers. As long as any of them still exist in the level, it breaks. However, painting new ones after deleting the old ones works fine. Potentially related to light build. Gonna test that after I wake up.

avatar image TJ V ♦♦ STAFF Apr 05 '16 at 07:26 PM

Hmm, it sounds like either the asset or the level has become corrupted. Likely the level since the asset works fine in other levels.

Let me know what the results of your light building tests are.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I attempted to move your last comment to an answer in order to resolve this post, but it looks like AnswerHub lost it for whatever reason. So I am reposting your response from my email notification:

No influence, sadly. Tried anything I could think off, in the end only delete worked.

Well, not about to repaint the entire cave assets just because of this. Gonna finish it up in 4.10.4 and be done with it.

I'm sorry we couldn't find a better solution. It is sometimes difficult tracking down the exact cause when dealing with assets that have possibly become corrupted. Internally when we have seen these errors, resaving the assets have fix them for us so far.

Cheers,

TJ

more ▼

answered Apr 07 '16 at 05:27 PM

avatar image

TJ V ♦♦ STAFF
41k 1009 183 494

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question