x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

NavMesh resolution problem?

Hi, i got a team of npc that should get cover from enemies, and i marked the cover points with some TargetPoint-derived blueprins, and placed them near some obstacles, but i noticed that the navmesh around those obstacle is kinda low-res, i mean that some cover point are actually out the navemesh of just some centimeters even if are 50cm from the obstacles. My npcs got to the cover point just for the acceptable range of the Move BT node, i think.

I found the Cell (horizontal) Size value in the project settings, and lowered it from 19 to 10 to get amore precise navmesh, but even if now all the cover points get into the navmesh my npc don't even move to get to them, and i don't understand.

Moreover, if i reset the cell size back to 19, my npc still not move.

Is this a bug?

Product Version: UE 4.9
Tags:
more ▼

asked Apr 01 '16 at 09:41 AM in Blueprint Scripting

avatar image

fudo
109 7 23 28

avatar image fudo Apr 01 '16 at 09:53 AM

I also found this: alt text (navmesh cell size 5) it looks to me like 2 navmesh triangles are averlapping or sort of.

another bug?

navmesh_bug.png (72.3 kB)
avatar image fudo Apr 01 '16 at 10:12 AM

Now i tryed lowering the vale of Agent Radius to 20, but this too made my npcs not move, even raising it back to 34.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question