x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AI not respecting navmesh in UE 4.11

Hi. I have recently updated my project from UE 4.10 to 4.11. In my game, the character is followed by an enemy AI. When it is near it, it plays atack animation and the character falls, and the game restarts. Now, when the enemy sees my character, it goes towards it. If my character goes near a fire, there is no navmesh in there, so the AI considers that he doesn't see my character anymore (in AI Move to node- On fail execution line triggers), so he finds another random point in the map to go. In UE 4.10, this worked well. In UE 4.11, it doesn't work anymore. The enemy ignores the fact that there is no navmesh around the fire, so he goes towards my character, altough it wasn't supposed to.

The fire blueprint has a NavModifier component, with Area Class set to NavArea_Null. Also, it also contains a big cylinder around all other components, that has collision preset set to overlap all. How to solve this problem ? Is this a bug or some AI system changes that require a different workflow ?

Here is my AI Blueprint alt text Also, here is an overview of the map with navmesh alt text

Product Version: UE 4.11
Tags:
more ▼

asked Apr 01 '16 at 01:16 PM in Bug Reports

avatar image

mahri726
51 3 9 13

avatar image mahri726 Apr 01 '16 at 01:21 PM

I have attached the blueprint picture again because of bad quality. alt text

ainavbug2.jpg (1.8 MB)
avatar image Sean L ♦♦ STAFF Apr 01 '16 at 03:27 PM

Hello,

  • Are your events still firing as they were in 4.10?

  • Have you checked the blueprints containing the nav modifiers to ensure that none of the settings were changed during the upgrade?

  • Just to clarify, the issue you are reporting is that the AI is not respecting the Nav Modifier volume, correct?

avatar image mahri726 Apr 01 '16 at 07:15 PM

Yes, it is not respecting it, as long he follows the character. I have noticed that normally, when the the character is inside a Nav modifier volume (besides a fire), altough the AI sees it, he doesn't follow it. So far, so good. If the character is outside a nav modifier volume and the AI sees it, he starts to follow it, as expected. However, while being followed, if the character enters a nav modifier volume, the AI ignores the volume, and goes for the character.

I'm not sure if they're still firing as in 4.10, since because of low storage, I had to uninstall 4.10.

I don't remember seeing anything different, except the fact that the navmesh looked like that: alt text So I had to delete the blueprints in the scene and put them again from content browser, in order for the restricted area to be square.

avatar image Sean L ♦♦ STAFF Apr 05 '16 at 05:59 PM

After you replaced the blueprints, were they still not functioning properly?

Have you been able to reproduce any inconsistencies with the NavMesh in a clean 4.11 project that hasn't been converted? I've performed some tests on my end, and I have not had any issues at this time.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello,

I am marking this topic as resolved for tracking purposes, as we have not heard from you in a few days. If this issue persists, feel free to respond to this thread. For any new issues, please create a new Answerhub topic.

Have a great day

more ▼

answered Apr 11 '16 at 01:13 PM

avatar image

Sean L ♦♦ STAFF
43.6k 485 152 442

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question