x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editor crashing when sculpting terrain (after 4.11 update).

Hey everyone, We updated our engine to 4.11 and everything went fine except for now I will have an instant crash whenever I try to sculpt my landscape terrain in several large locations. It works just fine on some other landscapes within the same level, and I can even sculpt on some areas of this large landscape, but in two main areas that I really need to be able to sculpt in, any sculpting tool will cause the crash.

I had this issue previously on this same landscape but it was limited to one very small location and it was never consistent, now my issue seems to have grown to be 100% consistent within several very large sections of the map.

I was originally getting this crash when I would paint on one location that I had originally tried to use the visibility tool on, so I'm guessing it might be related to that and the reason why I can sculpt in some areas and not others is due to the component separation. I never spent the time to actually setup the visibility within the material for the landscape, so I just tried to remove any "visibility sculpting" I had done by making a large brush and holding shift to remove it on the areas I had originally tested it on.

Any ideas? Everything was going fine yesterday up until I updated my engine to 4.11 :(

Thanks for your assistance!

Here is the crash log xml:

 <?xml version="1.0" encoding="UTF-8"?>
 <FGenericCrashContext>
 <RuntimeProperties>
 <CrashVersion>3</CrashVersion>
 <CrashGUID>UE4CC-Windows-4F4D58424095BD9357B0ADA89AC11B5A</CrashGUID>
 <ProcessId>8512</ProcessId>
 <IsInternalBuild>0</IsInternalBuild>
 <IsPerforceBuild>0</IsPerforceBuild>
 <IsSourceDistribution>0</IsSourceDistribution>
 <SecondsSinceStart>35</SecondsSinceStart>
 <GameName>UE4-World_of_Origin</GameName>
 <ExecutableName>UE4Editor</ExecutableName>
 <BuildConfiguration>Development</BuildConfiguration>
 <PlatformName>Windows</PlatformName>
 <PlatformNameIni>Windows</PlatformNameIni>
 <EngineMode>Editor</EngineMode>
 <EngineVersion>4.11.0-2927265+++UE4+Release-4.11</EngineVersion>
 <CommandLine>&quot;C:\p4\WorldOfOrigins\World_of_Origin.uproject&quot; </CommandLine>
 <LanguageLCID>1033</LanguageLCID>
 <AppDefaultLocale>en_US</AppDefaultLocale>
 <IsUE4Release>1</IsUE4Release>
 <UserName></UserName>
 <BaseDir>C:/Program Files (x86)/Epic Games/4.11/Engine/Binaries/Win64/</BaseDir>
 <RootDir>C:/Program Files (x86)/Epic Games/4.11/</RootDir>
 <MachineId>A5EAB9B544D4D854D327BFBB0EBE207F</MachineId>
 <EpicAccountId>4d3ab1890b28433489a7650eac8811a1</EpicAccountId>
 <CallStack></CallStack>
 <SourceContext></SourceContext>
 <UserDescription></UserDescription>
 <ErrorMessage>Assertion failed: (Index &gt;= 0) &amp; (Index &lt; ArrayNum) [File:D:\BuildFarm\buildmachine_++UE4+Release-4.11\Engine\Source\Runtime\Core\Public\Containers\Array.h] [Line: 785] &nl;Array index out of bounds: -460183 from an array of size 15&nl;</ErrorMessage>
 <CrashDumpMode>0</CrashDumpMode>
 <Misc.NumberOfCores>4</Misc.NumberOfCores>
 <Misc.NumberOfCoresIncludingHyperthreads>8</Misc.NumberOfCoresIncludingHyperthreads>
 <Misc.Is64bitOperatingSystem>1</Misc.Is64bitOperatingSystem>
 <Misc.CPUVendor>GenuineIntel</Misc.CPUVendor>
 <Misc.CPUBrand>Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz</Misc.CPUBrand>
 <Misc.PrimaryGPUBrand>NVIDIA GeForce GTX 980 Ti</Misc.PrimaryGPUBrand>
 <Misc.OSVersionMajor>Windows 10</Misc.OSVersionMajor>
 <Misc.OSVersionMinor></Misc.OSVersionMinor>
 <MemoryStats.TotalPhysical>34287259648</MemoryStats.TotalPhysical>
 <MemoryStats.TotalVirtual>140737488224256</MemoryStats.TotalVirtual>
 <MemoryStats.PageSize>65536</MemoryStats.PageSize>
 <MemoryStats.TotalPhysicalGB>32</MemoryStats.TotalPhysicalGB>
 <MemoryStats.AvailablePhysical>25004756992</MemoryStats.AvailablePhysical>
 <MemoryStats.AvailableVirtual>140732743647232</MemoryStats.AvailableVirtual>
 <MemoryStats.UsedPhysical>2591727616</MemoryStats.UsedPhysical>
 <MemoryStats.PeakUsedPhysical>2591727616</MemoryStats.PeakUsedPhysical>
 <MemoryStats.UsedVirtual>3740741632</MemoryStats.UsedVirtual>
 <MemoryStats.PeakUsedVirtual>3848081408</MemoryStats.PeakUsedVirtual>
 <MemoryStats.bIsOOM>0</MemoryStats.bIsOOM>
 <MemoryStats.OOMAllocationSize>0</MemoryStats.OOMAllocationSize>
 <MemoryStats.OOMAllocationAlignment>0</MemoryStats.OOMAllocationAlignment>
 </RuntimeProperties>
 <PlatformProperties>
 <PlatformIsRunningWindows>1</PlatformIsRunningWindows>
 </PlatformProperties>
 </FGenericCrashContext>
 

Product Version: UE 4.11
Tags:
more ▼

asked Apr 01 '16 at 08:02 PM in Bug Reports

avatar image

tsnodgrass
56 3 8 12

avatar image AndrewHurley Apr 03 '16 at 04:44 PM

Hey tsnodgrass,

I have a few questions that will help me resolve this issue. Firstly, can you reproduce this crash in a new blank project of 4.11 using a simple landscape?

The areas of the landscape that are causing you to crash, have those component sections of the landscape been removed and re-added at any point?

Could you also provide me with some screenshots so I can visualize the issue you are reporting?

If you cannot reproduce this in a blank project, but can get the crash to occur in your own consistently, please take a look at our How to Report a Bug sticky on the forums.

It will provide you with all the necessary instructions when reporting a crash/bug so we can efficiently troubleshoot your issue.

Let me know if you have further questions.

Cheers,

Andrew Hurley

avatar image tsnodgrass Apr 06 '16 at 12:03 AM

Hey Andrew, I ended up just exporting the heightmap and the material masks and reimporting everything, all I lost was the vegetation placement which wasn't much anyways so it was easy to repaint the veg instances.

It was definitely an issue with the specific terrain itself, no more crashing since I re-built it with the exported heightmap and material masks for the landscape. Even when I would copy/paste the terrain into a new map with no material applied, same issue would cause a crash.

For now I need to keep on track with my project, but if this issue comes up again I will definitely provide screenshots and more specific information to troubleshoot it.

Thanks for your assistance, -Trystan

avatar image TerrainCreator Apr 08 '16 at 06:44 PM

So i have been having this same issue and have dug into it a bit more. It seems that in 4.11 there was some sort of update conflict with the foilage tool. Crashes Upon scene opening if the scene was created in 4.10 and sculpting while having foilage within the scene in 4.11 is causing the engine to just freeze and crash. Now unfortunately there is no way for us to fix this until Epic sort this issue out and make an engine update.

My advice is for now until it's fixed is don't add any foilage to your scene until your finished sculpting your terrain. I have tested the sculpting without foilage and it worked perfectly fine. the moment i added foilage and sculpted it crashed instantly. If your using 4.11 and are/have a scene that was made in 4.10 the only way i have found to get the scene open is to delete all the models that the foilage tool is referencing. i have tested this and the scene did open and play without any crashes. now since your deleting the model and not the data on the landscape once Epic fixes this issue just add the models back in and all the painted data will still be there. Allowing you to edit the scene and play it and fix some stuff while we wait on a fix for this foilage tool issue.

I hope this helps in any way to anyone experiencing this same issue in 4.11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Just for reference and tracking purposes, a bug has been entered for this issue (UE-29052). It has actually been marked as fixed for 4.11.2 hotfix which I will verify is fixed in that build. I will return here with an update once I have completed my testing.

We appreciate your patience with this issue as I know this one in particular is a bit of a workflow blocker. Let me know if you have further questions or need additional assistance.

Thank you,

Andrew Hurley

more ▼

answered Apr 08 '16 at 07:10 PM

avatar image Tendogames Apr 14 '16 at 11:32 AM

I had same problem, today the editor crashed 2 times while trying to sculpt the landscape. UE4 4.11.1 The landscape has foliage applied, painted manually in the terrain. One of the crash it also crashed the map to not load anymore, and nothing worked, even the backup saved were destroyed from the previous crash. Had to restart all over again.

avatar image tsnodgrass Apr 18 '16 at 09:25 PM

So this error is definitely still happening for me, it seems to only occur where I have placed vegetation onto the terrain. It is not affected by using the procedural grass, but just the regular foliage instances painted onto the terrain in foliage mode.

Right now my only solution for this(while waiting for the hotfix) is to remove any foliage in a specific location that I want to sculpt the terrain and make any changes needed, then go in and paint the foliage when I'm satisfied with the terrain.

avatar image AndrewHurley Apr 19 '16 at 02:03 PM

Once the 4.11.2 hotfix is released, test in that build and verify it no longer occurs. It is scheduled for today, so be on the lookout.

Cheers,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question