x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cpp hot reload button disappears

Hello !

I have a trouble with the Cpp hot reload button : it disappears each time I use it. I open the editor the button is live and after the first hor reload the button disappears and the editor doesn't reload the code. (my cpp functions aren't in bp.)

This problem happens only since I updated to 4.11.0 (today). My project was a blueprint project and I added a Cpp library after to add some functions that don't exist in bp natively.

thanks for reading !

Product Version: UE 4.11
Tags:
more ▼

asked Apr 01 '16 at 09:00 PM in Bug Reports

avatar image

mdonge
820 30 11 32

avatar image Doug E ♦♦ STAFF Apr 02 '16 at 03:21 PM

Hey mdonge-

Could you clarify a few things to help me test the issue you're reporting. What exactly do you mean by a Cpp library? Are you adding a new class based on Actor/Character/GameMode/etc.? What functions/code did you add to the code class? When preforming the hot reload, are you compiling from Visual Studio or using the in-editor compile button? Let me know if there is any other information you can provide that will help me reproduce the bug locally.

Cheers

Doug Wilson

avatar image Morgrhim Apr 02 '16 at 11:03 PM

Since I don't have an answer, I'll add that I'm experiencing this issue. I'm using a C++ blank project, and if I build in VS2015 by right-clicking on my project and choosing build, the Compile button in the Editor disappears and the editor doesn't seem to register the code changes. I've had this happen when both making a class based on Character and one based on Actor Component. I may try a few other base classes, but it seems to happen any time I build in VS2015. If I use the editor compile button everything works as expected.

Also, on the button disappearing, if I reload the project from the launcher it works fine again.

avatar image mdonge Apr 02 '16 at 11:28 PM

Hello !

So it's a blank blueprints based project. I add then Cpp code in the editor and created a Blueprint library based. there is only function I can' find in native BP.

The hot reload button in the editor, which worked until v4.11.0 seems to be broken because there is no hot reload (deleted function in the Cpp code are still there), and the button disappears just after that.

When I restart the editor, the button is there again but same behavior.

When I compile from VS2015 and then restart the editor, the code is loaded. I don't know if it's more explicit ;)

Thanks !

avatar image Doug E ♦♦ STAFF Apr 04 '16 at 01:54 PM

I tried to create a new project and add a class based on Character and Actor Component however I did not lose access to the compile button when preforming a hot reload. Does the button disappear each time you compile? Can you let me know if forcing a hot reload by creating a new class and adding a comment breaks the compile button as well?

avatar image Morgrhim Apr 04 '16 at 03:07 PM

When y ou say hot reload, are you referring to the compile button? I lose when build in VS. Not when using the button. And yes, I lose it every time I do this, without fail. I can add Pawn and GameMode to the classes that I've built from that do it.

avatar image Doug E ♦♦ STAFF Apr 04 '16 at 07:21 PM

A hot reload occurs when using the in-editor compile button or when building using Visual Studio with the editor still open. If possible, please create a new class. Doing so will trigger a hot reload in the editor. Please let me know if this causes the compile button to disappear. Also, if you edit this new code class and compile again (either in the editor or VS with the editor open) does this break the compile button as well?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

So I tried to add a new cpp actor, the button "compile" in unreal doesn't disappear anymore, even after deleting the new empty actor ...

Problem resolved for me ! Thanks !

more ▼

answered Apr 05 '16 at 08:43 AM

avatar image

mdonge
820 30 11 32

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question