x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

4.11 fails to load map from 4.10

I recently upgraded a project from 4.10 to 4.11. It seems that my map is not loading for some reason, and causing an exception to be thrown and crashing the engine. If I run the editor, it gets stuck at loading around 93-94% and after 20-30 seconds it crashes. If I set the startup map to nothing, the editor loads but ends up doing the same thing if I then try to load that map. The map worked fine in 4.10.

I attached the VS debugger to see if there was any further information. As soon as loading gets stuck, this appears in the log:

[2016.04.01-23.24.45:327][ 0]LogFileManager:Warning: ReadFile failed: Count=0 Length=1128349575 Error=Overlapped I/O operation is in progress. for file Path/To/My/Map.umap

When the exception is thrown, this appears:

Exception thrown at 0x00007FFFF9DAC88C (vcruntime140.dll) in UE4Editor.exe: 0xC0000005: Access violation writing location 0x0000015177230000.

Here's the callstack:alt text

Other info:

OS: Windows 10 x64

Configuration: Tried this in both DebugGame Editor + Development Editor, both have the same result.

EDIT:

I was able to load a couple of other maps that are used for the main menu, but the level where I actually have gameplay is a no-go. The level that doesn't load contains a decent amount of matinee stuff and the level blueprint is used a bit. Not sure if that would be the cause but I figured I'd throw as much info as possible here.

EDIT 2:

It seems that this happens even if I so much as right click on the map in the content browser. I assume the engine loads details for the right click menu, but there's something that ends up freezing the editor and eventually crashing it. The line of the crash ends up being in the same function but on line 54 rather than 38.

Product Version: UE 4.11
Tags:
more ▼

asked Apr 01 '16 at 11:35 PM in Bug Reports

avatar image

redxdev
68 4 10 21

avatar image Doug E ♦♦ STAFF Apr 04 '16 at 06:40 PM

Hey redxdev-

Based on the description it sounds as though either the map or an asset referenced by the map has become corrupted. Please try deleting the saved and Intermediate folders from the project and see if the map will open then. If the map still doesn't open, try to migrate the working 4.10 version of the affected map to a new 4.11 project and see if it will open there?

Cheers

Doug Wilson

avatar image redxdev Apr 04 '16 at 07:47 PM

Removing Saved + Intermediate didn't work. I'll get back to you on migrating the map.

avatar image redxdev Apr 04 '16 at 07:52 PM

Migrating the map into a blank 4.11 project from 4.10 worked just fine. Makes me think it might be something to do with my code. Obviously the new project doesn't have access to my C++ stuff, so I'm thinking that might be preventing it from loading? I'm not really sure how to troubleshoot that issue.

EDIT:

Did some digging in the debugger, it seems to be failing on a TextRenderComponent in UStruct::SerializeTaggedProperties. I'm going to see if I can figure out exactly what object is causing the issue.

avatar image Doug E ♦♦ STAFF Apr 11 '16 at 02:08 PM

Hey redxdev-

Have you had the chance to investigate which object is giving you the TextRenderComponent error? If you're still having problems opening the project in 4.11, can you send a copy of the 4.10 version of the project so I can test the conversion locally? If you're able to zip the project you can either attach it to a post here or upload it to google drive/drop-box and send me a download link on the forums for privacy.

avatar image redxdev Apr 11 '16 at 08:35 PM

Honestly, I'm at a bit of a loss for what is causing it. The only thing that has a TextRenderComponent as far as I'm aware works perfectly fine if I put it in a new map. I'll send you a link to the project on the forums in a bit.

avatar image Doug E ♦♦ STAFF Apr 12 '16 at 02:28 PM

I opened the project you sent in 4.10.4 however I received a compile error stating that Zom is an undeclared identifier at the GENERATED_BODY() line of PlayerStart.h when trying to build the .sln in the 4.11.1 binary engine.

avatar image redxdev Apr 12 '16 at 05:53 PM

Whoops, I actually had that fixed but reverted back to the 4.10 version. I'll have the fixed version to you in a bit.

avatar image Doug E ♦♦ STAFF Apr 14 '16 at 03:28 PM

After downloading the updated project and immediately upgrading from 4.10 to 4.11 and building did in fact give me the same crash you mentioned. When I tried to revert back to 4.10 I got the same errors about the GENERATED_BODY() line.

Since I am having difficulty testing from one version to another, can you try opening the 4.10 version and setting the default loading map to a level other than NineRooms and then convert to 4.11. If you're able to open the project in 4.11 after this, also let me know what happens when you double click the NineRooms map or right click on the asset in the content browser?

avatar image redxdev Apr 14 '16 at 04:30 PM

I also had some errors about GENERATED_BODY() when compiling with one and then switching to another version, but those were caused by the compiler apparently using old project files or something. I fixed those by deleting the sln + sdf files, along with the Build, Intermediate, and Binaries directories. Just make sure to delete those directories + files and then regenerate the project before trying to compile again.

I changed the startup map to something else, and the editor launches just fine. Double clicking on NineRooms causes the same issue as I've noted in my original post: The loading bar comes up, gets stuck for about 20-30 seconds, then crashes the editor with no error message. With a debugger attached (and the configuration set to DebugGame Editor) I get a break at the same line as above as well.

I also want to note that even so much as right clicking on NineMaps will crash the editor (it'll freeze for a while and then crash). It'll bring up a "Loading Objects..." message, freeze for about 20-30 seconds, then crash (a debugger attached will show that it crashes on the same line as when you try to load the map).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

After swapping between the 4.10 and 4.11 versions, it appears that one or more of the assets in the NineRooms level is corrupted and causing the level to not open properly. An easy solution to narrow down which asset is causing the problem would be to convert the project from 4.10 to 4.11 and then remove the Content folder from the project (cut/paste to desktop for example). Open the project and see if the level will open at this point. If the level loads then you can slowly start bringing assets from the Content folder back into the project, reopening the level each time to determine exactly which asset is causing the problem.

more ▼

answered Apr 14 '16 at 06:05 PM

avatar image redxdev Apr 14 '16 at 06:55 PM

Huh, didn't think of that. Yeah, the map loads when I remove other content. I'll try to narrow down what was causing the issues. Thanks for the help!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question