x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Blueprint replication problems on transition to 4.11

I have converted my project to from 4.10 to 4.11 and most of the things works smoothly (with performance increase, yey!) but I am having an issue with networking. Whenever I play in editor with 2 clients, I get a full crash. I debugged the code, and the error occurs at:

RepLayout.cpp, line 2209 check( Property->PropertyFlags & CPF_Net );

Basically, some replicated properties are uninitialized, probably because replication changed in Character C++ classes. The error occurs for my main character actor. My setup is as follows: Character -> ClassBase (C++) -> BP_ClassBase (BP) -> BP_Fighter (BP).

The error goes away when I open BP_ClassBase and recompile, but it is still there the next time I run it. Is there any way to permanently fix the rep layout on Blueprint objects? (I cannot recreate blueprint classes, they are HUGE).

Best, Ziga

Product Version: UE 4.11
Tags:
more ▼

asked Apr 02 '16 at 09:02 AM in Blueprint Scripting

avatar image

ziga.osolin
206 9 12 76

avatar image ziga.osolin Apr 05 '16 at 09:37 AM

I did some further testing: the error only occurs with PIE, not in packaged builds. Also, it appears not only for character but (somewhat randomly) for blueprints that use inheritance. For example, it also happens in all my projectile classes (again, the structure is Actor -> Spell (C++) -> BP_Projectile -> BP_CosmicShards). Still haven't found a workaround this issue, it is really frustrating because I cannot recompile all those blueprints every time I open the editor, they are too many.

Should I insert call stacks and debug issues, or try to reproduce this on simpler projects? Could it be the problem when switching versions only?

avatar image adipFTW Apr 29 '16 at 12:12 AM

Hey, I'm experiencing this issue as well, however it was not after switching engine versions. Up till recently we had a blueprint-only mulitplayer game, but since we want a dedicated server, we need to add c++ to the project. After doing that i restructured quite a lot inside the project and that was when this crash occured.

We believe it's related to inheritance when combining blueprints and c++ and I'm currently rolling back to track down possible reasons. I'll let you know if i find anything useful!

avatar image ziga.osolin Apr 29 '16 at 08:01 AM

Yes, it has something to do with how C++ and Blueprints interface but, if this helps, the issue was not present in 4.10. I merely switched to 4.11 with the same code, and the issue is there. It could be you did something similiar to mine code when refactoring for C++ support. I hope you have luch reconstructing the issue, it is impossible with my code base unfortunately.

avatar image CodeSpartan Apr 29 '16 at 06:24 PM

+1. I have the exact same problem, only my setup is a bit different: my classes that inherit from Character are all blueprint classes (no C++ class among them).

avatar image Darthlatte Apr 30 '16 at 11:34 AM

+1, Same problem here. With code upgraded from 4.10 to 4.11. I'm trying to replicate a variable in a character BP, and the editor crashes straight away with PIE.

RepLayout.cpp, line 2209 check( Property->PropertyFlags & CPF_Net );

avatar image adipFTW May 05 '16 at 09:58 AM

Addendum: After reverting to blueprint only i kept working with it, but now the error has shown up again, this time no c++ or version switching is involved...

Can I provide anything to figure out what the problem is? Unfortunately I dont even know what causes the problem, i just know the blueprint from the VS break when the editor crashes.

avatar image Dertzack May 12 '16 at 05:10 PM

+1, I am having the same problem and yes, my code is upgraded from 4.10 to 4.11, it just began to happen yesterday, even though I upgraded it as soon as it launched and I already had raplicated elements.

avatar image Terpsychore Jun 02 '16 at 07:44 PM

+1. I'm running into the same problem. Has anyone found a solution to this yet, or know if it's been addressed in 4.12? I've read through the patch notes as best I can, and nothing is really popping out at me.

avatar image Footman Jun 12 '16 at 07:10 PM

got same problem after converting to 4.11 to 4.12. additionaly my character_BP child mesh component values reset now. Happens only in editor but not in standalone game. So much bugs in new version.

avatar image KAISERslin Jul 01 '16 at 06:12 AM

I can confirm this. But my mesh components are copied on the childs.

avatar image S. Jonischkeit Sep 08 '16 at 07:09 AM
  • the Error Appeard after the Upgrade from 4.12 to 4.13 and only if I am playing in multiple PIE Windows (Number of Players > 1). No crash if I open one instance of PIE nore in the Build version.

I got a workaround by making minor changes to the derived classes so that the Engine realiesed that they have changed and want to recompile them. The result is that I can start the Project with 2 or more (in my case 3) instances of the PIE window. Everything works fine again. But when I close the Engine (using the close Buttons of the Engine itself, saving all changes) and reopen it, the error appears agian.

I tried to duplicate the dreived classes and delete the original once, but tthat did not fix it either.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question