x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

How to get a widgetbutton working over network?

Greetings.

I started working with Unreal Engine about a week ago. My goal is to make a RPG Multiplayer with different interactions. I'm still learning and getting used to it. Anyways normally I'm figuring out problems myself, but this time I need some help.

So here is the thing:

I have done a simple System where the blueprint gets the cursor breakresult when hovering over an actor with the prefix A so i can simply add more actors that are interactable later.

Then a 2 button widget pops up into the screen asking if you want to Take, Drop (or whatever) the Item. So far so good, with a Event Dispatcher i can manage to print a String when pressing the button, but the thing is i want it to be replicated. But everytime i try to replicate it, no matter how I try, I get the String printed as: Client -2: "Text"

I'm probably missing something pretty easy i just dont know it.

Here is my PlayerController Blueprint

alt text The Widget is just an empty button now because i deleted the wrong solution. It was just a simple Event Dispatcher called from the widget and used inside the PlayerController to print the String, with a custom event put on multicast. But then I always get Client-2 and nothing's working after that. I tried with Destroy Actor but it didnt go off.

Oh and yeah i know that i should have tried it with HasAuthority but you cant call that inside a widget as it seems. alt text

Product Version: UE 4.11
Tags:
actionmenu.png (24.6 kB)
more ▼

asked Apr 02 '16 at 01:55 PM in Blueprint Scripting

avatar image

W4uLi
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

-push- after 3 days

more ▼

answered Apr 05 '16 at 05:48 PM

avatar image

W4uLi
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question