x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Various Issues Moving To 4.11

Ok, the title might not be the most expressive one. But as soon as we moved to new version (from 4.10.4 to 4.11.0) we had the following issues.

1-) If editor crashes or becomes unresponsive for some reason, restarting it changes the size / scale of editor UI. (This might be acceptable by itself since editor was not terminated properly. Moving on.)

2-) Compile times after minor changes (sometimes even with no changes at all) is greatly increased. Sometimes I get over 1 - 1,5 seconds. (In previous versions, this value never exceeded over 400ms, tops.)

Seems like this is not the case when a new blank project is created. Compile times seem nominal.

3-) Mouse X and Mouse Y events are no longer giving any other value than 0.0. Tried with various pawns, player controllers even tried creating new custom axis mappings. Same thing.

Again, this is not the case when a new blank project file is created.. Issue only seems to happen in our existing project.

4-) Attempting some workarounds, going through some trials and errors, I did something like this at some point: alt text

And having this script in PlayerController class then attempting to compile it always ended up engine becoming unresponsive.

I attached my DxDiag Log as well in case it may be useful. This is all I could spot at first glance of new version.

Issues mostly seem to be originating from our project files really. If anything else comes up, I will update my post.

Also, I am willing to provide additional information if staff requires me to do so.

Have a great day.

Product Version: UE 4.11
Tags:
02a.png (231.5 kB)
dxdiag.txt (64.6 kB)
more ▼

asked Apr 02 '16 at 02:24 PM in Bug Reports

avatar image

onuryurdupak
92 6 8 13

avatar image Rudy Q ♦♦ STAFF Apr 04 '16 at 03:49 PM

Hello onuryurdupak,

I have a few questions for you that will help narrow down what issues you are experiencing.

Quick questions:

  1. Can you reproduce these issues by upgrading a clean project?

  2. If so, could you provide a detailed list of steps to reproduce them on our end?

  3. Could you provide screen shots of any blueprints needed to reproduce these issues on our end?

  4. When updating to a new version of the engine, does deleting your Saved, intermediate, and config files before updating (be sure to make copies so that you do not lose backup files) prevent any of the issues mentioned?

Additional info:

The issue dealing with the mouse X and Y is a known issue (UE-28960).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Rudy,

Can you describe what do you mean by "upgrading to clean project", does it mean transfering existing project files to a new project directory? Or something else?..

Btw, these issues started occuring after we upgraded our project through launcher. I tried creating a new blank project and transfering contents from old project directory to new one. Many of the problems we had are non-exisent at the moment (since doing this).

What I have described as number 4 was an attempt to make a temporary workaround for mouse event problems and it has gone away as well. (Editor becoming unresponsive upon clicking "compile")

Only remaining problem for us seems to be the one that is related to mouse events. Anyway If I can provide any kind of further assistance, please let me now.

Btw, is UE-28960 related to engine version upgrades? I mean do only people who have upgraded their projects have this problem or pretty much anyone who uses version 4.11.0 regardless of having their project upgraded or not?

more ▼

answered Apr 04 '16 at 08:48 PM

avatar image

onuryurdupak
92 6 8 13

avatar image Rudy Q ♦♦ STAFF Apr 05 '16 at 08:24 PM

To answer your first question:

What I was asking, was can you create a new project in 4.10 and then upgrade it to 4.11 and still reproduce the issues that you are having?

As for UE-28960:

This issue does not appear to be exclusive to those who have upgraded to 4.11.

I am happy to hear that the rest of your issues have been resolved. With this being the case it appears that you no longer need assistance (feel free to reopen if that is not the case). I will be marking your last comment as the answer. However, if these issues return please feel free to reopen this issue with a reply containing any additional information on how to reproduce this issue on our end and I will be happy to assist you further.

Make it a great day

avatar image onuryurdupak Apr 05 '16 at 09:57 PM

Thanks for your interest in this. Have a great day as well.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question