x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Missing UE4 options in drop down menu

Hi

I've made a fresh installation of Windows 10 Home, UE4 and Visual Studio Community 2015.

I've noticed in Windows Explorer that my .uproject file is only 1KB size and when I right click on it, the UE4 options don't appear in the drop down menu.

alt text

I do not recall having this problem with version 4.10 of Unreal Engine. This is how it should look like:

alt text

Any idea of what may be the cause of this?

Product Version: UE 4.11
Tags:
testproject.png (46.9 kB)
more ▼

asked Apr 02 '16 at 06:57 PM in Installation & Setup

avatar image

Almanzor
11 3 4 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello Almanzor,

It seems as though, for some reason, the .uproject files for 4.11 aren't being associated with the engine itself. To fix this, you should be able to right-click the .uproject file in question, select "Open With" and then if Unreal Engine isn't listed in the next window, press Browse and navigate to your installation for 4.11. My path is as follows, for reference:

C:\Program Files\Epic Games\4.11\Engine\Binaries\Win64

Once at that location, select UE4Editor.exe and it should associate those .uproject files with that version of the engine. If it doesn't work correctly, please let me know what the results were.

more ▼

answered Apr 04 '16 at 01:35 PM

avatar image Matthew J Apr 04 '16 at 03:22 PM

As an addition, after trying this myself (Admittedly on a .uproject file that was already associated, seeing as I wasn't having this issue) the Epic Games Launcher prompted me that some uproject files weren't associated with the correct file, and offered to fix that for me. Let me know if this prompt appears for you. Accepting it should fix the problem on its own if manually setting it didn't.

avatar image Thorp Jul 11 '16 at 04:13 AM

Hi Matthew, I'm seeing the same symptoms in 4.12.5. I've tried associating the .uproject file with the UE4Editor.exe in the 4.12 ...\Win64 directory. The menu remained unchanged. As you stated, when I later opened the launcher, it prompted to "re-associate" the uproject file and the project opens correctly.

For what it's worth, I also tried associating it with UE4Editor-Cmd.exe which also had no effect.

It would be great to generate the visual studio files with a right click, but I'd be happy to use any other method that you could provide.

My OS is Win10. VS is VS15, Community. Presently using UE4 prebuilt (not DL source). I was able to generate VS project files under 4.11.

Note- This entry is now OBE. The menu is now working for me. See the posted answer for the full description.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I was able to bring up Generate project files in the menu by following Mathew's answer BUT when I right clicked Open with I was presented with three versions of unreal. Only one had a blue icon (the others were black). When I chose the blue one it opened the project in 4.12. Subsequently right clicking the menu produced the Generate project files option. Many thanks Matthew for pointing me in the right direction!

more ▼

answered Jul 12 '16 at 08:19 PM

avatar image

Thorp
16 1 5 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question