x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Actor-Variable is setting to "None" when any other variables in a Struct are being changed.

I have encountered a behaviour I don't understand, so I assume it's a bug or maybe someone can explain this to me and how I fix it:

I am using a struct named MyStructure for testing with just two variables:

  • MyChildActor (Actor)

  • MyRandomString (String)

I have the following blueprints:

MyClassActor

  • Has MyStructure set as array and is exposed.

MyActor

  • Has MyClassActor set as parent class

  • Has 2 child actor components

  • Has a function to clear and then add items to the MyStructure-Array based on the child actor components, passing the MyChildActor in the MyChildActor-Variable of each array

MyChildActor

  • Is used to fill the child actor components of MyActor

Now when I use the function to automatically generate the arrays everything works fine, but as soon as I change any variables exposed in the MyActor blueprint in the level, the variables MyChildActor of each array in that particular blueprint actor reset to "None", while all other variables work as expected and aren't resetting.

Reason I am trying to save the MyChildActors in the struct is so I can use another blueprint to run a function in these, which doesn't work because they keep resetting for some reason.

The ID of the child actor components seem to stay exactly the same, so I don't get why they are resetting when I change any other variables in that array, while those other array variables stays the same (As seen in the screenshot). Using the eyedropper to select the child actor component again doesn't work either when any variables are changed.

alt text

Product Version: UE 4.11
Tags:
1_mystructure.png (48.5 kB)
2_myclassactor.png (145.3 kB)
3_myactor.png (350.7 kB)
4_myactorfinder.png (310.9 kB)
test.jpg (443.9 kB)
more ▼

asked Apr 02 '16 at 07:36 PM in Blueprint Scripting

avatar image

Fluffberry
11 1 2 4

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question