x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[updated] Active Debug Points not stopping in Level Blue Print

[note] I just added some new info a the end of this post as I just found something out.

Hi, I recently started working with UE4 and I am having this problem in 4.10 and 4.11.

I have added multiple Active Break Points to the Level Blue Print. They also show up in the "Debug Window". And to be sure, I print a string to the editor windows some point after the the Active Break Point. alt text The problem is that the Blue Print is not stopping during execution. I know 100% the node is passed (and I tried it with all nodes) because the sting is printed to the screen. In the beginning, this worked just fine. Then I sometimes had to close the level blue print otherwise the blue print would not stop during execution. That would fix it. In the mean time, I moved to 4.11 and now the level blue print never stops anymore. I do not think this is a 4.11 problem, but perhaps something I did during development? I just migrated all the assets to a new clean project and the blue print stopped just once. Then it never did again.

I know for debugging other blue prints, you have to select the Debug filter, but this is the Level Blue Print, and there is no option to do that. I "deleted all Break Points", but that did not help. What am I doing wrong? Is there something I am missing?

pdate 1 I just found out, that this problem only happens when the "number of players" is larger than 1. I am developing a multi player only game, so that is an important part of the development. Does this mean that active break points do not work for multi player setups? Is there alternates to do this (besides printing debug strings) #####

Update 2 The level blue print stated stopping again at certain times. It just very iffy and inconsistent, how ever, I have noticed that restarting the editor a lot, seems to make it a lot better. I am also getting the "Looks like a wire-trace was not injected" bug all the time (which is "fixed" by restarting the editor) so I guess restarting is the "fix" right now.... a little scary this is happening... #####

Product Version: UE 4.11
Tags:
breakpoints.png (90.2 kB)
more ▼

asked Apr 02 '16 at 09:02 PM in Blueprint Scripting

avatar image

bggangel
31 2 6 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question