x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Force editor to launch VS2013 while VS2015 is installed

Since we're building with PS4 support we need to use Visual Studio 2013 rather than 2015 to build our UE4 project. GenerateProjectFiles.bat recognizes this and generates the correct project files, however while in the editor creating a new C++ class (or trying to edit existing ones) launches an instance of VS2015 instead.

I've hunted all throughout the editor preferences and the only reference to the code editor allows you to set "Visual Studio" as the editor, but there's no ability to specify a particular version of it. Is there perhaps an undocumented command line switch we can pass to the editor to make it use VS2013 instead?

Before anyone suggests it, uninstalling VS2015 is not an option as we use that for other projects that require it.

Product Version: UE 4.10
Tags:
more ▼

asked Apr 03 '16 at 06:39 PM in C++ Programming

avatar image

nnazaroff
6 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I'm having the opposite problem. The editor is launching VS2013, but I need it to launch VS2015. The project files and VS solution file are generated correctly for 2015.

more ▼

answered May 17 '16 at 08:11 PM

avatar image

nzavaglia
6 1 2

avatar image nzavaglia May 17 '16 at 08:12 PM

I'm having the opposite problem. The editor is launching VS2013, but I need it to launch VS2015. The project files and VS solution file are generated correctly for 2015.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Haven't confirmed that this works, but maybe try hacking the build tool to force selection of a particular toolchain?

https://answers.unrealengine.com/questions/31887/visual-studio-2012-on-unreal-engine-402.html

more ▼

answered Jun 15 '16 at 06:52 PM

avatar image

MLPedro
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question