x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Rendering issues with Directional Light in UE 4.11

Update: We found new information about the problem:

alt text

Dear Epic Games,

Our team have encountered a problem in the rendering pipeline. Some "random" black artifacts. We tried to isolate the problem from the whole level and now we believe that the Directional Lighting is the cause of this behaviour together with the material setup. Artifacts appear not only on character meshes, but also on any surfaces (with some material setup), which are oriented as similar to vector of the Directional Light source. Right now we don't understand which Material properties causing the bug. Supposably Reflection/Roughness. And this is not dependent to Subsurface Profile Shader Model (other level props and objects cause this problem too). That's all we investigated for now.

We can send you our isolated test scene if necessary. But only privately. I'm attaching the screenshots of the problem:

alt text

alt text

Pay attention to the Directional Light vector:

alt text

Directional Light (vector) is rotated:

alt text

Directional Light is turned off:

alt text

Thank you!

Product Version: UE 4.11
Tags:
more ▼

asked Apr 04 '16 at 07:25 PM in Bug Reports

avatar image

Dmitry Zorin
21 2 6

avatar image Tim Hobson ♦♦ STAFF Apr 04 '16 at 09:27 PM

Hi Dmitry,

If you wouldn't mind sharing the project I can have a look and see if I can narrow down anything. You can send me a link in a private message on the forums.

I did a quick scene setup using the settings I could see turned on in your details panel and I didn't see the same results. I only used a basic skeletal mesh character though with basic material setups.

-Tim

avatar image Dmitry Zorin Apr 06 '16 at 11:21 AM

@TimHobson I've sent you a private message on the forum. Thank you for your help.

avatar image Tim Hobson ♦♦ STAFF Apr 06 '16 at 01:15 PM

Thank you! I've got the test scene. I worked with it a bit yesterday to try and recreate in a new level, but it wasn't able. It'll probably take a little bit of time for me to debug and also recreate in 4.10 for comparison. Thanks for your patience.

avatar image Dmitry Zorin Apr 06 '16 at 03:24 PM

@TimHobson

I uploaded the version for UE4.10.4 for you to the same address. Let us know if we can provide any further assistance.

avatar image Tim Hobson ♦♦ STAFF Apr 06 '16 at 03:39 PM

oh! That's great and helps a lot!

avatar image Dmitry Zorin Apr 07 '16 at 10:42 AM

@TimHobson

I don't know how the notification system is working here, so I just want to inform you about our progress on our side. Please look to the updated information in this post. Thank you for your time.

avatar image KillerPenguin Apr 05 '16 at 07:30 AM

Having this issue also. I think it's a problem when material roughness is really low. (0 for our case.)

Would be great if Epic fix this soon.

avatar image Tim Hobson ♦♦ STAFF Apr 05 '16 at 02:35 PM

@KillerPenguin

Without additional details it's hard to guess what may be the issue here. If you have a solid repro or a starting point I can give it a shot. Adjusting the Material roughness didn't show anything promising on my end.

A fix can be put in the quicker a ticket is put in.

So if you have anything regarding how the scene is set up like

  • Lighting settings

  • Material graph

  • what makes it happen vs not, such as light rotation, changed settings on your light or assets, etc.

These are just starting points to start investigating. We have a lot of reports coming in and we cannot dedicate an endless amount of time to one issue unfortunately. Any help is greatly appreciated so this can be reported and resolved as quickly as possible.

Thank you!

avatar image Dmitry Zorin Apr 07 '16 at 11:27 AM

@KillerPenguin

Try to increase "Min Roughness" parameter of your Directional Light ("Light" > Advanced properties). In our case, restoring the default value (0.08) is the solution. I'm really interested. Does it help to solve your problem too?

avatar image ThierryV Apr 28 '16 at 09:36 PM

We had the same issue and this fixed our problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Temporary solution: Increasing "Min Roughness" parameter of Directional Light ("Light" > Advanced properties) or restoring it to the default value (0.08).

But I still think that it's a bug and not a desired behaviour.

more ▼

answered Apr 29 '16 at 08:35 AM

avatar image

Dmitry Zorin
21 2 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question