x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

BUG: Character Movement and Landscape

I have a level that I made. I tried to get a moving character by exporting blueprints from a FPS template. I tried to create a new blueprint with a similar set up. I tried moving the landscape to a FPS template. Nothing worked.

If a Staff member can help me, I can provide a link to the project which I've already uploaded.

1) I can confirm that using a print function, I can see the character getting my WASD input and printing 1.0 or -1.0 accordingly. I can look around with the mouse but the keys dont make the character move. If I try to add a force directly instead of by using the input, the character just slides down the landscape in whatever direction the decline is and then falls through the moment it hits another object.

2) I tried to export the landscape to a new FPS template. There is an invisible plane at the top of the landscape which stops anything falling through it. The FPS controller can move but it floats above the landscape and even fired bullets bounce off this invisible plane above the landscape.

I'm really disappointed that I'm having so much trouble simply trying to get a character to move, after I spent so much time and effort building a really beautiful scene. Everything seems glitchy. I don't get how people make games using UE4.

Product Version: UE 4.11
Tags:
more ▼

asked Apr 05 '16 at 05:04 PM in Bug Reports

avatar image

Dyonisian
3 1 2 5

avatar image Adam Davis STAFF Apr 05 '16 at 07:49 PM

Hi Dyonisian,

Unfortunately I have not been able to reproduce this on my end. What steps did you take to recreate this error?

  • Have you been able to reproduce this on a clean, blank project with no additional content or is it limited to one project?

  • Does this occur on a flat plane landscape or has the landscape been sculpted?

  • Does it only occur when you approach a certain angle or area in the landscape?

avatar image Dyonisian Apr 05 '16 at 10:56 PM

This is limited to that one project. This occurs on a sculpted landscape. It appears to happen everywhere on the landscape. It slides down the landscape and then goes through it the moment it collides with an object. Most importantly Add movement input does nothing. Anything you can suggest?

avatar image Adam Davis STAFF Apr 06 '16 at 06:12 PM

Check your collision settings on both the landscape and the character to see if one is set to ignore the other.

avatar image Dyonisian Apr 06 '16 at 06:33 PM

Tried it, doesn't seem to help. Collision preset for landscape is block all. Preset for the character is Pawn.

avatar image Adam Davis STAFF Apr 06 '16 at 07:44 PM

Can you send me a sample project this is occurring in? I'll be happy to take a look and see what may be happening.

avatar image Dyonisian Apr 06 '16 at 09:34 PM
avatar image Adam Davis STAFF Apr 09 '16 at 10:46 PM

I have been trying to find the root cause of this error for several days, but unfortunately I cannot seem to locate what the primary error may be. Do you see this occur on any other map with sculpted landscape? I noticed that the map itself seems to be tied to this on my end. I was able to get your movement input to work when I created a new level, however I do not see any instance within your blueprints that would prevent movement from occurring.

avatar image Dyonisian Apr 10 '16 at 03:27 PM

Thanks for your help Adam, turns out what dsmith said helped. There's collision enabled on the skybox by mistake. Disabling that made everything work properly. If I could ask you something else, is there a documented, proper way to export a landscape, preferably still painted, to a new level or project?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

One of your static mesh objects has bad collision. you're spawning your character inside it. Fix the collision on your static meshes. Setting your skybox to "No Collision" fixes the issue.

Good luck!

more ▼

answered Apr 09 '16 at 11:13 PM

avatar image

dsmith
186 9 3 10

avatar image Dyonisian Apr 10 '16 at 03:28 PM

That fixed the problem. Thanks a lot for your help. Its not something I would have thought of myself.

avatar image dsmith Apr 10 '16 at 05:09 PM

Cool, please accept the answer as having solved your issue. As people go through their answers it's helpful to see which ones are closed. Thank you!

avatar image rodrigoreyesla Apr 28 '18 at 03:49 AM

So many thank yous!

I just spent a few hours trying to figure out why an AI character wouldn't move and I ran into this thread. Sure enough, my custom skybox had collision ;_;

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question