x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

The map specified on the commandline '/Game/Maps/Maps/Men' Could not be found. Exiting -

Hi! When I package my project and start it on my mobilephone i always get the error: The map specified on the commandline '/Game/Maps/Maps/Men' Could not be found. Exiting -

I already read this post but nothing worked: https://answers.unrealengine.com/questions/249461/the-map-specified-on-the-commandline-gamegenericsh-1.html

Product Version: UE 4.11
Tags:
more ▼

asked Apr 05 '16 at 07:06 PM in Packaging & Deployment

avatar image

Valey14
31 7 12 14

avatar image Samantha Sutton ♦♦ STAFF Apr 12 '16 at 05:07 PM

Valey14,

In order to better assist you, I'm going to need for you to provide me the logs from your mobile device.

  • Attach your phone to the computer

  • Go here: C:\NVPACK\android-sdk-windows\tools

  • Open up Monitor.bat

  • Launch the program and save the logs

Make sure that you highlight all of the logs, because they do not save unless they're highlighted.

Thank you!

avatar image Valey14 Apr 12 '16 at 05:52 PM

Hi Samantha, when i try to open the monitor.bat it just opens a fraction of a second

avatar image Samantha Sutton ♦♦ STAFF Apr 12 '16 at 07:00 PM

Try going here: C:\NVPACK\android-sdk-windows\tools\lib\monitor-x86 and opening Monitor.exe, and then follow the instructions!

Thanks!

avatar image Valey14 Apr 12 '16 at 07:07 PM

link text

thats what i get, but now it says that i have no google play store key

log.txt (27.8 kB)
avatar image Samantha Sutton ♦♦ STAFF Apr 12 '16 at 07:59 PM

In the editor, did you click the button to turn on the Google Play settings? It's buried in Project Settings > Android.

avatar image Valey14 Apr 13 '16 at 06:38 PM

Hi, now i am getting the error again, here is my log. Pleas help! link text

log.txt (67.7 kB)
avatar image Samantha Sutton ♦♦ STAFF Apr 14 '16 at 03:33 PM

After reviewing your logs, it seems that your device is running into a signal 11 crash. This crash is quite generic but it typically means that there is an issue with your gpu drivers on the device.

Could you please try the following:

  • Try reproducing this issue in a newly created project, make sure you try without adding additional maps, and also try by adding some maps in like your original project.

  • Try changing your target hardware to mobile & 2D/3D scalability. Try again with mobile & maximum quality

  • Try using ETC2 instead of ETC1

  • Update your Android device to Marshmallow if applicable

Please provide new monitor.bat files when you're testing. You can also include the output logs from the error, in case you run into any errors packaging.

If you find exact reproduction steps, please list those out within your next reply.

Thanks!

avatar image Valey14 Apr 18 '16 at 02:21 PM

Hi, I tried to reproduce the issue with a new map. I also tried packaging my project with 2d/3d scalability. And I tried it with ETC2, but i get the error every time.

but i found out, when I launch my project instead of packaging it, the menu opens, but i get an other error" Error 1 exiting"link textlink textlink text

avatar image Samantha Sutton ♦♦ STAFF Apr 21 '16 at 09:13 PM

So in the logs for 2d 3d scaleable.txt, the issue you're running into is a Signal 11 crash. This means that your GPU drivers are having trouble with the project. You may need to update the drivers or software on your phone.

In the launched, new error.txt, I see there is a problem with locating some of your maps. Make sure that the maps are located in files that are being packaged for the project. You may want to also go to Project Settings > Maps & Modes and make sure that you have your maps set up correctly within the default map section.

What kind of devices are you using, and what is their version of Android?

Thanks!

avatar image Valey14 Apr 22 '16 at 01:05 PM

in Maps an Modes there was no map set, but when i set a game default map, i get the error " The map specified on the commandline ´/Temp/Untitled_0` could not be found. Would you like to load the default map instead?" But i dont even have a map that is specified on that commandline.

I use my OnePlus 2 with Android 5.1.1 and its up to date.

avatar image Samantha Sutton ♦♦ STAFF Apr 22 '16 at 04:20 PM

Can you upload your project and provide it to me through a private message on the forums?

Thank you!

avatar image ultrask14 Jun 10 '16 at 09:48 AM

i am having the same issue with error code 1 with my maps. they are in the correct folder. any way someone can help?

avatar image Samantha Sutton ♦♦ STAFF Jun 10 '16 at 03:17 PM

Please submit a separate thread to AnswerHub with your logs included and additional details and we'll assist you further.

Thanks!

avatar image Valey14 Apr 26 '16 at 12:29 PM

Any news about the error?

avatar image Samantha Sutton ♦♦ STAFF Apr 26 '16 at 07:01 PM

Valey14,

I have packaged and ran your project successfully on a Nexus 5, Nvidia Shield, Nexus 5x and a Nexus 6P. Unfortunately, we do not have the HTC One Plus 2, but the 5x and 6P were the closest devices that we had that I could test on. It could ultimately be the device itself. What I would suggest doing is if you're able to, update the device to the newest version of the Android OS that's out for your device.

Please keep in mind that all of the devices tested on are on Android Version 6.0.1 except for the Nvidia Shield which is on Android Version 6.0.

Looking forward to hearing back from you, thanks!

avatar image WoodsShin Jul 18 '16 at 12:00 AM

Hi,

I had the same issue. I changed uproject filename when I built. I had to sync with perfoce and build it with engine source. Anyway it caused the cook path was modified. That's why game couldn't load map. I recommend you to use the same file name with the Name in uproject. It could resolved in my case.

Shin

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Valey14,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

more ▼

answered May 02 '16 at 03:31 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question