x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editor doesn't show up on openSUSE 42.1

I've compiled UE4.11 editor from GitHub source on my openSUSE 42.1 KDE system and when I try to launch the editor via "cd Engine/Binaries/Linux && ./UE4Editor" it crashes without any errors or showing only a thin black window on my desktop or a big black window that covers my whole screen that crashes after 2 minutes.

When compiling UE4, I haven't got any errors, so I don't know, why it crashes.

The editor worked really good on my former installation, an elementary OS Freya (based on Ubuntu 14.04) with a not so good processor. The Unity Editor for Linux runs great, only UE4 crashes...

Thank you in advance!

UPDATE (7.4.2016) I've got these errors in diagnostics.txt:

 Unknown!/usr/lib64/libLLVMCore.so.3.7(LLVMAddTargetDependentFunctionAttr+0xa6) [0x7fc6d507f826] + some bytes
 Unknown!/usr/lib64/dri/radeonsi_dri.so(+0x591eea) [0x7fc6d8b69eea] + some bytes
 etc, etc.
 Unknown!/usr/lib64/dri/radeonsi_dri.so(+0x16e020) [0x7fc6d8746020] + some bytes
 Unknown!/home/alexander/Downloads/UE4/UnrealEngine/Engine/Binaries/Linux/libUE4Editor-Core.so(+0x2becb2) [0x7fc717baecb2] + some bytes
 Unknown!/home/alexander/Downloads/UE4/UnrealEngine/Engine/Binaries/Linux/libUE4Editor-Core.so(+0x5d0e4b) [0x7fc717ec0e4b] + some bytes
 Unknown!/home/alexander/Downloads/UE4/UnrealEngine/Engine/Binaries/Linux/libUE4Editor-Core.so(+0x5ec0c9) [0x7fc717edc0c9] + some bytes
 Unknown!/lib64/libpthread.so.0(+0x80a4) [0x7fc7187380a4] + some bytes
 Unknown!/lib64/libc.so.6(clone+0x6d) [0x7fc70b65cfed] + some bytes

Looks like UE4 can't run with AMD Radeon drivers, but why?

UPDATE (14.4.2016) I now know, that I've forgotten to create the BuildConfiguration.xml. It seems that this prevented the editor to start. Now I added one and everything seems OK, but about five seconds after starting I get the error "Signal 11 caught." and the editor doesn't show up either. But the messages that are printed out before crashing are the same I got using the editor under elementary OS, so I really do not know where the editor crashes. Since the process catches sig11, there's no log from where I could copy&paste information from... Hope that you have enough information now.

Product Version: UE 4.11
Tags:
more ▼

asked Apr 06 '16 at 03:36 PM in Linux

A. Leithner gravatar image

A. Leithner
1 1 1

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

It's not like it can't run with AMD drivers, the crash happens in LLVM runtime core library (C++ core library for Clang compiled applications i guess) but AMD drivers might be the cause of it too (that LLVM call might been controlled crash) i don't think it's UE4 as this happens deep in the driver. Without symbol data or any other logs there not much it can be helped, you might try updating AMD driver (or use diffrent driver) or LLVM or switch there versions around. Also check if other 3D applications work properly. it might be also idea try running editor with -opengl and -opengl4 maybe diffrent OpenGL profile will work. IF nothing keen be help here we can also try to make this quastion as bug raport, but problem with Linux is that every distributre and sometimes system installation have different setups so it hard to fix things like tha.

more ▼

answered Apr 07 '16 at 03:27 PM

Shadowriver gravatar image

Shadowriver ♦
23.8k 872 94 967

A. Leithner gravatar image A. Leithner Apr 07 '16 at 03:40 PM

Thank you for your reply, I will install the newest AMD Crimson driver (the driver shown in logs are the ones made by openSUSE Community) and yes, other 3D-Applications like Blender or games work properly. I'll test it and then write another comment ;-)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question