x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Child blueprint reset to Parent defaults

This has been a bug for as long as I can remember but what happens is if you have a blueprint actor that is a child of a parent blueprint actor and it inherits variables, there are times when all child blueprints reset. This seems to occur when editing information inside the Parent blueprint. This does not always happen, and Im not sure what actually causes it, but it is extremely annoying and really sets me back in terms of progress because I have about 50 child blueprints that I have to re add values to.

Product Version: UE 4.11
Tags:
more ▼

asked Apr 06 '16 at 09:35 PM in Bug Reports

avatar image

Shirk
230 39 52 63

avatar image SolSkyre May 13 '16 at 12:52 PM

I have the same problem and puzzled how long this bug remained, It becomes a shame rather...

avatar image Mr.Lachetti Jun 17 '16 at 04:47 AM

I also get this bug in 4.11. All my weapons settings resets to default, after change parent class.

avatar image paradoc Jun 26 '16 at 01:22 PM

4.12 as well. has there been any official response to this yet? [edit] seems to be addressed here

avatar image JoeWintergreen Aug 30 '16 at 10:40 AM

This is still happening in 4.12.

avatar image Shirk Oct 11 '16 at 02:28 AM

This is still a bug in 4.13! Epic get on this stuff!

avatar image JoeWintergreen Oct 11 '16 at 02:30 AM

Can confirm still happening in 4.13. I get it on different classes now though, many of the previously affected ones are fine now.

avatar image polygon Oct 12 '16 at 08:55 AM

Yep, I can confirm this and it becomes nearly impossible to work with this bug :-/

avatar image spyro Oct 12 '16 at 02:42 PM

Had this problems from time to time in my project. Was super-annoying and I head to restore the whole blueprint from my VCS each time.

avatar image Shirk Oct 30 '16 at 07:25 AM

This is still happening in 4.14 preview.

avatar image Selentic Dec 20 '16 at 10:38 PM

This is still happening in 4.14.

avatar image JoeWintergreen Dec 20 '16 at 10:58 PM

This is, indeed, still happening in 4.14.

I was at Epic in Bellevue recently and spoke to someone there about it, Mike somebody, said he'd be happy to get some SVN details off me and take a look at repro-ing it in my project. I forgot his surname though and don't know how to get ahold of him. Maybe someone can give me a list of possible Mikes?

avatar image HuntaKiller Dec 29 '16 at 11:42 PM

I also just experienced this problem now I have to set multiple values on several blueprint child classes..

avatar image Macw0lf Jan 10 '17 at 06:01 PM

This bug is a real problem.

I have have found quite a few reported permutations of it. With many hundreds of child blueprint actors, having to fix their defaults every few days is a real PITA.

avatar image Stephen Ellis ♦♦ STAFF Jan 11 '17 at 02:12 PM

Hi everyone. I have moved this post into the 'Bug Reports' section so our staff can follow up. This has been previously investigated for the 4.11 release, and the issue was reproduced and logged (https://issues.unrealengine.com/issue/UE-22557) but it seems the specific reproduction no longer occurred as of the 4.13 release. We will likely need a new reproduction from you, so your help is appreciated.

avatar image HuntaKiller Jan 11 '17 at 04:58 PM

When it last happened to me, the editor crashed because of a different reason (forget the problem by now) but when I restarted the editor a lot of my child BP values had been reset to default.

EDIT: so it's become clear that this happens when the editor crashes

Everyone experiencing this problem should vote it's priority at this link: https://issues.unrealengine.com/issue/UE-22557

avatar image Say1O Jan 11 '17 at 05:15 PM

I have this problem too in 4.14!

avatar image icecreammatt Jan 11 '17 at 05:19 PM

I wanted to add I've also had this issue in 14.0 and 14.1. I haven't upgraded to 14.2 yet. I had a ton of work reset after a crash the other night and all my child blueprintgs had their settings reset to defaults.

avatar image Kain Shin Jan 15 '17 at 04:33 AM

I posted a repro project for this at https://answers.unrealengine.com/questions/246046/certain-bp-class-properties-keep-losing-value.html

I will repost that here: link text alt text

MyActorArchetype is the base Blueprint class from the C++ MyActor class. That works fine.

Repro Steps:

  1. MyActorArchetype_Child is a Blueprint derived from MyActorArchetype. Note that the FText MyProperty in it is blank.

  2. Set it to defaults, compile the blueprint, and save, then close the editor.

Result:

A) When you reopen the editor, that FText field is blank again within the child blueprint. Its inherited value got lost.

B) In addition to loss of values within child blueprints, instances of the parent blueprint class, which is not inherited from any other blueprint, will have uninitialized properties and must rely on GetArchetype() to find the serialized values that were set by humans in data on that archetype.

Expected:

A) For inherited child properties of an instanced UObject to persist between editor sessions when embedded inside another instanced UObject

B) For properties within instanced UObjects to serialize into every other instance when embedded inside another instanced UObject.

Additional Notes:

i) Property values will not get lost if you set the child archetype's property to something that does not match the parent's.

ii) A workaround solution is to not embed UObjects within UObjects but instead, have the embedded UObject be sub-objects of the outer Actor (maybe outer component, too, but did not test that)

avatar image polygon Jan 11 '17 at 05:34 PM

Unfortunately this is still happening and the main problem is that it's pretty hard to reproduce as this issue shows up randomly as far as I can say. I hope this will be investigated soon because this is a VERY serious bug and can destroy a whole game project :/

avatar image Freestyledork Jan 12 '17 at 04:25 AM

Hi TJ,

I seem to still have this issue in 4.14.2. The items are only reset when the parent blueprint is edited and the editor is reopened or packaged to play in stand alone. It doesn't happen right away and the values that change back to the parents default seem to be random.

I have a base building BP and some default values like name and cost. Then I have child buildings that stem from the base. I change those cost and name values on the child. If I edit the parent and compile the child BP are randomly reset, not sure if its limited to Child BP that are not open in the editor at the time of compile. I just spent a couple weeks rebuilding a project in the latest version to find out the bug still exist. Very annoying.

If you want a project to test PM me and ill send you mine.

avatar image TJ V ♦♦ STAFF Jan 12 '17 at 04:18 PM

Hi Freestyledork,

That would be great. PM me a link to download the project over the Forums if you don't mind.

avatar image Freestyledork Jan 13 '17 at 06:33 PM

I noticed something possibly helpful today. If I notice the child blueprints are getting reset in standalone but not in PIE. I add a custom event to the effected blueprints and compile then delete the event and compile again. After that I play in standalone that class has its custom defaults.

This only works if you notice before closing the engine. If you close the engine without doing this you will loose all the custom set values on that child BP.

avatar image Freestyledork Jan 12 '17 at 05:37 PM

PM Sent Thanks TJ

avatar image TJ V ♦♦ STAFF Jan 18 '17 at 08:18 PM

Hi Freestyledork,

Sorry for the delay. In the PM you sent a before and after project. Starting with the 'before reset' project, can you give me the exact steps to reproduce the issue?

I appreciate the 'after reset' project but the devs will want to see the error as it happens.

avatar image Freestyledork Jan 18 '17 at 08:48 PM

I can't seem to find an exact way to reproduce the error, I told you what I know. It shouldn't be hard for someone more experienced then me to find out why this is happening. I will list the steps that I most likely believe to cause the error.

1) Make a custom Child BP from actor type and add custom variables (well call this base)

2) Make Child BP from base and change extended variable values (assume base has a name variable and we changed it here)

3) edit the parent (base) compile

4) play game in standalone and the child BP name variable was reset to the base value. (note PIE would still show edited value not parents default.) (note2 possible that editing the parent without the child BP open in editor or placed in game could be a reason why its not saved.)

I told you what I know, at this time I don't have the ability to spend hours to find an exact way to reproduce the error. I was hoping that's what someone from Epic staff could do. Hopefully this helps as it is a really annoying bug,

avatar image GAME3D Mar 10 '17 at 12:32 AM

I getting this since a verry long time, also into 4.15 version.

  1. Create a character bp, with some variables.

  2. make a instanced bp of this class.

  3. Place this bp to the map.

  4. setup the variables you made into the parent, with other values as default.

  5. Save everything, also the map.

  6. now open the parent bp , change some code into it, or add more variables, what ever.

  7. compile the parent bp.

  8. to be sure save all / then save map

  9. close editor

  10. open editor

  11. now, you will see that the instanced and into map placed childs will be resete to default.

  12. if the bug not occure, just add more code to the parent and continue.

  13. Sooner or later you will see that you lost the values by reset to default.

It most hapen, if you changed some thing at the parent bp/class

I hope this help to reproduce this annoying bug. It really interuppt the progress of developing, if you always have to take care about some lost values and reseted child classes.

avatar image icecreammatt Mar 10 '17 at 12:34 AM

This bug is a huge pain. What I have done to work around this is at begin play I have code that manually sets all the default values. That way if the values I put in the menu are reset they are not totally lost. I really wish this bug would get fixed.

avatar image Freestyledork Mar 10 '17 at 12:42 AM

Agreed, very annoying. I tried posting steps but apparently we are the only select few who notice this issue. I can confirm its still happening in 4.15. I have added extra steps into my workflow, that I wish I didn't have to deal with, to prevent data loss. I've even provided a sample project.

avatar image Measuring Mar 21 '17 at 11:58 PM

Any news on this issue, I'm running the very latest version of the engine and at random times, some of my child actors reset their settings. For example. I have a door blueprint, I made a child blueprint of that called metal door. In here I tweak the meshes, sounds and effects. In the level, I change various properties of the placed actors like if the door is locked or opened and such. Theses settings keep resetting themselves and It's a huge setback for my project. Constantly having to go through many many maps setting up the door actors again. Does anybody have a clue on how to fix this? And why it only happens to some of my actors while others work just fine?

Thanks

avatar image Name368 Mar 30 '17 at 04:01 PM

Same problem here... This is second time that happened to me, first about 2-3 months ago and now again (4.15.1)... Yesterday until i closed editor was everything fine, today i opened my project and 15 out of 16 child classes were reset to defaults...

avatar image Devin.E Mar 30 '17 at 04:18 PM

Having the same problem :/, are you guys using any kind of Sorce Control? we are using Perforce.

avatar image Freestyledork Mar 30 '17 at 04:33 PM

I'm using perforce, but it's happened before I started using source control and after. Let me ask you this.. Are you on a desktop or laptop? Do you have auto save enabled? How long was the project open the time before you noticed the reset? Are the classes that were reset spawned into the level or already placed?

Hoping to help narrow down a set of similar criteria so unreal staff can find this bug. Because unreal staff can't reproduce the issue my guess is it has to do with having a project open for an extended period of time.

avatar image Benthedaddy Apr 14 '17 at 11:29 AM

So I'm also getting this problem and have done in multiple versions and multiple projects. It also happens around 80% of the time on load up of a project. This is really starting to ruin my experience of unreal since I am currently getting it in the latest version, on an item script I've written. Each item you pick up is a child of the MasterItem blueprint that contains all the variables to specify what that item is, buildable? Actor to spawn if buildable? Equipable? Etc I've seen so many of these posts where they've been unable to replicate the problem, do you think it could be some kind of compatability issue? Hardware or software... I know that sounds ridiculous but just seems odd that you can't replicate it on a system that is not experiencing the issue. Really hope you figure this out soon as for those experiencing this bug, it is so frustrating :(

avatar image GAME3D Apr 14 '17 at 01:14 PM

Try out to copy past all construction script code to all instances you made from the parent. But not sure this realy fix the problem 100%. Will see over time, if my instanced bps will reset to default. ATM it seems to work that way. I'm agree, They realy should fix this! This is an issue, a AAA engine should not have for a such long time as it happen with this issue. Let's try to show how this is: You painted your blue car yellow. Then at the next day your car is again blue. This is near the same, as this issue is for customers. You lose all the time your work. I love Unreal Engine, but this should be fixed, realy!

avatar image Freestyledork Apr 14 '17 at 02:54 PM

Can you guys share any info about how long the project was open on your computer? Was it a laptop or desktop? Using source control or no? Are the items that are resting placed in level or spawned dynamically?

Trying to get enough info to help figure this out. It's really surprising epic doesn't see this as more of a priority as it's clearly effecting lots of people. Basic nesting of subclasses should be rock solid on a engine of this caliber. Hopefully the importance of this issue is realized and they can elevate the time spent to find why it's happening.

avatar image Benthedaddy Apr 14 '17 at 03:21 PM

Project open on average of 4 hours, Using desktop gaming pc. All children are present in level, not spawned dynamically. Source Control?

avatar image GAME3D Apr 14 '17 at 07:35 PM

Some times the project was long open, some times not, if it hapen. Desktop pc/ win 10/ Child was placed into map. Not dynamicaly spawned. No source controll.

avatar image HuntaKiller Apr 14 '17 at 09:40 PM

When it happens to me, my project has usually been open for hours, my objects are not placed in the level (they spawn at runtime). I believe it has something to do with the auto-save.

avatar image GAME3D Apr 15 '17 at 03:35 PM

May switch off Autosave to test this ? But i don't think autosave is the issue. What is working at my projects, you need to copy past the construction script from parent to every child. Since i did this, i don't got a reset. But not 100% sure this fix it over time. And it break the idea of inheritance.

avatar image Benthedaddy Apr 17 '17 at 01:47 PM

It is odd that unreal don't take this more seriously, since this is such a big issue and undermines the whole support structure of the engine. Been reading a lot of these posts for the last 6 months and always get the feeling of well... We can't replicate the problem so it must not be there! Or we can't do anything about it if we can't replicate it! I love unreal and have done since I first discovered it all that time ago but if their was another engine anywhere near as good as this, I would jump ship straight away due to this long outstanding bug. Luckily for Unreal, their are no such engines out there at the moment.

So what am I supposed to do Unreal? Not use child Blueprints? Is this still being looked into by Unreal?

As I said before, you don't seem to be able to replicate this problem on a system not experiencing it so what are you doing instead?

avatar image JoeWintergreen Apr 24 '17 at 06:56 AM

I've made a thread on the forums where we can hopefully discuss this more easily/productively. Includes a survey it'd be helpful if you'd all fill out. https://forums.unrealengine.com/showthread.php?143060-SURVEY-There-s-A-Really-Really-Terrible-Bug-Where-Child-Blueprints-Get-Their-Variables-Reset

avatar image TJ V ♦♦ STAFF May 01 '17 at 12:29 PM

Hey Joe,

Just resolving this report for tracking purposes. Thanks again for making that survey. Hopefully between here and the forum post we will get some more info that will allow us to track down the cause of this issue.

As I mentioned in the forum thread, 7 people said they can reproduce the issue in a new project. This is exactly what we are looking for. If anyone can do this, please upload it here, link it on the Forum thread, or PM me directly over the Forums.

Thanks,

TJ

avatar image basta Feb 10 '18 at 05:23 PM

Hello, This issue have been solved in version 4.18 or 4.19 ??

avatar image Benthedaddy Feb 18 '18 at 11:59 AM

I’ve learnt to completely change my way of programming to avoid this bug and haven’t seen it in a long time. I now use tables to set the initial variables of a child at begin play rather than having to go through the frustration of resets, works well for me and adds little extra work if done properly :)

avatar image basta Feb 19 '18 at 02:27 PM

ok, i got you, but i have heard that on the versions 4.17-4.19 this proplem goes away, now i'm working on the 4.10. I will test it on the 4.19 and we will see what will happen next

(comments are locked)
10|2000 characters needed characters left

4 answers: sort voted first

Copying this from the forum post I made about it:

OK so I've managed to reproduce this very easily in a new project 100% of the time:

  1. Create a First Person template project

  2. Create a new Blueprint Actor

  3. Connect a Get All Actors Of Class node to Begin Play, and set it to the FirstPersonCharacter class

  4. Create a public variable in the parent Blueprint (I used a boolean and left it false), compile/save

  5. Create a Child Blueprint from this parent and drag an instance of it in the map

  6. Change the boolean of the child instance in your map to true

  7. Compile the FirstPersonCharacter Blueprint

  8. Close the editor (it will ask you to save the map which you must do)

  9. Open the project again and notice the public variable you changed is now back at default value

  10. Hope that these steps reproduce the issue for everyone and this long standing bug gets fixed :)

You should now also be able to change the variable in the child blueprint again, compile the FirstPersonCharacter blueprint (might work with any blueprint you're getting all actors of class with), save and restart, and it will keep resetting back to default over and over, 100% of the time.

more ▼

answered May 21 '17 at 08:41 AM

avatar image

akka
41 1 2 4

avatar image TJ V ♦♦ STAFF May 22 '17 at 07:20 PM

Hi akka,

Thank you so much for posting this repro! I was able to finally reproduce the bug and I've been testing in different version.

I was able to reproduce this in 4.15.2 and 4.16 Preview 3. However; I wasn't able to repro this in our internal version of 4.17.

In his Forum post, Michael N explains the overhaul that was implemented that he believed should fix this issue. Thanks to your repro, we can confirm that it is indeed fixed for this use case. Hopefully everyone will see similar results when this version is released.

I'll also post this on the Forum thread as well.

Cheers,

TJ

avatar image Macw0lf May 22 '17 at 07:51 PM

I have noted in the past this, or similarly described issues, have been flagged as fixed - but it ended up not being quite the same issue. So I would be really keen for someone who has tested it on 4.17 letting us know their result. I have stopped at 4.14 as each upgrade is a bit of work to apply in our project and waiting has been prudent.

But if it works.. I'll be upgrading right away - no brainer.

If this is indeed the fix we have been waiting for, it will be a massive step forward for any of us who have built complex workarounds and lost a lot of time with it! Fingers crossed!!

(comments are locked)
10|2000 characters needed characters left

Hi, bug still exists in 4.18.0. Pretty annoying and would be a great addition if this is fixed. UE4 is a really good and fun engine to work in but you can't look over the fact that UE has some nasty long-time open issues like these. Please Epic, add more dedicated resources to this bugs and other long outstanding bugs. I get that adding new features must be done as well but please put these long time open bugs on the next sprint.

Otherwise pretty awesome engine ;-)

more ▼

answered Nov 18 '17 at 10:44 AM

avatar image

TimothyBrake
51 2 7 10

avatar image CubitStudios Feb 18 '18 at 02:38 AM

I have now also experienced this bug in the latest 4.19 previews.... Perhaps it's with us forever more :S

(comments are locked)
10|2000 characters needed characters left

This bug is extremely serious and I've encountered it in ALL unreal projects that I've worked on within the last 1,5 years. My experience has brought me to the following theories:

  1. It's unlikely that it's hardware related. I've worked on different machines with different hardware and the issue happened on all of them.

  2. The issue seems to need some time till it occurs. It almost never happens with a fresh project and it starts to happen when you've invested some time in the project. WHEN it happens, you can't get rid of it. Almost if something in the backend of the project breaks forever. From this point on you will have to deal with this bug every working session.

  3. The chance for this bug to occur seems to be related to child blueprints or inheritance in Unreal in general. Chances to encounter the bug raise with complexity of inheritance. If you have a Parent actor, a child actor and a second generation child actor that inherits from the first child actor, chances rise that you'll be confronted with this issue sooner than later.

  4. Inheritance in Unreal is NOT rock solid. It works, yes. But it's fragile. I don't know if this also happens in C++ but in Blueprint the inheritance system CAN lead to unpredictable results that completely break blueprints and / or the project. As I said before: If the bug happens, you have actually no chance to solve it. I've worked on a project where I can cast a child actor to it's parent class via code and all the inheritance stuff works well in code but the output log tells me that this child does not inherit from it's parent class, even tough it actually does and all the blueprint stuff works. Inheritance in UE4 should be investigated by Epic with a priority of 10^36!

  5. There are workarounds to avoid breaking your project but it's not really comfortable to do such workarounds. This should not be necessary in an engine like this. What you can do is to only use inheritance in a moderate amount and avoid it when it's possible. You should also initialize your child actors via a function in the construction script and not in the level editor. This is more work but it worked for me so far.

I'm really hoping that this issue will be investigated as it's ABSOLUTELY PROJECT BREAKING!

more ▼

answered Apr 16 '17 at 10:14 AM

avatar image

polygon
71 6 13 22

avatar image GAME3D Apr 16 '17 at 02:33 PM

I heard, that it not hapen in C++. can you show us a bit more details, about how you did this : "You should also initialize your child actors via a function in the construction script and not in the level editor. This is more work but it worked for me so far. " Thanks!

(comments are locked)
10|2000 characters needed characters left

Hey everyone,

I've been looking into this and trying to get a repro in 4.14.3, but without any luck. Any new info, repro steps, and/or test projects would be much appreciated.

I attempted to repro in a new project with the same/similar steps from the JIRA and also in a converted much more complex test bed.

more ▼

answered Jan 11 '17 at 08:21 PM

avatar image

TJ V ♦♦ STAFF
41.2k 1009 181 493

avatar image Freestyledork Mar 14 '17 at 05:22 PM

Tj, Can you confirm that your testing child bp variables that are set differently from parent are being reset in the class defaults after modifying the parent bp and the child bp are not open or instanced in the level. Also note the effect is only appears after a full ue4 engine restart or standalone game, play in editor will not show the error.

avatar image Freestyledork Mar 14 '17 at 06:48 PM

Id like to also add I took some time today to try and nail down replication steps I was unsuccessful. I can confirm this still happens to me in 4.15 on my main project. I even rebuild everything from scratch in 4.14 because I thought something was corrupt. It still happens. The way I identify if it's happened while I'm working is by doing a play in standalone before I exit to check variables haven't been reset. If I notice they are reset my remedy is simply open all child BP and add a custom event node save, then delete the node and save again. Doing this to all the Child BP fixes the problem every time.

Seems plenty of people have the issue, its hard to re create at its simplest form. This leads me into thinking possibly autosave might have something to do with this bug. or some form of cache being over written. I am attaching my repro attempt so that you may see more clearly how I am getting this bug. I use a very similar method of getting the variables to show on screen and see if they are wrong.

Hope this helps.

link text

avatar image Macw0lf Mar 14 '17 at 07:09 PM

It happened to me again yesterday too. 14.4.3.

Hadn't happened for a while so I thought I was in the clear - but then noticed a pile of actors in my levels reverting to default state (which is quite drastic as I use various blueprint variables to control visuals)... affected about 400 actors. :-/

To reduce repeated rework, I have chosen to give up on updating them when it occurs and only fix before a public update release... but it just seems to add a huge risk/uncertainty to the release update pipeline - so isn't a workable solution for much longer.

(Even tried loading variable values from a data table for each actor during runtime to force the darn things into a state - but that proved a major PITA too).

Hope the problem gets sorted.

avatar image TJ V ♦♦ STAFF Mar 21 '17 at 08:27 PM

Hey guys,

I've still be unable to get a repro on this. I tried using your project Freestyledork, but the only variable reset I can reproduce is by renaming variables in the parent blueprint. That is a known issue in 4.15 and is fixed in our latest internal build.

It's possible that could also fix this issue but without a reliable repro I'm not able to test for it.

If you guys get anymore info, please let me know.

avatar image GAME3D Mar 30 '17 at 07:41 PM

Last day i lost again the whole setup of all my intanced ai bp.

For reproducing: Make a parent AI, or character BP. Then add a few variables to the construction script. The variables are editable. Now make instances of this bp. place some of those intanced BPs to the map, then change the values into the instances.(those you placed to map) Now save all and save map. Restart editor Now open the parent of the instanced BPs, and add more editable variables to construction script. Also add some code to the parent bp event graph. Don't touch anything at the map and save all, save map. Now restart pc. open editor again and see that all instanced BP are set to the default seting of the parent BP. This not hapen all the time!!! So continue with add code and variables to the parent bp. save all save map, restart pc.test again. Do this as long the error not hapen. I'm sure, you will hit the error, once you do this, again and again. (This is not a jocke! but the error hapen randomly and the only way to see it, is to continue, to add stuff to the parent, aslong the error not occure.)

At least, if it hapen into a large world, you could destroy the PC and trash it trought the window. Really, it is a pain if it hapen.

Not sure, it have to due with the time your project was open. Last i got the issue, my project was open, longer as one day.

avatar image Freezerain Mar 31 '17 at 11:26 AM

Can confirm that not all child and not all variables are set to defaults. There was a problem with struct variables, but since i moved to data table because of this bug, didn't have it right now. But for now my mesh of the child is reseting to parent, and not for highest one. For example my helmet that not have any code in it reseting to "armour_parent" mesh but stay with "custom_row_name" so its taking all data from Data_table very well. Cant really find a root of this problem and not sure that its not in my code, because i mess with it in this days. My other branches like "weapon_parent" - "sword_bp" is broken too, but its not affecting parents above like "equipment_parent" that connect armour and weapon parent and "items_parent" that master for everything, its stay the same and my branch "consumable_parent" - "health_potion" is working and have custom mesh all that time.

avatar image EoinOBroin Apr 09 '17 at 11:21 PM

Happened to me on several occasions recently in 4.15, frustrating as it causes all child blueprints to lose the values that had to be manually set up and return to default.

avatar image Benthedaddy Apr 14 '17 at 03:20 PM

Project open on average of 4 hours, Using desktop gaming pc. All children are present in level, not spawned dynamically. Source Control?

avatar image Benthedaddy Apr 15 '17 at 10:01 AM

It is odd that unreal don't take this more seriously, since this is such a big issue and undermines the whole support structure of the engine. Been reading a lot of these posts for the last 6 months and always get the feeling of well... We can't replicate the problem so it must not be there! Or we can't do anything about it if we can't replicate it! I love unreal and have done since I first discovered it all that time ago but if their was another engine anywhere near as good as this, I would jump ship straight away due to this long outstanding bug. Luckily for Unreal, their are no such engines out there at the moment.

So what am I supposed to do Unreal? Not use child Blueprints? Is this still being looked into by Unreal?

As I said before, you don't seem to be able to replicate this problem on a system not experiencing it so what are you doing instead?

avatar image Macw0lf Apr 15 '17 at 11:05 AM

I gotta agree with you. This is singularly the biggest issue with UE4 from our perspective. I there wasn't 18 months invested in the game, we would jump ship simply because of the wasted time and rework this bug has caused. Unreal is a better engine than the others, but I would sacrifice those extra features for reliability and stability.

Epic - please - we can't recreate the bug - we don't know what to do!

It happens seemingly randomly. I have even put debug code in to watch for blueprint child attributes that change, and report it when it happens. Even then, and it happen frequently, I have not been able to recreate it, or understand why.

I have 400+ level actors that are not instantiated but exist in the level. Each is part of a multi-layer blueprint hierarchy, and each level adding it's own few variables. Every now and again.. bam! every door in my game resets to open, the mesh goes back to the default, etc. And it's not just doors.. it's any one of about 40 different blueprint actor types...

For example - just today.... my debug code spotted dozens of actor resets and reported them.. when I run the game... Every item listed is a BP actor that has reset itself to defaults. Bah!

alt text

avatar image JoeWintergreen Apr 16 '17 at 01:16 AM

Yeah, this just happened again to me. Doors for me too! UsableDoor is the base class, and even in-level instances of data-only child classes which change no default values got their vars all reset to default when I opened the map just now. So none of them are locked, because the default is unlocked. Ready to kill.

avatar image Macw0lf Apr 16 '17 at 06:15 PM

"You should also initialize your child actors via a function in the construction script and not in the level editor. "

This unfortunately doesn't make too much sense. Every instance of an actor in the level has different a different starting state, and different variable settings. Initializing the actor in the construction function would only work if every instance of an actor in the level had the same initial values.

That would defeat the point of having the ability to have an actor in the level.

avatar image polygon Apr 17 '17 at 12:39 PM

Yes, it's not a perfect way to work around the issue but I prefer it over being confronted with the bug and having to redo all my work.

All you need to do is to create a init-function in your parent class with inputs for all the variables that can be different on each child instance placed in your level. Let's say you have a parent class "Monster" and a child class "Werewolf". Then I'd simply setup a function called "init" in the "Monster" (or Werewolf) class with inputs for all variables that can vary. You end up with an init function with inputs like health, AttackDamage, etc. Then I would call this init function from the level blueprint and set the values that need to be different for each child.

This method works for me so far but it can lead to problems when an actor's begin play function gets called before he got initialized by the level bp. This depends on your setup.

avatar image GAME3D Apr 17 '17 at 01:56 PM

How fun? My parent have about 30 variables. Will try out my method a bit more. Just copy past all code from parent construction script to the childs too. It seems to work that way, but not 100% sure it fixed it. At least, since then i don't got a reset. I will see over time, if this fixed the problem.

avatar image TJ V ♦♦ STAFF Apr 17 '17 at 08:23 PM

Hi everyone,

Thank you for the feedback. Our developers are aware of this issue but without a reliable repro case its not possible for us to effectively investigate the bug. If anyone finds a way to reproduce this, please post it here.

As for the ongoing discussion, we ask that you create a forum post and reference this report. This will make it easier to find useful info in this thread in the future.

TJ

avatar image Freestyledork Apr 17 '17 at 08:44 PM

Unfortunately it seems this bug becomes evident after some time in the editor and if spending to much time on one problem (even one as critical as this) is not possible, then i'm afraid we will never have a reliable repro.

I can only speak for myself but I've tried to take time and help with clues on the issue. It really does exist, it's not some phantom problem. The copy paste response is a bit off putting. Basically claiming if you cant tell us exactly why this is happening we wont fix it. I realize this is not your decision alone and don't mean to pass blame.

Here's to hoping someone more talented than myself chimes in. Dollars to donuts this is hidden in some method deep in the engine... I can't begin to try and solve it on my own.

**EDIT Maybe it's possible to enable some advance logging? so when the issue happens I could submit the log??

avatar image jordylakiere Jul 06 '17 at 03:37 PM

Bug still exists in 4.16

Collision is being reset to "character" and anim BP to "none" on my child skeletal mesh components. This came out of nowhere, worked fine before. This is totally game breaking.

(comments are locked)
10|2000 characters needed characters left

Hi TJ, Whilst I appreciate the response and the work the Unreal team puts into the engine, plus the fact we get to use it for free... I still feel like this is not good enough, it's yet another we can't reproduce it so we can't fix it answer that we've seen so many times and offers no consolation to those experiencing this breaking bug. As previously said this happens on every project I make that has master-child relationships and I find it impossible not to reproduce the bug. The fact that you can't seem to reproduce it is very odd. Have you tried to reproduce on multiple varying pc systems? Seems strange that only a certain percentage of people ever experience it and it's usually from first using the engine. All I have to do is make a parent blueprint, make a struct, reference it in the parent, create a child, change the struct variables in the child, play with the third person or player controller scripts for an hour or so, save, shutdown, restart and the bug appears at least 75% of the time..... So why can't you reproduce it???

more ▼

answered Apr 18 '17 at 12:10 PM

avatar image

Benthedaddy
6 1 2

(comments are locked)
10|2000 characters needed characters left

Hi,
Something I have seen several times with Blueprints inheriting from each others, is that by design Unreal doesn't seem to store a flag to remember if a property has been overriden or not.
Which means it only relies on a diff with the parent BP to consider a property to be overriden or not (yellow arrow) and actually save the value.
The consequence is that I often see bugs similar to the ones described in this thread (inherited values being reset).

Here is an example :
1 - Have some BP named "base" with an integer property "health" set to 100.
2 - Have a BP named "child", with "base" as a parent, and "health set to 50. A yellow arrow will appear to notify the value as overriden.
3 - Take the "base", modify the "health" value to 50, then back to 100. The "child" health will be updated to 100 too.
Whenever the base BP property is equal to the overriden child property, Unreal seems to consider that it is no more overriden.

I have seen this behaviour up to 4.16, haven't tested on more recent builds.
I hope it will help !

more ▼

answered Mar 16 '18 at 05:58 PM

avatar image

DNEadrien.cambon
6 1 3

avatar image Freestyledork Apr 07 '18 at 09:52 PM

Just tested on clean 4.19 and confirm this is still a issue, I really thought this would be fixed by now...

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question