x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Apex cloth validation crashes 4.11 + cable missing

having upgraded to 4.11 I had to replace the files the editor could not find at launch (like eu4editor - lightpropagationvolumeruntime.dll) before I could get into the project, upon which it crashed on play - due to apex cloth, the only solution was to reimport my skeletal meshes after deleting all the clothing entries through the bulk edit property matrix, because it would crash as soon as I had anything of apex cloth on my screen. This is still an issue - I can't use apex clothing. How do I get the missing file, which is not having this error on line 685? which is btw: check(ClothSimulPositionNormalBuffer[Index].VertexBufferRHI.IsValid());

(Assertion failed: ClothSimulPositionNormalBuffer[Index].VertexBufferRHI.IsValid() [File:D:\BuildFarm\buildmachine_++UE4+Release-4.11\Engine\Source\Runtime\Engine\Public\GPUSkinVertexFactory.h] [Line: 685])

A separate issue I'm having, but which also entirely prevents me from proceeding to work on the project is the disappearance of the cable component in its entirety. it just doesn't exist anymore in my 4.11 and all the related nodes return errors.. I checked the cable component class files and none seem to be missing, but no cable. If no cable/cloth for a long time(untill4.12 maybe?), then how can I work around these issues??

So there is a third issue regarding mouse look input suddenly working in world orientation to the first glance, instead of being a control rotation, this occurred when I changed the bool of use controller rotation and orient mouse to movement (picked up the grapple gun which has no rope anymore)

If anyone has any idea how to fix, or even work around these issues temporarily to proceed without crashing during new session in pie/standalone game, please advise.

After a few usual crashes the editor stopped giving me reports and just insta quits to desk, how to re-enable reports?

My decals OR sound crashes to desktop as well, happens every time I fire a gun, was not able to obtain a warning message about that yet, nor of the mouse.

Product Version: UE 4.11
Tags:
more ▼

asked Apr 07 '16 at 10:42 AM in Bug Reports

avatar image

Polivantage
66 1 6 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Sorry for the trouble, the issue was found to be that the 4.10 project had a max concurrency count of 0 (which it shouldn't have been allowed). When loaded in 4.11, the code which translates the old max concurrency feature to the new feature didn't clamp the value of the old data to the proper ranges (i.e. greater than 0). The new system (correctly) asserts that there shouldn't be a max concurrency count of 0 since that should mean that no sound would be allowed to play.

I submitted the fix to our 4.11.2 hotfix branch so it should come out soon. In the meantime, to fix the issue, either make sure your 4.10 projects don't set a max concurrency of 0 before upgrading or add the following code change to your 4.11 solution in SoundBase.cpp in USoundBase::PostLoad():

         ConcurrencyOverrides.MaxCount = FMath::Max(MaxConcurrentPlayCount_DEPRECATED, 1);

more ▼

answered Apr 13 '16 at 05:31 PM

avatar image

Minus_Kelvin STAFF
922 23 5 31

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Polivantage,

I was able to reproduce the crash and have narrowed it down to your .wav files, primarily those used on the shell casing blueprint your pistol spawns. I found that exporting the files and importing them from the desktop in a new project seemed to allow me to play the sounds without a crash, but migrating them to a new project still caused the crash (merely playing the sounds causes the crash to occur, no blueprints are required). Try exporting your sounds and re-importing them to see if this works, if it does not, you will have to work with placeholder assets or alter the sounds to prevent the crash from occurring. I have entered UE-29403 to be assessed by the development staff.

more ▼

answered Apr 12 '16 at 08:14 PM

avatar image Polivantage Apr 13 '16 at 11:57 PM

Dear Adam, Thank you very much for your support! this issue has boggled my mind until now, I'd never think it were the assets - because if I just drop the casing without firing it, the sound plays and no crash occurs. I still wonder what actually causes the crash with those assets, knowing the more technical details would help to prevent future problems. I'm deeply grateful, going to do as you suggested and re-export those sounds, thanks a lot! Leo.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

so far i'm experiencing the 4.11 "stable" release as some sort of a bad 1st of april joke. Does someone know where to get a non-crashing version of the engine? my 4.10.4 worked fine, after install of 4.11 both of them crash on various peripheral actions as described above, -highly annoying. I have tried hauling in compiled, portable versions, adjusting the code, that's so far the only way I am able to work on my project, being constantly interrupted by crashes. I've spent a lot of time and effort on this project and would not like to start with a clean one. Please, could someone point me in the right direction?

more ▼

answered Apr 07 '16 at 12:07 PM

avatar image

Polivantage
66 1 6 9

avatar image Adam Davis STAFF Apr 07 '16 at 03:33 PM

Hi Polivantage,

Deleted original post as it applied through an incorrect account

Please do not bump threads that have not gone unanswered for 4 or more days. This clutters the answerhub and makes it difficult to parse through information. If after 4 days you have not received a response, feel free to bump the thread once.

For your specific errors I have a few questions that may help to determine what may be occurring:

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?

  • What steps can I take to reproduce this on my end?

  • Have you tried verifying your engine build? If you go to the launcher>library>engine version dropdown context menu>verify it should run through to see if any files were damaged/missing and repair/replace them as appropriate.

  • I am not missing the cable component on my end, are you able to call the cable component in a new actor?

  • Can you post your crash logs here? They can be found at \Unreal Projects\PROJECTNAME\saved\logs\

  • In addition, can you post your callstack here after the editor crashes?

  • Is this a c++ or blueprint project?

avatar image Polivantage Apr 07 '16 at 09:32 PM

hi, i misposted my reply as an answer.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Adam, thank you for the attention.

As stated above, I receive no more reports upon crash, it just sends me to desktop rather quickly without any aftermath, sadly. How can I re-enable my crash reports?

I have done some extensive testing and came up with the following problems and reasons therefor.

My project is entirely done with blueprinting, there is not a line of C I have written for it, - so far though.

  • cable still missing in blank third person project just like in old project.

  • cloth works in blank project, most assets are deformed upon import. Some cloth assets still crash old project upon their previewing on the mesh, not upon import.

  • its not the sound that crashes upon gunshot, but actor spawn from class. (included screenshot of the code) shell alone in world crashes not, but spawned at gun it insta-quits the editor (with no error report as usual)

  • upon crash there is no error report, how can I re-enable those? my end user settings enable ue4 to send info to epic, but at some point my crash reports just stopped appearing.

  • Decals appear as thin lines instead of their original (square) shape. They were square in 4.10.4.

Now my major worry is the disappearance of the cable component, as you can see below its just not there, all the nodes referring to it still exist. Note that all the above has been tested after the 4.11.1 release I just installed before testing. It worries me because other issues I have encountered before, or have seen them in other people's posts, but missing a common component to add to blueprints is new.

The gun worked smooth before 4.11, now in 4.11.1 it lags with every gunshot and crashes if I try to spawn my shell at its side. This is also imo a major point for attention as I have no idea what can be causing this.

decals missing cable fresh project missing cable original project code that crashes 4.11.1 100% of the time, works fine in 4.10.4 code on the spawned object, works fine by itself in the world.

more ▼

answered Apr 07 '16 at 09:31 PM

avatar image

Polivantage
66 1 6 9

avatar image Polivantage Apr 07 '16 at 09:45 PM

forgot to include log here it is. log last crash

I suppose the interesting part is in the end: [2016.04.07-22.01.29:253][140]LogCrashTracker:

[2016.04.07-22.01.29:253][140]LogWindows:Error: === Critical error: === Assertion failed: Concurrency->MaxCount > 0 [File:D:\BuildFarm\buildmachine_++UE4+Release-4.11\Engine\Source\Runtime\Engine\Private\SoundConcurrency.cpp] [Line: 165]

[2016.04.07-22.01.29:320][140]LogExit: Executing StaticShutdownAfterError [2016.04.07-22.01.29:342][140]LogPhysics:Warning: PHYSX: ....\PhysX\src\NpScene.cpp (2946) 8 : PxScene::unlockWrite() called without matching call to PxScene::lockWrite(), behaviour will be undefined. [2016.04.07-22.01.29:342][140]LogPhysics:Warning: PHYSX: ....\PhysX\src\NpScene.cpp (2946) 8 : PxScene::unlockWrite() called without matching call to PxScene::lockWrite(), behaviour will be undefined. [2016.04.07-22.01.29:343][140]LogPhysics:Warning: PHYSX: ....\PhysX\src\NpScene.cpp (2946) 8 : PxScene::unlockWrite() called without matching call to PxScene::lockWrite(), behaviour will be undefined. etc..

2nd log is the crash

avatar image Adam Davis STAFF Apr 07 '16 at 09:50 PM

Try verifying your engine build. To do so, go to Launcher>Library>Dropdown context menu>verify to run through and replace or repair damaged and missing files. If this does not return the cable component you may need to uninstall and reinstall the editor. Thankfully as this is occurring in additional projects that does mean that the project most likely is not corrupted, which would be a more significant loss than an editor reinstall. If neither of these fixes the error, please comment again and we'll move forward with a few additional steps that may help to show what is occurring.

avatar image Polivantage Apr 07 '16 at 09:55 PM

have been verifying whole day, hoping for a fix, this all btw happens after 4.11.1 i just installed, im going to completely remove and re-install the engine now as you suggest and let you know what happens, Thank you for your help.

avatar image Polivantage Apr 07 '16 at 11:00 PM

After a fresh install of 4.11.1 my cable component has returned, I had to replace all the references to it to make it function.

avatar image Adam Davis STAFF Apr 09 '16 at 05:12 PM

Did the reinstall fix the crash as well or are you still experiencing the crash? If not, do you have a project this is occurring in you would be willing to share? I'll be happy to take a look and see what may be occurring.

avatar image Polivantage Apr 09 '16 at 07:04 PM

Dear Adam, Unfortunately the crash is not fixed yet. I have a new problem related to the iKinema license telling me its void while I'm not using a license, but have just purchased the indie runtime. I have contacted iKinema, but am waiting for Monday to be able to work again, because I still haven't got a reply with a solution which is applicable to my situation (full re-install, no older folders left). So currently my animation graph is not compiling unless I disconnect the iKinema nodes which is something I haven't bothered with so far. Without a functioning animation graph, a lot of other things do not function correctly for some reason, so I wonder whether it would give a good representation of the real problems which a working animation graph would not solve.

Taking the above into account, I'd be happy to share my project in hope of a fix, or even a workaround. As soon as I am able to- I will post a stripped version of it (no textures) on google drive and send you a private message with the link, Thank you very much for your concern, I'll get to it asap.

avatar image Polivantage Apr 09 '16 at 07:10 PM

is there a way for me to send you the link privately? I do not mind others peeking in parts of the project, but some things I would like to keep private for the time being, also it is not a project I would show to my under aged sister, for example, because of the amount of details, mainly around the pelvis area of my characters. I should say I'm morphing certain body parts off and away where needed, but they do persist in their primal appearance outside the PIE sessions, please do not be alarmed, i'm not into any kind of bad activity, in fact its my personal baby project so far. On top of that all my clothing had to be removed so things got really obvious. Anyhow, I will try to find your forum account, perhaps, I remember doing similar sending in the past, it would be a lot easier for me though if you could provide me the link. Thanks again, Leo.

avatar image Polivantage Apr 09 '16 at 07:54 PM

I have sent you a google drive link to my project as a private message to your forum account I found through a google search. Included is also a simple text file with a few instructions about the inventory system I have employed and some other useful information on what was stripped, and how to disable the safety on the gun to fire it for example. Thanks again, I look forward to your insight.

avatar image Adam Davis STAFF Apr 11 '16 at 05:52 PM

Hi Polivantage,

Thank you for the project. I am having a look through it, however I've run into a small snag. I cannot find the functionality for picking up items. Can you show me in a screenshot where this is located? The pickup action is not currently working on my end and preventing me from accessing the gun to pick it up.

avatar image Polivantage Apr 11 '16 at 06:11 PM

The (e) key branches off into telekinetic or normal object handling depending if you are in magic mode (t), if you are in combat mode(r) nothing will work. First person is enabled with(v). So in neutral mode in which you start off, if you press (e) shortly aiming at the item, it will add it to the inventory with a short delay of about 0.15 sec, if you hold the (e) key, you will just carry the item around cosmetically until (e) is released. In magic mode (e) does telekinesis, whereby mouse wheel controls the distance. Simplest way to pickup an item is go first person mode(v) and tap (e) once aiming at the item, I'm really sorry for the inconvenience, it's all under construction.alt text

ekey.png (500.8 kB)
avatar image Polivantage Apr 11 '16 at 06:19 PM

[1]: /storage/temp/86361-grabinteraction_charbp.png

avatar image Adam Davis STAFF Apr 11 '16 at 10:08 PM

Hi Polivantage,

Thank you for the update. I have been able to pick up the pistol and turn off the safety, however thus far I have not seen any firing action or experiencing a crash when I press LMB. Do you have any other steps I can take to reproduce this crash with the provided project?

avatar image Polivantage Apr 11 '16 at 10:26 PM

whenever I do that it still instantly sends me to desktop, with iKinema working, if the animations are working it should fire, if you can't enable iKinema, bypass it in the animation graph. If the animations are showing, you can try picking up two pistols, equipping them both by consecutively pressing the equip button in the inventory (dual wield mode), then both mouse buttons should be firing a pistol each. Now that iKinema is working I will strip and upload my current version just in case where the crashes persist.

avatar image Polivantage Apr 07 '16 at 09:49 PM

I now think, looking in the log, that perhaps its the accumulation of sounds (shot, impact, shell) and that the concurrency can't handle overloads or something

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question