x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

GearVR project just goes black after vertical movement

Not really sure if this is some sort of issue with my phone or GearVR, but it really looks odd since it only happened with a single project so far.

First some hardware/software/system stuff:

  • Samspreung Galaxy S7 (SM-G930F, european Exynos version)

  • running Android 6.0.1 Build MMB29K.G930FXXU1APB4

  • GearVR came with the phone, not sure if that edition has a name (like the "Innovators edition" that came out some time ago)

  • Project created with 4.11 Preview 5 (which was more like "let's see how well it works")

  • Project lastly built with both 4.11.0 and 4.11.1

  • Built for Minimum/Target SDK Version 19 (since the Tooltip said "Set to 19 for GearVR")

  • NDK API Level is android-22, SDK API Level is matchndk (in case it matters)

So, what happens with that particular project? It's supposed to be some sort of ArchViz stuff I made based on some blueprints (the paper stuff that has room measurements) and put some furniture in to see what it might look like when it's actually built.

Putting it in the GearVR works fine for the first time, I can look around and do all sorts of things...mostly. Sometimes even the first run fails when I perform a vertical motion (looking up or down) while horizontal movement seems to be fine. With the second and later tries, it seems to happen more quickly then for the first run after booting the phone (and sometimes even with non-vertical motion; and varying time until it happens).

The weird thing: a blank First Person Template build with the same settings created in 4.11.0 seems to do just fine. And so do official GearVR apps from the Oculus store.

Edit: I just migrated the Level into the FP Template project, and it shows the same behavior there. I haven't played around with the FP Template sample map long enough to experience the problem, but it might actually be related to my level? It started off as Desktop project and still is, so the settings are on High quality rather than mobile. But then again, it's a simple ArchViz project with low-poly boxes and stuff for cupboards/tables/other surfaces; so I don't think it should be of relevance.

Also: for other apps (regardless of whether it is the FP Template or Oculus GearVR apps), taking the headset off closes them properly. When this happens for the affected ArchViz project, it stays open in the background (but doesn't seem to work when being reselected).

From adb logcat, one of the prominent pieces is this:

04-08 15:55:48.350 18559 19721 I OVR     : DeviceManagerThread - poll error event 60 (Tid=19721)
04-08 15:55:48.350 18559 19721 I OVR     : OVR::Android::HIDDevice - ReadError: fd 60, ReadBufferSize 96, BytesRead -1, errno 5
04-08 15:55:48.350 18559 19721 I OVR     : OVR::Android::HIDDevice - Lost connection to vid=04e8:pid=a500:ser=R322XXU0AOJ1
04-08 15:55:48.350 18559 19721 I OVR     : DeviceManagerThread::RemoveSelectFd 60 (Tid=19721)
04-08 15:55:48.350 18559 19721 I OVR     : OVR::Android::HIDDevice - Closed vid=04e8:pid=a500:ser=R322XXU0AOJ1
04-08 15:55:48.350 18119 18213 V VRSVC   : (HmtSensorObserver.java:34) onEvent [onEvent() event=512 path=ovr0 isVRMode=true]
04-08 15:55:48.350 18119 18213 V VRSVC   : (HmtSensorObserver.java:36) onEvent [sensor detached!]
04-08 15:55:48.350 18119 18119 D VRSVC   : (LogEvent.java:113) TcYL [OnDeviceEvent onSensorDetached hmtConnected=true]
04-08 15:55:48.350 18119 18119 V VRSVC   : (HmtSensorObserver.java:40) TcYL [OnDeviceEvent onSensorDetached() finished. elapsedTime=0]
04-08 15:55:48.350 18559 19721 I OVR     : OVR::SensorDevice - Closed 'vid=04e8:pid=a500:ser=R322XXU0AOJ1'
04-08 15:55:48.350 18559 19721 I OVR     : PhoneSensors::~PhoneSensors()
04-08 15:55:48.360 18559 19721 I OVR     : OVR::Android::HIDDevice - Shutdown vid=04e8:pid=a500:ser=R322XXU0AOJ1

...as if the phone was detached or something like that - so I'm not certain if this is actually a hardware issue. But then again, why do other GearVR apps work? In the meantime, I did some further testing with other forum members and exchanged builds - which work just fine, and have the same reports; so I'm not sure if that message is even related to the issue.

I already tried to clear the Intermediate/Build/Binary folders and Full Rebuild before creating a new apk/obb, to no avail apparently. I suppose the only thing I didn't try yet was recreating the project on 4.11.1 and reimporting the contents (which might be some work, so I'm hoping I don't have to).

I also tried the promoted branch in the mean time, which seems to have solved the problem (at least I had no black screens yet).

Any ideas on what could be going on there or what else I could try?

Plus, I hope the bullet list and the log look fine after posting; the Preview looks terrible in here.

Product Version: UE 4.11
Tags:
more ▼

asked Apr 08 '16 at 02:50 PM in VR

avatar image

BhaaL
146 8 11 20

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

4.12 Preview 1 and promoted on GitHub seem to have fixed this; not sure if its a 4.11 Problem that got squashed in the mean time.

more ▼

answered Apr 30 '16 at 01:40 PM

avatar image

BhaaL
146 8 11 20

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question