x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't hold LMB to sculpt or paint landscape

Hi!

I can no longer click and hold LMB to continuously sculpt on landscapes in 4.11 (or 4.11.1). At first, I could hold LMB and if I was sculpting it would keep raising the terrain. Now it will do the action once where I clicked and will not keep applying it as I move my mouse. If I click OUT of UnrealEditor and click back IN (so that where I click will cause a sculpt action) it will do the action multiple times as if I had held the mouse button in. But then it stops immediately. This seemed to start when I was configuring a terrain to paint with a multi-layered landscape material, I first noticed it when I tried to paint and it did this. Sculpting had been working just fine prior to that point but then after I tried painting for the first time and that didn't work, it didn't work for sculpting anymore. This was all while running the same instance of the Unreal Editor. When I added an earlier version (4.10.4) after this started happening, it worked just fine for the earlier version on a new project.

I tried the following:

Adding a new, simpler terrain. Rebuilding all. Exiting Razer Synapse (I use a Razer DeathAdder Chroma corded) and restarting UE4. Plugging in another mouse (HP corded mouse, plain no software needed). Restarting my computer. Upgrading to 4.11.1. Starting a new project and adding a really simple terrain, no paint. Uninstalling Unreal Engine and the Launcher and reinstalling.

Product Version: UE 4.11
Tags:
more ▼

asked Apr 10 '16 at 03:21 PM in Using UE4

avatar image

mrtupins
6 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Figured this out after a ton of fiddling around, I had to delete (backing it up first) my settings in %localappdata%\UnrealEngine\4.11 in order to get this working again. Keep in mind, if you're using a different UE4 version, then delete your respective version.

more ▼

answered Apr 24 '16 at 03:13 PM

avatar image

mrtupins
6 1 2 3

avatar image gamedev11 Apr 28 '16 at 06:55 PM

Hey there,

I'm also having this issue as well, however I deleted both the configs in my project directory and appdata and the issue still persists. Did you have to do anything else to fix the issue?

avatar image gamedev11 Apr 28 '16 at 07:34 PM

I've seemed to resolve the issue by closing my secondary editor viewport (which was assigned to 2D top), which i suppose was interfering with my 3D viewport and sculpting. Thanks!

avatar image lolwatno Jun 20 '16 at 04:39 PM

Sorry I'm newer to this so I'm not sure what you mean about secondary viewport but I also resolved it by maximizing my 3D viewport out of my 4 pane layout.

avatar image mrtupins Apr 28 '16 at 07:51 PM

Cool, good to know. Quite a bizarre issue to have. I was going to suggest that maybe you deleted the folder for the wrong version.

avatar image WilliamHooper May 14 '16 at 09:11 PM

Ya'll saved an old man from a panic attack... thanks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question