x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Emissive Material doesn't glow

I am pretty new to Unreal so my apologies if this is something really simple. I have tried many different things in the last few days in order to get it to work and am a bit stumped (last time i was stumped like this it was a single checkbox in a parameter that i didn't know existed, so maybe its easy!).

My emissive materials don't glow. I created one following this tutorial :

https://www.youtube.com/watch?v=ywd3lFOuMV8

In my beam, this is what happens when my initial color blue is set to .8,

alt text

And this is what happens when blue is set to 50:

alt text

Since the particle color is mulitplied by the gradient, it should definitely be pushing it past 1 (which is when glowing should happen). I have my settings all set to epic. This is what it looks like in a basic scene: Any thoughts? alt text

Product Version: UE 4.11
Tags:
firstbeam.png (9.5 kB)
secondbeam.png (9.1 kB)
inscene.png (31.6 kB)
more ▼

asked Apr 10 '16 at 04:47 PM in Using UE4

avatar image

rcushman
33 1 2 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Ah! It turned out that I had accidentally unchecked the "mobile HDR" box in the preferences and that seems like it did it. I had toggled it on and off a few times previous, and it didn't change anything (no glow reappeared), but if i toggled it back on, closed the program, than opened it again, glow is on!

more ▼

answered Apr 11 '16 at 07:01 AM

avatar image

rcushman
33 1 2 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

can you show us/me your material setup?

more ▼

answered Apr 10 '16 at 04:51 PM

avatar image

Luos
8.8k 281 57 322

avatar image rcushman Apr 10 '16 at 04:57 PM

Sure! Here:alt text

alt text

materialsetup.png (119.2 kB)
matsetup2.png (122.8 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hmm, try putting another multiply between the multiply and emissive color, and multiply by 10 :)

(Left multiply is the multiply you have between particle color and emisive color: alt text )

more ▼

answered Apr 10 '16 at 05:24 PM

avatar image

Luos
8.8k 281 57 322

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

If you want the glowy aura around it, you need to enable bloom in your camera. If you want it to emit light on the scene, you need to mark it as static and build the lighting.

more ▼

answered Apr 10 '16 at 05:26 PM

avatar image

Velsen
141 3 5 5

avatar image Velsen Apr 10 '16 at 05:40 PM

Oh yeah also forgot, make sure that in the Lighting tab of your mesh you enable Use Emissive for Static Lighting, otherwise even if it's static it won't emit light on the scene.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question