x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

GenerateProjectFiles not generating directories, definitions, classes

I am on a Linux machine with UE 4.11 installed, built it and can run the editor with no problem. I have installed it in the Download folder:

 /home/me/Downloads/UnrealEngine/

I am following this tutorial for setting up a cmake environment to do my C++ development in CLion. If I understand the tutorial correctly, I am supposed to have a template game first. I tried going for a blank c++ project and called it BasicCodeNoStarter. It is stored in:

 /home/me/Documents/Unreal Projects/BasicCodeNoStarter/

I then go on the terminal and:

 cd Downloads/UnrealEngine/ && ./GenerateProjectFiles.sh -cmakefile -game -project "/home/me/Documents/Unreal Projects/BasicCodeNoStarter/BasicCodeNoStarter.uproject"

When I do that, I get:

 UnrealBuildTool Exception: ERROR: Directory '/home/me/Downloads/UnrealEngine/Engine/Source/Projects/BasicCodeNoStarter' is missing 'Source' folder.

It looks to me like it is creating a directory inside my engine installation and failing for some reason. Although I had files in the source directory of my project:

 ls "/home/me/Documents/Unreal Projects/BasicCodeNoStarter/Source/BasicCodeNoStarter"
 BasicCodeNoStarter.Build.cs     BasicCodeNoStarterGameMode.h     BasicCodeNoStarter.cpp
 BasicCodeNoStarter.h     BasicCodeNoStarterGameMode.cpp

I tried adding a class MyActor there and after I did that, Unreal editor compiled the project automatically but that does not change anything. Running GenerateProjectFiles.sh still returns the same error.

UPDATE

I managed to get it to build by manually creating the source folder:

 mkdir /home/me/Downloads/UnrealEngine/Engine/Source/Projects/BasicCodeNoStarter/Source 

and the CmakeLists.txt gets generated for me and I no longer get the error. However,

-The directory /Engine/Source/Projects/BasicCodeNoStarter/Source does not get populated.

-The c++ class that I had added to my project through Unreal's IDE, namely MyActor, is nowhere to be found. It is not in the source directory ^ nor is there any sign of it in the CmakeLists.txt file.

  • include_directories and add_definitions both have empty argument lists in the cmake file.

My guess is that I am missing a step before running the build tool. Any idea what?

Product Version: UE 4.11
Tags:
more ▼

asked Apr 11 '16 at 04:47 PM in C++ Programming

avatar image

Shah29
6 1 3 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question