x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Directional light's dynamic shadows don't work

Hi all, I'm having a problem with getting dynamic shadows from directional light to work on MY pc (when I open my scene on a machine in my university the shadows are there). Also point lights cast dynamic shadows without any issues, my problem is strictly with the directional light, and it happens in every scene on my PC. I tried upgrading to UE 4.11, but that didn't fix it either. Do you guys think I need to reinstall my UE, or is there a known solution. Many thanks!

Product Version: UE 4.10
Tags:
more ▼

asked Apr 12 '16 at 01:26 PM in Rendering

avatar image

McTwark
6 1 2 2

avatar image McTwark Apr 12 '16 at 12:06 PM

A little update on the situation. I completely removed Unreal engine from my PC,then installed it again and my problem is still there,no dynamic shadows from directional light at all. Then I uploaded my project on a friend's machine, and the shadows were there. It's really frustrating because I can't think of a reason why that would happen. I also tried deleting all my light from the scene and adding new ones, didn't fix it. I tried importing project settings ini. from a computer where the shadows were visible, didn't fix it either. So, I'm out of ideas.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

worth checking the scalabiltiy settings are the same on your pc at home. try turning the settings all to epic in Settings>engine scalabiltiy settings. its also worth checking that you have dynamic shadows tick on in Show>LightingComponents .

i hope that helps.

more ▼

answered Apr 12 '16 at 01:54 PM

avatar image

r8ivy
199 9 11 27

avatar image McTwark Apr 12 '16 at 02:37 PM

It was the scalability setting I can't believe I didn't think of that, and none of my tutors and peers thought of it either. Thank you so much, you made my day!!!

avatar image r8ivy Apr 13 '16 at 08:16 AM

its always the last thing ;) glad it worked out

avatar image Goknub Feb 03 '18 at 07:28 AM

Thank you for that suggestion, that was my issue too.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question