x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Matinee - Out of memory

Hello,

I don't know if it's really a bug or if I've made something wrong.

When I "Record Movie" in matinee (.jpg / 30fps / stream texture or not), the computer start to go out of memory and finish by a BSOD.

The memory used by the UEeditor process increase very fast ( about 100-200Mb/s), after 1 minute my memory (16Gb) is full and start to swap. Pagefile.sys is managed by system and I think the system limit it to about 25Gb. And Windows alert me that I run out of memory. I can avoid BSOD by shuting down the editor fastly after the Windows alert. I want to record a sequence of 3-4 minutes, but crash occurs at 2 minutes and few seconds.

My Spec: Core I7 3770k / 16 Gb of RAM / Plenty space on differents SSD/ GTX 960 4Gb Any ideas?

thanks by advance

Product Version: UE 4.11
Tags:
more ▼

asked Apr 12 '16 at 02:51 PM in Bug Reports

avatar image

Metathesus
125 7 10 13

avatar image Metathesus Apr 14 '16 at 09:16 AM

I've been able to export the video frames with command line (only 2 or 3Gb of RAM used instead of more than 40Gb....)

 "C:\EditorPath\ue4editor.exe" "ProjectPath\ProjectName.uproject" -game Content/Maps/LevelName.umap?-ResX=1920 -ResY=1080 -BENCHMARK -FPS=30 -MAXQUALITYMODE -DUMPMOVIE -NOTEXTURESTREAMING -FULLSCREEN

All is exported in Png, very long and voluminous, but it works.

So if you have any ideas of to make "Record Movie" works in matinee, I will be happy to read you.

avatar image Matt.Williams Apr 14 '16 at 07:49 PM

Hey Metathesus,

Can you send me a screenshot of your Render Settings window? I'd like to see all of the settings you're using. A setting that might help you out is "Use Separate Process".

I can't seem to reproduce the memory increase. Are you able to reproduce this on a basic template project?

-Matt W.

avatar image Metathesus Apr 14 '16 at 08:26 PM

Hey Matt,

I've tried with a the template project "First Person", the problem does NOT occurs.

Screenshots here:

alt text

alt text

If you needs some obscures logs, I can send them to you after you specify me what exactly you need to debug.

Thanks for your time!

capturea.jpg (297.0 kB)
captureb.jpg (224.9 kB)
avatar image Matt.Williams Apr 18 '16 at 05:47 PM

Can you check your output log for any log spam? Look for some Access None errors, that kind of thing. Can you try a "Play in New Editor Window"(No rendering) and let me know if that also causes a memory increase?

-Matt W.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello,

After your request, I test and It seems the bug go away.

I've made a lot of changes on my project (most on BP) , so I don't know what changes made the trick.

If you really need to track the bug, I can restore an old save for UE4 Development and check if the bug was present.

Thanks for your help

more ▼

answered Apr 18 '16 at 06:38 PM

avatar image

Metathesus
125 7 10 13

avatar image Matt.Williams Apr 18 '16 at 07:12 PM

Hey Metathesus,

That's great! It may involve a lot more testing to track down, but might be easier now that you have broken/working versions of the project. The first thing we'd do is get a copy of the output log. We'd also run a memreport and see if we can track the problem there.

So it's up to you if you'd like to continue investigating.

-Matt W.

avatar image Metathesus Apr 18 '16 at 07:59 PM

After Investigations on a backup, I'm pretty sure that my bug come from this function (in my custom skysphere) on "Event Tick" instead of "Event Begin Play"

Now Movie is OK and I haven't a performance drop after one minute of gameplay.

alt text

My Output Log was showing nothing interesting about that.

capture.jpg (51.4 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question