x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Error: RunUAT.bat ERROR: AutomationTool was unable to run successfully.

About a week ago I started having problems cooking my project, each time with the error RunUAT.bat ERROR: AutomationTool was unable to run successfully. Around this time, I started messing around with matinee, in addition around the same time I made a copy of my original map file which I'm currently working with. I've read in similar posts that creating a copy of your map file will cause this problem, however I don't know how to fix it and its not like I can just restart from scratch.

Things I've tried:

  1. Moving the original map file to a separate location

  2. Moving the duplicated map file to a seperate location, then cooking the original outdated map file

  3. Cooking a different map file within the same project file

  4. Creating a new project file and copying the content folder from the original project file, then repeating step 1

I'm at a loss here.

output log

Product Version: UE 4.10
Tags:
outputlog.txt (2.6 MB)
more ▼

asked Apr 13 '16 at 04:24 AM in Packaging & Deployment

avatar image

lostdexter
18 4 10 12

avatar image lostdexter Apr 15 '16 at 06:17 PM

It's been two days and still haven't figured anything out.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello lostdexter,

The "AutomationTool was unable to run successfully." message essentially means that the build failed and will be listed whenever the build fails in most cases. The actual errors that are causing it to fail can be found further up in the log. It seems like the error that is causing your build failure is this one:

LogPackageName:Error: DoesPackageExist: DoesPackageExist FAILED: '/Game/FirstPersonBP/LightBeams/1_14 - Copy' is not a standard unreal filename or a long path name. Reason: Name may not contain the following characters:

While it seems like it cuts off early at the end, it's trying to say that filenames in UE4 cannot contain a space. Can you try removing the spaces in the "1_14 - Copy" name and see if the packaging process will work then?

more ▼

answered Apr 15 '16 at 06:29 PM

avatar image lostdexter Apr 15 '16 at 06:36 PM

Thank you so much, that solved the problem. I guess since it had spaces, it also didn't show up within the editor so I had no idea that file was even there.

avatar image Matthew J Apr 15 '16 at 06:37 PM

I'm glad to hear that the issue was so simple.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question