x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android Dev Setup - Missing Components

Having trouble with getting past.... alt text

I have followed, http://docs.unrealengine.com/latest/INT/Platforms/Android/GettingStarted/index.html?utm_source=editor&utm_medium=docs&utm_campaign=tutorials

  • Installed all from AndroidWorks without error.

  • Checked the Win 7 Environment Variables. Attempted various on UE 4.11.1, 4.10.4, 4.9.2, VS2013CE, VS2015CE.

I also note that the Android phone doesn't show up in the UE4 device manager. 'adb devices' sees the phone.

The linked "Android Quick Start" help doc from UE4.11 was written for UE4.9. Not sure if this is relevant.

Is there a way to debug exactly which components are missing? I can't find any log to indicate what to try next. Any help with direction would be appreciated.

Product Version: UE 4.11
Tags:
ads.jpg (40.6 kB)
more ▼

asked Apr 13 '16 at 05:38 AM in Packaging & Deployment

avatar image

AlanAlan
13 4 7 9

avatar image MitRA Jun 18 '16 at 02:04 AM

Same problem. The main issue is that the error message gives zero information about actual problem.

avatar image DesertEagle_PWN Mar 20 '19 at 04:09 AM

Make sure also that all of your Android SDK paths in Project Settings > AndroidSDK are correct as well. If you're like me and updated from an old SDK you may have accidentally missed changing those. Though it really would help if this error was more insightful or useful.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

SOLVED. Installed on my new MSI GT80. Everything works. UE411, VS2015, No Tegra. Still don't know why not on the other machine. Could be in some log somewhere. Anyone else having same problems, I would be happy to try and help.

more ▼

answered Apr 15 '16 at 07:18 AM

avatar image

AlanAlan
13 4 7 9

avatar image paul.jan725 Sep 12 '16 at 08:14 PM

Hit this when updating my AndroidWorks from 1R4 to 1R5. Solved by manually setting new locations for Edit Menu > Project Settings > Android SDK.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hit the same issue. All the answers so far have been specific to individual solutions, so I had to track down a little further.

The sdk setup validation is done via UnrealBuildTool, executed from TargetPlatformManagerModule.cpp :: SetupSDKStatus()

You can iterate a little faster than through the editor: run /Engine/Binaries/DotNET/UnrealBuildTool.exe -validateplatform -platforms=Android

you can add -verbose, but it doesn't actually print anything useful.

In your IDE, set UnrealBuildTool as the startup project, set the parameters above for launch, and add a breakpoint in UEBuildAndroid.cs :: HasAnySDK()

step through, and you can see what values are actually being used for the validation step, and what it is expecting / what it can't find.

Epic: it would be nice if -verbose actually printed something useful in this situation.

more ▼

answered Oct 04 '16 at 06:22 PM

avatar image

VictorRachels
226 7 5 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question