Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Scene capture 2d component potential bug


I'm doing a building system for a tower defense game, everything is working fine etc. I want to be able to do a camera preview toggle system which allows you to see what the tower looks like from a top orthographic view and is rendered onto a UMG widget image. I have made 1 scene capture component in my scene and make it attach to a scene component inside my blueprints (there's probably a better way of doing it but this seems to work fine).

Anyway every time that i test it out it mostly works great but I have 2 lines on the top left corners which seem to be showing a different camera or something i'm not entirely sure, i'll provide a video if needed but i've took a screenshot. I'm not entirely sure but i think i started getting this when i upgraded to 4.11 as i can't remember this happening in 4.10.4, so it may be something to do with the new changes in the material editor?

Does anyone recognize what is going on? is this a bug in the new 4.11? or is it something i'm doing wrong?

Hope someone can help, thank you in advance, screenshots below. -Connor

alt text alt text alt text alt text

Product Version: UE 4.11
screenshot1.jpg (152.2 kB)
screenshot 2.jpg (92.1 kB)
screenshot 3.jpg (135.0 kB)
bp1.jpg (56.7 kB)
more ▼

asked Apr 13 '16 at 06:08 PM in Bug Reports

avatar image

19 10 16 16

avatar image Rudy Q ♦♦ STAFF Apr 14 '16 at 03:37 PM

Hello Conno,

I could not reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. If you delete your saved, intermediate, and config files before upgrading the project, does this make a difference?

Note: You may want to make copies of the files before deleting them in case you need them later.

avatar image Conno Apr 17 '16 at 01:34 AM

Hi, thank you for the reply and giving some time to help, apologies for the long reply I have been busy at university. I have made a new level in my current game and tried to reproduce and it still makes these weird lines.

In my new scene these are the components which exist and factor:

  • Camera actor blueprint (it is just a single blueprint with a capture scene 2d inside)

  • Blueprint with trigger and arrow component, when the player steps inside the trigger the camera actor blueprint changes to the location of the arrow

  • HUD, my UMG component is linked to the camera render material

The effect i want happens perfectly as intended but it's like it's random or something. I'll attach screenshots and link the video, i'll also try to replicate it on a fresh project. Removing the Saved file does not affect anything either.

Link to bug video: https://youtu.be/pu7FadDQuqU

Edit: I've just realized that the lines see straight through my border image behind the camera if that's important? also if its to note 4.11 made the UMG component completely invisible and defaulted the alpha to 0 so I had to turn the alpha to 1.

Thanks again, Connor

alt text alt text

alt text

bp help 1.jpg (35.3 kB)
bp help 2.jpg (173.5 kB)
bp help 3.jpg (190.9 kB)
avatar image Rudy Q ♦♦ STAFF Apr 22 '16 at 02:07 PM

Hello Conno,

Thank you for the additional information. I noticed that you said you created this issue in a new level, however I will need you to recreate this issue in clean project with new assets. This will help narrow down the cause of the issue that you are having.

avatar image Conno Apr 23 '16 at 08:43 PM

Hi again,

I've made a new project and I was able to reproduce the issue. I made a third person template and made a series of items again, I've uploaded a screenshot so you can try reproduce the issue.

To clarify, my intention is to have a 2d scene component render an overlapped actor blueprints as a preview type system and have that 2d scene component render the current to a UMG image using the render material. I want to be able to switch between what the camera is seeing depending on what trigger the player is overlapping. I didn't think that having a scene component in every instance of the actor blueprint would be cost effective so I thought that if i just have one 2d scene component placed anywhere in the scene and have it simply move to the location of where the player has overlapped that would be the best approach. It works great as intended but it seems as if the camera is constantly changing location I'm not sure, hence the weird lines in the top left of the camera render. Apologies I'm bad at explaining.

this is an oldish version of my game which includes the preview system but on a toggle, I've decided not to have it on a toggle and appear upon overlap but either way causes the same issue, feel free to watch: https://www.youtube.com/watch?v=z42aRB1FIf0

alt text

alt text

avatar image Conno Apr 25 '16 at 12:42 AM

Apologies for the double post, I think that i may have fixed it. I changed the render texture size down to 512x512 and the weird lines/weird flashes seem to not appear anymore.

Edit: i seem to still be getting the lines in editor but i cant seem to replicate them again during playing in a standalone game

confused, maybe a bug?

avatar image Rudy Q ♦♦ STAFF May 02 '16 at 01:35 PM

Hello Conno,

Thank you for all of the information that you have provided. However, after running a few more tests based on the information given I have not been able to reproduce this issue on our end. Could you please provide the blank project used to recreate this issue? This will allow me to take a closer look at what is going on.

avatar image Conno May 04 '16 at 12:32 AM

Hi again,

I've uploaded my blank project to a git hub repository, fairly new to git hub so hopefully it will work.


Made using 4.11, it might get an error when you load, not sure why but it plays as expected. Hope you can find out what the cause is.

Cheers, Connor

avatar image Rudy Q ♦♦ STAFF May 09 '16 at 05:28 PM

Hello Conno,

After looking through your project and running a few tests, I was not able to reproduce this issue on our end. I did notice that you have constrain Aspect Ratio for your camera set to true in the examples above. While changing this on our end has no effect, could you try turning this off and let me know if this helps?

avatar image Conno May 10 '16 at 01:02 AM

Hi again,

I didn't notice that I had constrain aspect ratio on - you are on about my camera on the third person blueprint right? I've tried turning that on and off to no avail. I can't understand what's going on, it's as if the 2d scene capture component duplicates itself and plays another instance on top of it or something I'm really not sure. I'm going to update to the latest version of 4.11 and will edit this post to see if it still happens.

P.S - i think in my project which I provided you the blueprints have been rotated the wrong way, they need to be rotated like this below but regardless this doesn't change anything.

alt text

edit: updated to the latest version of 4.11 and i'm still getting the 2d camera bug shown here(it seems like a 50/50% chance that it happens on the top left and top side of the player screen if that makes sense):

alt text

correct pos.jpg (35.3 kB)
still bug.png (687.6 kB)
avatar image Rudy Q ♦♦ STAFF May 13 '16 at 03:00 PM

Hello Conno,

I have run a few more tests on your project, however I was unable to reproduce this issue on our end. Could you tell me what engine scalability settings you are using?

avatar image Conno May 14 '16 at 01:20 AM

Hi again,

I am always usually on Epic quality but I've tried switching to other quality settings but to no avail. I've made sure to update all my drivers in case it's anything GPU related and doesn't seem to be. Is there anything else I could do to help you replicate this?

Cheers, Connor

avatar image Conno May 15 '16 at 05:47 AM

Apologies for the double post, something else is happening which I believe is related to this strange occurrence. I'm in the process of implementing a custom character in engine and whenever my character generally moves my screen all of a sudden becomes somewhat foggy with light and the same 2 camera lines appear on the left and top sides of my screen (the big ones). The foggy type effect is somewhat like auto exposure, though I've made it so the maximum and minimum are both 1. I haven't even got a camera 2D scene capture in my scene, so could this be just a camera related issue overall? (this isn't in my blank project btw)

Edit: Resetting auto exposure back to default did nothing.

Edit: I deleted the camera on my main game which stopped the bleeding/foggy effect for some reason, I tried remaking the camera on my example project but the lines on the left and top still come up on the 2d camera preview render.

I've uploaded a video here if you can watch: https://www.youtube.com/watch?v=t9KvVBP0Bxc

Screenshots: alt text alt text

lines 1.png (851.3 kB)
lines 2.png (984.5 kB)
avatar image Rudy Q ♦♦ STAFF May 19 '16 at 03:00 PM

Hello Conno,

Thank you for all of the additional information, however could you provide your dxdiag?

avatar image Conno May 22 '16 at 10:06 PM

Apologies for the later response as usual, here is my dxdiag, i hope it helps. I think the bug doesn't happen when I have build the game but I can't say for sure.

link text

dxdiag.txt (51.4 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Conno,

After doing some more digging in our report database I was able to find that this is a known issue (UE-11109) and that it has been submitted to the developers for further consideration. I will be sure to bump up the community interest for this issue for you. Thank you for your time and information.

Make it a great day

more ▼

answered May 24 '16 at 08:01 PM

avatar image

Rudy Q ♦♦ STAFF
47.4k 545 132 525

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question