x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

LogStats:Warning: MetaData mismatch

LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//FLauncherTask///Thread_19e4_0///####STATCAT_Advanced#### old //STATGROUP_Threads//FLauncherTask///Thread_2028_0///####STATCAT_Advanced####

Guys got this warning while building for WEBGL, i understand its an error of ambiguous names. Kindly let me know where i can change and how. Im new to unreal.Thank you.

Product Version: UE 4.11
Tags:
more ▼

asked Apr 14 '16 at 09:49 AM in Bug Reports

avatar image

Andyram
1 1 3 3

avatar image Doug E ♦♦ STAFF Apr 14 '16 at 02:18 PM

Hey Andyram-

Is this an output from building/compiling the project or from attempting to package the project? Could you provide the full log file where these lines appear? Does this reproduce in a new project with no added content and if so, can you list the steps that reproduce it?

avatar image Andyram Apr 14 '16 at 03:42 PM

Hi Doug, Here are the steps which i followed and have attached the out put log file with error.

This are the steps i took to make the level

1) Open First person map.

2) Created a new level

3) Added Mesh in the world

4) Made Blueprints for the material to get the desired effect on the mesh

5) Added Lights depending on the need in the level

6) Added one skybox

7) Added Post process Volume

8) Added Lightmass Volume

9) Build the light

10) Added Collision mesh and gave it collision properties and made it invisible in the level

11) Converted it to HTML 5 Build ( Started with default setting for lights and the level )

12) Launching it in HTML 5 and this is whlink texten i get this error and the mesh is not visible on the web browser

Screen shot of the web playeralt text

output log.txt (357.8 kB)
error (1).jpg (147.7 kB)
avatar image Doug E ♦♦ STAFF Apr 14 '16 at 04:14 PM

Looking at the logs, it appears the project packaged successfully, so it seems there may be something wrong with something in the package or something may not be setup correctly and causing the error. I started to follow your steps to reproduce but I'm not sure what mesh you're referring to adding to the world? Was it added in the newly created level? Also, what did you add to the blueprint / what were the desired effects? Please be as clear and detailed with the reproduction steps so that I can follow your setup as closely as possible. If you are using custom meshes/materials, could you provide those as well? If it's easier, can you supply a sample project that demonstrates the error?

avatar image Andyram Apr 14 '16 at 05:19 PM

Hey Doug, i was working on Archviz, yes i created a new level in 3ds max and most of the mesh contain sub material. And by blueprint i mean i created materials in blue print material and used some of the material from the engine.

Adding to this we have a collision issues near the steps in first floor, where the player falls off once he steps down however the player walks fine in other areas of the house. Unreal tutorials and documents were referred while doing this.

I have shared the complete file here https://we.tl/7hQa2Sm1eI it's 1.6 GB , if you feel the file size is huge, i can share my work through team viewer. Kindly let me know in that case.

avatar image Doug E ♦♦ STAFF Apr 14 '16 at 06:12 PM

After opening the sample project you posted, what steps need to be done to experience the issue? I believe I need to package the project for HTML5, however what needs to be done after that point?

avatar image Andyram Apr 14 '16 at 06:17 PM

Yes Exactly, You can also open final 3 project which is present in Geometry folder and launch in HTML5

avatar image Andyram Apr 15 '16 at 01:08 PM

Hey Doug, Any updates ?

avatar image Doug E ♦♦ STAFF Apr 15 '16 at 01:46 PM

I did test the sample project you sent me and was able to package for HTML5 and have the game open and allow me to walk around the house. When you package the project, let me know if refreshing the page (F5) has any affect.

avatar image Andyram Apr 15 '16 at 02:10 PM

Hey Doug, I wonder how its possible, did you make any changes or used any sort of plugins or drivers ?. I'm using normal unreal engine, and i used 4.10 version for this project. Can you please guide me with the steps you took before packing it to HTML5 And i assume the refresh is for HTML page and again no luck with that kindly let me know your engine version too .

avatar image Andyram Apr 15 '16 at 03:29 PM

Kindly let me know, have stuck at this stage from past 2 days.

avatar image Andyram Apr 15 '16 at 05:05 PM

Doug, a gentle reminder, could you just update me on this ?

avatar image Doug E ♦♦ STAFF Apr 15 '16 at 05:49 PM

Hey Andyram-

Asking for a status update is understandable but please refrain from bumping a post if it has been less than 4 days.

I wanted to retest the project to make sure the behavior I was seeing would reproduce. After unzipping and opening the project I pressed the drop-down arrow next to Launch and chose Chrome. Once it finished and the internet page opened, the gray bar stayed at about a quarter filled when the page finished loading. Pressing F5 caused the page to reload at which point the bar completely filled and the House_3 level opened.

avatar image Andyram Apr 15 '16 at 06:26 PM

Hey Doug, Thanks for the reply, After seeing the above suggestion i tried building and packing it to HTML via chrome option in unreal 4.11, but it seems to throw the same error. Even the refresh is of no help.

Can you please forward me the build which is working fine for you including the wegl html pages, so that i can verify once ?

avatar image Doug E ♦♦ STAFF Apr 15 '16 at 07:11 PM

This was tested using the project from the link you provided previously. The project opened in the binary version of the 4.10.4 engine. Let me know if you get the same error if you try launching using another machine?

avatar image Andyram Apr 16 '16 at 05:58 AM

Hey Doug, Dont know why but its throwing the same error in 4.10 as well. Should i try re installing the engine ?

Can you please send me the HTML out put files which worked for you ?

avatar image Doug E ♦♦ STAFF Apr 19 '16 at 08:16 PM

Hey Andyram-

I'm not entirely sure I understand what you mean by the HTML output files. If you're referring to the logs from the Chrome window after launch, you can find those logs here:

link text

If you are instead referring to the Output provided by the editor, that is here:

link text

Again, this was using the House_3 project you provided and clicking the Launch for Chrome.

chromeoutput.txt (22.8 kB)
editoroutput.txt (343.4 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Andyram,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

more ▼

answered Apr 25 '16 at 08:06 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question