x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Warning: Unknown property in after changing variable in Structure

I think this should be brought up as these seems to be a bug, after changing some variables in a blueprint Structure the log posts a load of warnings, and these come up every time i compile blueprint that use these Structures, my currently project logs around 200+ lines of these as i have changed/edited or added variables to my Structures.

 Warning: Unknown property in InventoryItem: Strength_75_0501B0854829642FFD33308F0CA4BA8A=0,Dexterity_76_EA2FB9DA4D578697BB9EBEB68971CF74=0,Intelligence_77_9022AF064DCBC523BF2829A8B9E7771B=0) 
 Warning: Unknown property in InventoryItem: Dexterity_76_EA2FB9DA4D578697BB9EBEB68971CF74=0,Intelligence_77_9022AF064DCBC523BF2829A8B9E7771B=0) 
 Warning: Unknown property in InventoryItem: Intelligence_77_9022AF064DCBC523BF2829A8B9E7771B=0) 
 Warning: Unknown property in ItemInformation: Quality_39_CBD1FAA54940E088B192D7A42622FDA0=NewEnumerator1,Amount_96_5BD0F40343BC83E7582405A59DEF24E8=1) 
 Warning: Unknown property in ItemInformation: Amount_96_5BD0F40343BC83E7582405A59DEF24E8=1) 
Product Version: UE 4.11
Tags:
more ▼

asked Apr 15 '16 at 12:20 PM in Bug Reports

avatar image

OverRated_AU
167 7 15 27

avatar image TJ V ♦♦ STAFF Apr 15 '16 at 04:51 PM

Hi OverRated_AU,

I have seen a similar issue if a variable starts with a space. Can you double check the Variables that the warnings are referencing and see if they contain a space at the beginning?

avatar image OverRated_AU Apr 15 '16 at 06:13 PM

Nope no spacing, this is how many warnings i get from my player controller lol these seem to all be in memory as my project works just fine.

link text

log.txt (79.9 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

I was able to get the same warnings in the project that you attached (thank you BTW) and I was also able to reproduce the issue in a new blank project. I've created JIRA UE-30031 and our developers will be investigating the issue further.

Cheers,

TJ

more ▼

answered Apr 27 '16 at 07:54 PM

avatar image

TJ V ♦♦ STAFF
41.1k 1009 183 493

avatar image OverRated_AU Apr 28 '16 at 04:42 PM

Great to hear thanks for letting us know,

avatar image OverRated_AU Jul 04 '16 at 12:19 PM

Any news on the progress on this bug fix?

avatar image CriErr Jul 04 '16 at 12:32 PM

I have strong feeling those bugs are related, and here you can see some discussion about it.

avatar image OverRated_AU Jul 04 '16 at 12:37 PM

No there not related and this bug was also in 4.9 and could even date back longer than that, its not related to 4.12 i was hoping it would be fixed by now.

avatar image TJ V ♦♦ STAFF Jul 06 '16 at 06:36 PM

Hi OverRated_AU,

The JIRA is listed as a Major priority and is on track to be fixed in a future release. I'll update here when there is more news.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have had lots of problems like this. Definitely bugs. If you can find a reliable way to produce the bug, you should definitely add that here so we can an actual fix.

Workarounds - Sometimes, deleting the variable and recreating it will fix the problem. - Recreating the blueprints that emit the error have always fixed it for me. DON'T duplicate your blueprint. It just duplicates the problem. Create a new blueprint with the same parent class as the one you're duping. Create all the variables and set their defaults. Create all the functions and set their input/output paramaters and create their local variables. Then you can copy/paste your event graphs from the original blueprint to the new ones with 99% of them "just working".

more ▼

answered Apr 16 '16 at 10:24 PM

avatar image

CleanCut
2.1k 67 84 77

avatar image OverRated_AU Apr 17 '16 at 02:56 AM

The problem with recreating them is that these Structures are used in multiply places and replacing them is simple job it would take a lot of time, there should be away to clean these up without doing that, If Epic wants to track this bug down all they need to do is download the action RPG Inventory System and compile the InventoryManagerComponent and it will show.

avatar image TJ V ♦♦ STAFF Apr 18 '16 at 08:14 PM

Have either of you seen these warning outside of a project that contains the RPG Inventory System?

avatar image CleanCut Apr 18 '16 at 08:31 PM

Yes, any blueprint project I have ever worked on. I have never used the RPG Inventory System.

I used to rename variables. A lot -- until I realized the errors seem to correlate with renaming. Now I try not to rename variables.

Maybe I can come up with something reproducible...

I do my blueprinting on a Mac, by the way.

avatar image OverRated_AU Apr 19 '16 at 02:10 PM

Ill have to see if i can reproduce the bug in a new project, I'm unsure what the source of the warning are but i have tried removing the variables and re-adding them which just adds to the warnings, it seems to happen if any of the variables are changed or removed, ill try to strip down the RPG Inventory to see if i can find the source of the problem, these structures are used though out the project and also on UMG widgets.

avatar image TJ V ♦♦ STAFF Apr 26 '16 at 12:18 PM

HI OverRated_AU,

Any luck creating a test case for these warnings?

avatar image OverRated_AU Apr 26 '16 at 05:06 PM

I couldn't reproduce it on a new project, but i did take 2 assets from the ARPG Inventory and reproduced it in a blank project, this should make it easier to be fixed.

EDIT:

Well i just reproduced the bug on a new project with 2 new files with a similar setup, project link is below. Compiling the UMG widget will produce the warnings

https://cp.sync.com/dl/c42cdd850#jiv8cug9-jdjmtx3s-jbp78g9e-67dqwxfk

avatar image CriErr Apr 26 '16 at 05:21 PM

What exactly wrong with that project? I rename add and remove variables from struct and it compiles perfectly.

avatar image OverRated_AU Apr 26 '16 at 06:12 PM

Thats not the point the point is it compiles with warnings which show in the log, in large projects with lots of structure changes it can get annoying.

avatar image CriErr Apr 26 '16 at 06:34 PM

Yes, i can see it now, had it before, but i don't quite remember how i got rid of it, i guess i remake everything, that's only workaround?

avatar image OverRated_AU Apr 26 '16 at 07:06 PM

Each time you change the structure you need to remove and add back the varaible to the UMG file, but once you change the structure again you find your self doing this fix each time, and if that one structure is used and tied in with other blueprints this can get annoying and very time consuming for just fixing a warning.

avatar image CleanCut Apr 19 '16 at 10:33 PM

I was able to reproduce a similar (maybe related) condition. I posted it as its own bug report here: https://answers.unrealengine.com/questions/407784/4112-failed-blueprint-import-reproducible.html

avatar image OverRated_AU Apr 19 '16 at 11:29 PM

I don't think these are related this bug on discussion is to do with structures variables being changed or removed.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

OK I can confirm that its structure variables which are producing these warnings. I just fixed a few by setting the variable to a Boolean then compiling then setting it back to the structure then reconnecting the wires then compiling again. It seems when you change a structure the references to the following structure leave behind the old variable references in memory? so we can class this as a bug as these references should be getting cleaned up in the process, I hope this bug gets looked at as i hate to have to redo all my structure references each time i change the main structure.

more ▼

answered Apr 20 '16 at 07:48 AM

avatar image

OverRated_AU
167 7 15 27

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Have same issue all the time, but it just go away after recompile and reopen project.

Important note: If you use structure in interface, you need to compile interface before closing project or it would break all connections between structure and interface.

more ▼

answered Apr 20 '16 at 12:34 AM

avatar image

CriErr
1.2k 57 21 56

avatar image OverRated_AU Apr 20 '16 at 12:57 AM

Adding to a structure will not break connections but you will have to connect your new varibles up if your building the structure any where, i wonder if the problem is related to saved variables of that structure not being updated correctly.

avatar image CriErr Apr 20 '16 at 01:22 AM

Dunno, working on project for 6 month or something, happens to me a lot.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question