x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Visual Studio 2010/2013 conflict

When I create a new C++ project Visual Studio 2010 automatically starts telling that, of course, the project isn't supported. Is there a .ini or config file where I can specify the Visual Studio 2013 path?

Product Version: Not Selected
Tags:
more ▼

asked May 07 '14 at 11:56 AM in Installation & Setup

avatar image

Habaki
6 2 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hey Habaki,

If you are using the GitHub version of UE4, please see this post about where to change the setting for which compiler the editor uses:

https://answers.unrealengine.com/questions/31887/visual-studio-2012-on-unreal-engine-402.html

If you are using the Installed/Launcher version of UE4, please let us know.

Edit: To clarify, this is the solution if the UnrealBuildTool is defaulting to use VS 2010 instead of 2013. If this is not the accurate description of your problem, please reply and provide further detail to the steps you are taking to hit this error and also provide a screenshot of the error message you are getting.

Thanks!

-Steve

more ▼

answered May 07 '14 at 06:26 PM

avatar image

Steve Allison STAFF
4.4k 123 58 209

avatar image Habaki May 08 '14 at 08:25 AM

Hi Steve, Thank you for the answer, I'm using the Installed/Launcher version of UE4. I'll try with the GitHub version today. How do I check UnrealBuildTool default? The steps are: 1. Launch 4.0 or 4.1 from the Launcher. 2. Create a C++ project. 3. When the Editor reload to open the project VS2010 automally starts.

Thanks, -Habaki

avatar image Steve Allison STAFF May 09 '14 at 06:44 PM

Once you've generated a solution file (the .sln), when you right-click on it do you get the option to open in VS2013 instead of VS2010?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I'm having a similar problem. I actually have VS2005, VS2008, VS2010, VS2012, and VS2013 all installed on my machine. Guess I am too lazy to remove them.

In any case, I cloned and built UE4.3 and launch the editor just fine. However, whenever I created a 3rd person camera code project, it booted an instance of 2005 and crapped out on an error.

How do I force Unreal to associate VS2013? Btw, I'm currently using Express for Desktop.

more ▼

answered Aug 03 '14 at 03:42 AM

avatar image

morness
41 2 6 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Okay I figured out how to solve it. Bit of a face palm. After uninstalling 2005, 2008, 2010, and 2012 (leaving 2013), instead of launching the wrong Visual Studio, it would simply not launch at all (no error, no feedback). So I actually went and uninstalled VS2013 Express and reinstalled it, reinstalled Unreal Engine and still nothing.

The easy way to fix this is to right click on the project in Unreal Engine and go to explore. Then right click on the sln file and set "Open With" and point it to Visual Studio Version Selector. And then that fixed it for me.

more ▼

answered Aug 03 '14 at 06:32 PM

avatar image

morness
41 2 6 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question