x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to package game with plugins right way?

I've spent few hours trying to package my game right way. Unfortunately, I've met some strange issues with it.

How to package own plugins the right way? I have plugin with custom actor component, that added to blueprint actor on my map. I've tested two variants:

A. Plugin added to game project and turned on. It can be used in editor now and it works as it should without packagin. But despite I can see its content among packaged files, the desired component doesn't work in packaged game.

Is it expected behaviour of plugins system?

B. Plugin was added into "PublicDependencies" of the game project. It works okay now while game is packaged in Development mode, but when I'm trying to build the game in Shipping mode I get:

 MainFrameActions: Packaging (Windows): UnrealBuildTool: VaOceanShaders.cpp
 MainFrameActions: Packaging (Windows): UnrealBuildTool: D:\WorkProjects\SeaCraft\Plugins\VaOcean\Source\VaOceanPlugin\Public\IVaOceanPlugin.h(12) : error C2143: syntax error : missing ';' before '<class-head>'
 MainFrameActions: Packaging (Windows): UnrealBuildTool: D:\WorkProjects\SeaCraft\Plugins\VaOcean\Source\VaOceanPlugin\Public\IVaOceanPlugin.h(12) : error C2143: syntax error : missing ';' before '<class-head>'D:\WorkProjects\SeaCraft\Plugins\VaOcean\Source\VaOceanPlugin\Public\IVaOceanPlugin.h(
 MainFrameActions: Packaging (Windows): 12) : error C2143: syntax error : missing ';' before '<class-head>'
 MainFrameActions: Packaging (Windows): UnrealBuildTool: 
 MainFrameActions: Packaging (Windows): UnrealBuildTool: D:\WorkProjects\SeaCraft\Plugins\VaOcean\Source\VaOceanPlugin\Public\IVaOceanPlugin.h(12) : error C2143: syntax error : missing ';' before '<class-head>'
 MainFrameActions: Packaging (Windows): UnrealBuildTool: ShipVehicle.cpp

What can be a problem with it?

P.S. - Also I've found that content from plugin won't work in packaged game. I know that this feature is not fully implemented yet, so JFYI.

Product Version: Not Selected
Tags:
more ▼

asked May 07 '14 at 01:00 PM in Packaging & Deployment

avatar image

ufna
163 12 13 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Solved. It was ';' missing after DECLARE_LOG_CATEGORY_EXTERN - it failed the shipping build.

more ▼

answered May 09 '14 at 03:41 PM

avatar image

ufna
163 12 13 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

i can problem of plugin VaOcean:alt text

how solved this problem of VaOcean plugin for unreal engine 4.2 ?

also when i open the option of terrain blueprint, unrealengine crashed, closes, how to solve?

sin título.jpg (32.2 kB)
more ▼

answered Jul 03 '14 at 10:48 PM

avatar image

Anim
6 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question