x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

IOS problem's Game builds & Transfer's fine but fails on install 40% every time ?

Please help,

I have been banging my head with this now, firstly i am using certs and provisions generated with exact same bundle id for project and they show Green in UE4, but when i try to build on iPhone or transfer .IPA via iTunes i get same failer, the error is always during install at 40%

LogPlayLevel: DeploymentServer: [DD] Installing IPA on device '........' ... LogPlayLevel: DeploymentServer: [DD] ... Install is 5% complete at phase 'CreatingStagingDirectory' LogPlayLevel: DeploymentServer: [DD] ... Install is 15% complete at phase 'ExtractingPackage' LogPlayLevel: DeploymentServer: [DD] ... Install is 20% complete at phase 'InspectingPackage' LogPlayLevel: DeploymentServer: [DD] ... Install is 20% complete at phase 'TakingInstallLock' LogPlayLevel: DeploymentServer: [DD] ... Install is 30% complete at phase 'PreflightingApplication' LogPlayLevel: DeploymentServer: [DD] ... Install is 30% complete at phase 'InstallingEmbeddedProfile' LogPlayLevel: DeploymentServer: [DD] ... Install is 40% complete at phase 'VerifyingApplication' LogPlayLevel: DeploymentServer: Install \ Update of "TappyChicken.ipa" failed with Application Verification Failed Error in 5.45 seconds LogPlayLevel: DeploymentServer: [DD] LogPlayLevel: DeploymentServer: Exiting. LogPlayLevel: CommandUtils.Run: Run: Took 13.0751119s to run DeploymentServer.exe, ExitCode=1 LogPlayLevel: BuildCommand.Execute: ERROR: BUILD FAILED LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception: LogPlayLevel: Program.Main: ERROR: Exception in AutomationUtils.Automation: Command failed (Result:1): C:\Program Files (x86)\Epic Games\4.10\Engine\Binaries\DotNET\IOS\DeploymentServer.exe Install -ipa "C:\Users\DSB Games\Documents\Unreal Projects\TappyChicken\Binaries\IOS\TappyChicken.ipa" -device All_iOS_On_DSBW10 -additionalcommandline "-SessionId=5ADA6353484AC07CAA4EFA9E0893B9D1 -SessionOwner=DSBGames -SessionName='Play On Device'". See logfile for details: 'DeploymentServer-2016.04.15-21.01.55.txt' LogPlayLevel: Stacktrace: at AutomationTool.CommandUtils.RunAndLog(String App, String CommandLine, String Logfile, Int32 MaxSuccessCode, String Input, ERunOptions Options, Dictionary`2 EnvVars) LogPlayLevel: at IOSPlatform.Deploy(ProjectParams Params, DeploymentContext SC) LogPlayLevel: at Project.Deploy(ProjectParams Params) LogPlayLevel: at BuildCookRun.DoBuildCookRun(ProjectParams Params) LogPlayLevel: at BuildCommand.Execute() LogPlayLevel: at AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands) LogPlayLevel: at AutomationTool.Automation.Process(String[] CommandLine) LogPlayLevel: at AutomationTool.Program.MainProc(Object Param) LogPlayLevel: at AutomationTool.InternalUtils.RunSingleInstance(Action`1 Main, Object Param) LogPlayLevel: at AutomationTool.Program.Main() LogPlayLevel: ProcessManager.KillAll: Trying to kill 0 spawned processes. LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=Error_Unknown LogPlayLevel: Domain_ProcessExit LogPlayLevel: copying UAT log files... LogPlayLevel: RunUAT.bat ERROR: AutomationTool was unable to run successfully. LogPlayLevel: Completed Launch On Stage: Build Task, Time: 19.022387 LogPlayLevel: BUILD FAILED PackagingResults:Error: Error Deployment failed! Unknown Error

i have tried doing this on my Mac, PC and both generate the same ?

PS, sorry for the Output log in the question

Product Version: UE 4.10
Tags:
more ▼

asked Apr 15 '16 at 08:14 PM in Packaging & Deployment

avatar image

DylanBatt74
10 1 2 3

avatar image DylanBatt74 Apr 23 '16 at 06:15 PM

Can anyone help on this ?

avatar image Nick Jackson Apr 24 '16 at 01:24 AM

Just signed in to say that I am having the same error. It fails on this step:

LogPlayLevel: mono: [DD] ... Install is 40% complete at phase 'VerifyingApplication' LogPlayLevel: mono: Install \ Update of "TopDownIOSMobile.ipa" failed with Application Verification Failed Error in 5.96 seconds

I tried with Windows and Mac both get the same error. Tried in Editor, IPhonePackeger on Windows and Editor and ITunes deployment on Mac. None get beyond the ApplicationVerification step. Using iPhone 6+

Edit: Using 4.11.2

avatar image Steve Hardister ♦♦ STAFF Apr 25 '16 at 02:14 PM

Please try these solutions from a user experiencing almost the same issue:

[https://answers.unrealengine.com/questions/86888/ios-build-failed-during-installation.html][1]

  • Put the bundle identifier from [your] app id in project settings

  • Make sure there are not two .plst files in your project\Build\IOS folder. If there are, delete the one that has your project name in it and leave the one named "info.plist."

avatar image Nick Jackson Apr 25 '16 at 10:49 PM

Hi Steve.

I assume we're talking about Bundle Identifier in the IOS settings. It is set, as you can see from the screenshotalt text. The provision and certificates match and are highlighted in green.

I checked the project/Build/IOS folder and there are no .plst files there at all. Only the .IPA file that's the product of the build process. I am not sure if that's a problem or not, I don't recall seeing separate .plists there before.

I can confirm there is only one .plist inside the .IPA package when I inspect it. It's content matches my settings in the editor:

CFBundleIdentifier gk0r.Test

But it still fails on the VerifyingApplication phase.

For what it's worth - I can deploy other applications (non-UE4) naively from xCode but I am not sure if that means anything.

1.png (54.8 kB)
avatar image Steve Hardister ♦♦ STAFF Apr 26 '16 at 05:45 PM

Just to see if this is project related or related to your provisions,etc. please test by packaging the free demo "Tappy Chicken" available here:

https://wiki.unrealengine.com/Tappy_Chicken_Sample_Game

avatar image Nick Jackson Apr 27 '16 at 01:08 PM

Hi Steve

I downloaded Tappy Chicken from the link you provided. I changed Bundle Identifier to match my provision and certificate.

Windows

When I try to Launch on Device I get this error log output

When I try to install the .IPA via IphonePackager I get this error log output:

Mac

When I try to Launch on Device I get this error log:

When I try to upload the app using iTunes it loads the application, installs it, then immediately deletes it from the phone.

I have turned on trusted developer in Device settings.

iMac (Late 2015 Model) is running 10.11.4 El Capitan.

Windows 8

iPhone 6+ running iOS 9.3.1

Tried UE4 versions 4.11 and 4.10

Please let me know if you would like to follow any other steps to attempt to reproduce. Thanks

avatar image DylanBatt74 Apr 26 '16 at 08:22 PM

I have been using this TappyChicken project to test this, and that is what i was getting the errors with , all provisions and cert green but fails,

My concern now is if i cant get this working using XCODE certs etc, should i buy developer licence yet, or am i going to get same problems and be £79 out of pocket ?

avatar image Steve Hardister ♦♦ STAFF Apr 26 '16 at 08:56 PM

@ DylanBatt74: You should be able to launch Tappy Chicken on the iOS Device directly or package as an .ipa file that you can transfer to your device through iTunes without buying a developer license. I suggest not spending money until we have determined the cause of the issue since purchasing a developers license will not correct this (You only need that license to publish to the app store itself.) -Since I am not able to reproduce this with Tappy Chicken packaging from a MacBook Pro to an iPad, please list your system specs and what iOS device you are launching to and iOS. (ie iPhone 5S running iOS 9 )

@Nick Jackson: Please try with Tappy Chicken, if you have not already, so that we are all on the same page.

-Thanks

avatar image DylanBatt74 Apr 27 '16 at 06:50 PM

Hi Steve,

This was the Original thread i started about this, Exact same problem as Nick all my specs and what i have done are on there

https://forums.unrealengine.com/showthread.php?107153-Build-And-Test-on-IOS-Device-Problems

avatar image DylanBatt74 Apr 27 '16 at 07:11 PM

Hi Steve,

I almost forgot, I am using IOS 9.3.1 on an iPhone 6s

Developing on and have tried both

MAC Pro (Hackintosh) 10.11.4 El Capitan, UE4 4.9, 4.10 and 4.11
PC with Certs and Provisions from XCODE UE4 4.9, 4.10 and 4.11

i7-4790k @4.6 32Gb Ram

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I believe the following AnswerHub Post addresses and provides the fix for this issue as the user was experiencing the same error in the their Project Log:

ipa will not install to device (iOS)

While I suggest reading the entire post for a better understanding of the problem, here are some key points:

  1. Apple's World Wide Developer Relations certificate recently expired. Make sure you have the new one installed: (https://www.apple.com/certificateauthority/ install the WWDR certificate expiring in 2023).

  2. Delete all old Certs, Identifiers and Provisions then create new key pairs with with 4.9 iPhonePackager. Then recreate all the Apple necessities.

  3. For UE4.10, Use the attached iPhonePackager. Put it in 4.10InstallDir/Engine/Binaries/DotNET/IOS and then package as normal: 80982-iphonepackager.zip

  4. Alternately, use this packager: 81003-iphonepackager

Please try these steps and let me know if they do not resolve the issue.

Thanks,

Steve H.

more ▼

answered Apr 28 '16 at 06:08 PM

avatar image DylanBatt74 Apr 29 '16 at 09:47 AM

@Nick Jackson, @Steve Hardister

I tried all of the above with no joy, so i plumped into buying my Dev licence as i need it for my XCODE work as well Anyway built Tappy Chicken to test and tested on my phone, :) YESS straight on no issues, so i packaged up .ipa and installed via iTunes and worked also

So that fixed it for me, hope this helps

avatar image Steve Hardister ♦♦ STAFF Apr 29 '16 at 05:02 PM

So one detail I did not see mentioned before on this post is that you are working with XCode 7. From the following forum post, it appears it is possible to Launch On Device and Package (and transfer to device through iTunes), but additional steps are required:

https://forums.unrealengine.com/showthread.php?81130-Xcode-7-deploy-to-iOS-device-without-joining-developer-program

avatar image Nick Jackson May 01 '16 at 01:18 AM

Thanks for info @DylanBatt74. I also tried everything @Steve Hardister suggested but to no avail. I can regenerate new provision but I can't work out how to regenerate developers certificate without being a member of Apple Developers Program.

I first generated it in March. This was after the old WWDR expired. I have deployed UE4 games on my device after the WWDR expiry date so I don't think it has anything to do with that.

The strangest thing is that I can use the same provision and certificate to deploy an xCode application. But I can't use them to deploy UE4 app for some reason.

@DylanBatt74 - what have you done differently after joining ADP? Can I get this to work without having to fork out the fee?

avatar image Steve Hardister ♦♦ STAFF May 03 '16 at 05:39 PM

In a conversation with our primary iOS Developer, Peter Sauerbrei, he suggested that "[you] either [have] old provisions or don't realize the Apple World Wide Developer Authority Certificate expired in February and must be uninstalled."

Please make sure that this has been uninstalled and that you are running the updated certificate from Apple. Let me know if this does not resolve the issue.

Related article: http://thenextweb.com/apple/2016/02/15/apples-wwdr-certificate-expired-today-causing-problems-for-developers/#gref

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have not done anything differently,apart from where you upload your generated key to Apple to generate cert then download along with the provision, i have also generated the key as a wildcard along with my app provision as this just enables me to use for developing games and app and not having to generate a provision for each app When I'm ready to deploy to store I will create a new provision which will be specific to the app

But apart from that all I have done is use the paid for method, as I need for uploading to store and this way Sorry I can't be more helpful but I was having the same issues and that fixed for me

more ▼

answered May 01 '16 at 01:31 PM

avatar image

DylanBatt74
10 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question