x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Client's Player Blueprint Will Not Run When Playing Over LAN Connection

I recently updated to 4.11 and in PIE joining session and playing the game works fine and even in packaged game on the same machine I can create a session and join it no problem but when I try and do it over LAN it will join but the client will not execute anything in it's player blueprint. I'm lost and out of ideas. Any help would be great I will post some of the stuff that runs on the begin play node.

alt text

Product Version: UE 4.11
Tags:
more ▼

asked Apr 16 '16 at 12:38 AM in Blueprint Scripting

avatar image

Vul Sil
11 3 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I have fixed it it. I went into the logs and found a error that said tick function something anyways. I fixed my problem by setting the tick interval in each blueprint back to 0.

more ▼

answered Apr 19 '16 at 01:33 AM

avatar image

Vul Sil
11 3 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey there,

if everything is working via PIE and on the same Computer, then we will need the LOG Files of your Client and Server.

Please remove all existing LOG Files from your packaged game. Then Start the Server on one PC and the Client on a second PC. Then try to connect. If it fails, close both Games and go into the LOG Folder again.

Upload the files here so we can see what goes wrong.

I would guess that the Client gets kicked off while joining or something like that.

LOG Files can be found in the "\Saved\Logs" Folder of your game/project.

more ▼

answered Apr 17 '16 at 06:25 PM

avatar image

eXi
6.8k 332 184 465

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question