x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Zip up project: Unzipping has missing .dll

I tried zipping up my project using the built-in zip up function under File/Packaging. However, when I unzip it, it says it's missing a .dll file.

alt text

So I try to rebuild them, but it encounters an error.

alt text

From what I can tell from online searching, this can't build because it doesn't have the necessary C++ files to rebuild the .dll. How do I make the engine zip up those files as well, or do I just have to manually drop them in there?

Product Version: UE 4.10
Tags:
more ▼

asked Apr 17 '16 at 01:46 AM in Packaging & Deployment

avatar image

Yulgalminakf
73 12 17 26

avatar image Sean L ♦♦ STAFF Apr 25 '16 at 05:36 PM

Hello,

I have attempted to reproduce your issue, but have not been able to do so. Here are my steps:

  1. Create a new C++ project

  2. Zip up project

  3. Delete the project files from my computer

  4. Unzip the project files

  5. open the project

I am getting the rebuild message, but my project is opening successfully. Is there a step that you are performing that I am missing?

avatar image Yulgalminakf Apr 26 '16 at 12:16 AM

Quick question: did you use the built-in ue4 zip-up, or did you go to the files directly and zip those up? Because, zipping up the entire project works fine, it's only the built-in zip up that doesn't load.

I'm still not sure what the problem is, but I found a solution, just go into the project's file directory and copy-paste the entire "Source" folder into the zip file. Still unsure why the engine doesn't see the source files as necessary.

So, if you are using the built-in zip up functionality, does your zip at the end contain the "Source" folder?

avatar image Sean L ♦♦ STAFF Apr 26 '16 at 06:27 PM

My zip contained the source folder and did require a rebuild, but it was able to build successfully and I didn't have any issue opening the project. Does this occur for you in any project, or only in a particular project?

avatar image Yulgalminakf Apr 26 '16 at 07:24 PM

It occurs with any project.

This: https://www.dropbox.com/s/zqm9iplfgvbvbfq/MyProject2%20full%20zip.zip?dl=0 is a full and manual zip of the project (minus intermediate and .sdf visual studio files). I went directly to the folder that contains the project, and right-clicked, then added it to archive. This comes up with a message that says it needs to rebuild the .dll. It builds with no problems. This is not the problem I'm having.

This: https://www.dropbox.com/s/ndgpshvph89pcip/MyProject2%20built%20in%20zip%20result.zip?dl=0 is the result when I open the project (the first link) and go to File->Package Project->Zip Up Project. This also opens with a message saying it needs to rebuild the .dll file, but does NOT rebuild properly. It comes up with the same error message from my first post that says "Try rebuilding from source manually." This is the problem I'm having. It doesn't automatically place the "Source" folder into the zip.

Here's a list of every single step I made:

  1. Make an empty project.

  2. Delete the Starter Content.

  3. Add New->New C++ file.

  4. Make a new class called "MyClass" extending from none.

  5. Manually add in extension to UObject and make it a UCLASS(BlueprintType) to make it show up in blueprints and other stuff involved with that (I forgot to make it a UObject from the start).

  6. Build

  7. Make a blueprint that contains the class as a variable.

  8. Save everything.

  9. File->Package Project->Zip Up Project.

The result is the second zip file linked in this post. It does NOT contain the "Source" folder. If I manually add in the "Source" folder, it rebuilds the .dll file just fine, but without manually inputting the "Source" folder, it does not rebuild properly.

P.S. Not sure it it would even make a difference to the zip-up functionality, but I tried all three Build Configurations in File->Package Project->Build Configurations. All three resulted in the same zip-up without a "Source" folder.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello,

After further investigation, it appears that this issue is fixed in 4.11. I followed your steps, but was unable to reproduce the issue, as my zip contained a source folder as expected. Go ahead and try it out in 4.11 and let me know if that solves your issue.

Have a great day

more ▼

answered Apr 27 '16 at 04:55 PM

avatar image

Sean L ♦♦ STAFF
43.9k 485 150 440

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question