x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Problem with FPS blueprint, error while playing

Hi!

I'm kind of new to Unreal Engine and I have a problem with my FSP-blueprint. I'm doin an arch-viz walk through and wanted to remove the arms and guns. So I deleted them in the viewport and then compiled and saved both blueprint and project. I know now that I should've just hidden them instead of deleting them. Anyway, my FPS couldn't move after I deleted the arms and guns. Solved that problem by adding new meshes but now I get an error message every time I play in the editor. Tried to cook/package the project and it crashes almost immediately, I guess it's connected to my blueprint-problem... I'm not used to blueprints and have no clue how to fix this... :( Please help! alt textalt textalt text

Product Version: UE 4.10
Tags:
message log.jpg (236.0 kB)
blueprint.jpg (608.9 kB)
more ▼

asked Apr 18 '16 at 05:48 AM in Blueprint Scripting

avatar image

Was14vda
11 2 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

That error means you have not assigned an Animation Blueprint for the that Mesh. To avoid this error (assuming you dont want the hands to move at all) just add a IsValid node before Montage Play in Event Graph.

alt text

is valid.png (111.1 kB)
more ▼

answered Apr 18 '16 at 06:24 AM

avatar image

ryanjon2040
1.6k 56 43 93

avatar image Was14vda Apr 18 '16 at 06:47 AM

It worked, yey! Thank you!

But the project still crashes when I've cooked/packaged it.. Do you think there's a connection between the FPS-blueprint? Or what could be the problem? Didn't have this problem before I messed with the blueprint. :/

avatar image ryanjon2040 Apr 18 '16 at 07:25 AM

At what point you got the error? Did the game started?

avatar image Was14vda Apr 18 '16 at 07:32 AM

The game starts, sometimes I can walk and move for a little while and then it crashes. Sometimes it crashes immediately..

avatar image ryanjon2040 Apr 18 '16 at 08:18 AM

Try playing in Editor for sometime and see if it crashes. If it does then please post the error from Output log :)

avatar image Was14vda Apr 18 '16 at 11:37 AM

It works fine in the editor. Only crashes in the packaged exe-file.. Found this log via the unreal engine crash reporter. I guess this is the problem "[2016.04.18-11.22.13:767][988]LogSkinnedMeshComp:Warning: GetSocketByName(): No SkeletalMesh for SkeletalMesh" ?

[link text][1] [1]: /storage/temp/87302-attityd_131_h3.log

attityd_131_h3.log (157.6 kB)
avatar image Was14vda Apr 22 '16 at 05:10 AM

Any luck finding out what's wrong? Thankful for your help!

avatar image Was14vda Apr 22 '16 at 08:16 AM

Btw, I managed to migrate a FPS-blueprint to this project from the FPS-template. But it still crashes in the standalone game-mode. This is the new log via the crash reporter..link text

attityd_131_h3.log (18.0 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question