x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Texture corruption on iOS?

When running my packaged build (.IPA) or through launching to device via editor, my iOS builds will incorrectly render one of my images. This is what I see on an iPhone 5 (iOS 9.1) and iPhone 6 + (iOS 9.3):

alt text

The image is initially a 1920x1080 image. I have tried importing it as .JPEG, .PNG and .TGA. This texture is the sole texture being output through the UMG widget.

The iPhone 5 runs at 1136x640 and the iPhone 6 + runs at 1920x1080.

At first I thought it might be due to the fact that the image is not a power of 2 resolution image, but other images that have been imported into the project do not suffer this problem. Here is additional information regarding the setup for this image:

alt text

It shows DXT1 in the above image, but I have also previously tried setting the image to group to UI and having it at compression DXT1/5 (default).

This is from the Get Info in OS X regarding the image before importing it in: alt text

What's interesting is that this does not happen on an Android phone running Android 4.4, despite using the exact same settings. Are there any steps I can take to remedy this? Is it a packaging issue or an error on my behalf?

Product Version: UE 4.10
Tags:
img_0007.jpg (329.5 kB)
image_problem.png (21.7 kB)
image details.png (29.8 kB)
more ▼

asked Apr 19 '16 at 08:29 AM in Rendering

avatar image

Sabun
48 4 9 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

In the end, it was a power of 2 issue. Embedding the image into a larger image of 2048x2048 proportions made for the image to be visible on iOS. My confusion came from glancing at other image resolutions and not realising they were still power of two, but not in tandem. For example, 1024x512 is still valid in iOS but 1024x768 is not. 2048x1024, 256x512 etc are all usable.

more ▼

answered Jun 23 '16 at 03:18 AM

avatar image

Sabun
48 4 9 9

avatar image InLove4 Sep 30 '16 at 01:36 AM

explains me how you did it please Sabun, I did not understand.

avatar image Sabun Sep 30 '16 at 04:52 AM

What I did was use a tool (GIMP in this case, but you can use Photoshop or Krita in the same way), and created a base image with a power of 2 resolution (for example 2048x2048).

Then I pasted in the original image I had that was not at a power of 2 resolution ( for example 1920x1080). I saved this new image and used it in UE4. So, it's a 2048x2048 image with a 1920x1080 image embedded in it.

Then in UE4's UI, I simply scaled the image up until only the embedded image could be seen (hiding the excess parts of the image). This is not the best way to approach this, but it is one quick solution. If you could instead adjust your image to be saved directly as a power of 2 resolution, then you would be better off.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question