x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Chaperone bounds lag behind geometry

For some reason the Chaperone bounds are very floaty compared to the rest of the geometry. So they seem to lag behind. This happens on my own project as well as VR templates that I have found.

This only happens when there is a camera in the scene. So if i just open a empty project and try 'VR preview' the bounds seem solid.

I can't find anyone else with this problem so i guess the issue is at my end. I have tried reinstalling UE4 and steamVR but the problem persists. Any ideas? The same problem also happens on 4.10.

Using a consumer Vive.

Product Version: UE 4.11
Tags:
more ▼

asked Apr 19 '16 at 12:05 PM in VR

avatar image

jokippo
21 1 1 4

avatar image Springularity Apr 23 '16 at 03:04 PM

I'm also having exactly this issue. The Chaperone bounds lag a centimeter or two behind geometry. Causes an unpleasant swimmy effect when the chaperone is visible.

As you say, deleting the player camera fixes it.

Found this other question which has a code solution..

https://answers.unrealengine.com/questions/377439/vr-buffered-frames-and-follow-hmd-orientation-miss.html

I'm updating to 4.11.1 now to see if it's fixed.

avatar image Springularity Apr 23 '16 at 03:55 PM

Nope, still occurring in 4.11.1.

Have linked back to this question from the old one.

avatar image Jonny Cache Apr 26 '16 at 07:40 AM

Also experiencing the same issue with 4.11.2

If you implement the camera the old way like this the chaperon is locked solid to the world and everything is okay. However, if you implement it the new way that was recommended for 4.11 the chaperon lags behind the world noticeably.

The new 4.11 method is far more convenient and powerful, but unfortunately while the world is running great I find the bounds sloshing about to be very nauseating.

The symptom is very similar to buffered frames issue Springularity mentioned. However, the code was modified in 4.11 just as ChadTaylor said so the source is probably something else. :(

avatar image weberl May 05 '16 at 10:49 PM

Did you get this solved in the meantime? I have the same problem and no idea what I did wrong.

avatar image 3DA May 07 '16 at 03:18 PM

New finding, When I use this:

https://docs.unrealengine.com/latest/INT/Platforms/SteamVR/QuickStart/2/

and in step 10. I use 0 Z height /0,0,0/ :

...10. Select the Player Start and position it so that the center of the Player Start is just above the Static Mesh used for the ground. In this example we used a Z height of 1.0 CM for the Player Start.

...everything works fine.

avatar image Rasped May 07 '16 at 04:00 PM

The fix above does not take care of the problem with controllers.

They still suffer from the lag.

Watch this video for clarification: https://www.youtube.com/watch?v=FCDCvbo_ClM

avatar image 3DA May 07 '16 at 04:12 PM

correcting - New finding -Chaperone floating

When I change in Project Setting/Maps&Modes/DefaultModes/ Default GameMode from "VR" to Game Mode Chaperone is sticky. Problem is in VR gameMode

avatar image Eternus Nox May 09 '16 at 05:08 PM

This is still occurring for me on 4.12 preview 2 also, really hope we get a fix or official workaround soon

avatar image VictorBurgos May 09 '16 at 05:18 PM

4.12 is still in preview. Post it as a Bug Report if you are still having issues.

avatar image 3DA Jun 02 '16 at 10:17 AM

Hi Epic, Thank you for your work and the new version.

I have a basic questions.

Vive Chaperone is still "Wavy" in 4.12 when I using this https://docs.unrealengine.com/latest/INT/Platforms/SteamVR/QuickStart/2/index.html

Only deselect "auto manage active camera target" help me https://answers.unrealengine.com/questions/407349/chaparone-bounds-lag-behind-geometry.html

https://answers.unrealengine.com/questions/407349/chaparone-bounds-lag-behind-geometry.html https://forums.unrealengine.com/showthread.php?109879-quot-Wavy-quot-chaperone

My questions: 1. The setting doc is obsolete? 2. I missed something in doc? 3. I have to use a paid Epic support? 4. It is blocking feature against development? 5. Can I get an official response?

Thank you very much. Michal

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Ok I solved this. You need to decativate the property "auto manage active camera target" in your player controller. If I do this then the lag is gone.

alt text

more ▼

answered May 05 '16 at 10:59 PM

avatar image

weberl
232 16 19 33

avatar image Jonny Cache May 06 '16 at 01:53 PM

Hey jokippo! Weberl's solution here fixed the floaty chaperon problem even with the new 4.11 camera setup :D The world is locked solid again!

avatar image Springularity May 07 '16 at 12:24 PM

Yup, fixed for me too. Awesome, thanks folks :)

avatar image Springularity May 07 '16 at 12:54 PM

Ok, after further investigation. I now cannot use the camera attached to my VR character to get location or rotation of the HMD if I turn off "Auto Manage Active Camera Target." So not a perfect fix. There a way round this?

avatar image Jonny Cache May 09 '16 at 04:19 PM

Ran into the same issue with this flag set. While the player pawn seems to spawn in the same orientation, the camera is rotated (in my case it was 90 degrees counter clockwise).

You can rotate the player start entity so that the camera and pawn align, but it's not a good fix. It looks like if you use the Auto Manage Camera flag you don't use the pawns camera, but the camera from the controllers camera manager which has a separate rotation from the pawn. :(

avatar image weberl May 11 '16 at 12:01 PM

In the meantime i spent some more time with this issue. I had the best result with removing the camera. Yes you heard correctly. Remove the camera from the pawn and you will still have lag free images in your HMD.

avatar image Springularity May 11 '16 at 12:38 PM

How do you get HMD transform info without having a camera in the player pawn? Is there another route to get HMD position and rotation easily?

avatar image weberl May 17 '16 at 06:52 AM

Yes. I will Post a Screenshot of my working setup tonight. I have the controllers working too.

avatar image Springularity May 17 '16 at 10:31 AM

Fantastic, that'd be much appreciated, thanks :)

avatar image weberl May 18 '16 at 12:20 AM

I get the Players position in the chaperone like this: alt text

Here's my pawn: alt text

And here is the controller setup. I rotated them 90degree and lifted them 70cm into the air to make sure they always spawn on start: alt text

Anyway: the X and Y coordinated of the Thumbsticks are switched so just rewire them in your scripts...

My chaperone is flat on the ground and doesn't float arround when moving the headset. There is no lag.

avatar image Rasped May 11 '16 at 12:46 PM

@weberl You should uncheck your answer as accepted I think. Doesn't seem like the solution is really what we need. I'm not sure that Epic monitors threads with an accepted answer

avatar image Rasped May 11 '16 at 12:47 PM

Oh, you can't unaccept it t seems... sorry.

avatar image Rasped May 07 '16 at 03:57 PM

When I use this solution, my controllers are now tracked X and Y "negative".

Mean they move mirrored inside the play area. Not attached to the camera... really weird

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question