x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging ERROR

Hey, I just wanted to package my project for Windows 64-bit and it goes wrong

Here is the end of log: alt text

Please help, I'm on Jam and really running out of time

Thanks :D

Product Version: UE 4.11
Tags:
bez názvu.png (172.4 kB)
more ▼

asked Apr 19 '16 at 03:40 PM in Packaging & Deployment

avatar image

SiCzech
45 7 11 14

avatar image Matthew J May 02 '16 at 06:19 PM

Hello SiCzech,

I wish I saw this post sooner, I would've helped out. I'm assuming the Jam is over now? If not and you still need help, please post the entire log that contains the errors from your project's directory under Saved / Logs. While the error given is "Unknown Error", this basically means "It failed" and the actual error/warning causing it is elsewhere in the log.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Welcome back. Did you add any plugins to your project that may be code based and need to recompiled? That would cause the editor to require Visual Studio to be able to continue.

The Project Launcher is a way to be able to set up profiles for launching/packaging your project so that you can switch between profiles at will. It is often used when packaging DLC or Patches as well. You can find more information here: https://docs.unrealengine.com/latest/INT/Engine/Deployment/Releasing/

more ▼

answered Jun 06 '16 at 12:44 PM

avatar image SiCzech Jun 07 '16 at 05:47 PM

oh..you were right, thank you again..

But finally, I've got a problem as I had before, the unknown error. And the migration doesn't work.. It is a alpha version export of our game

Here is the Log:link text

log.txt (383.7 kB)
avatar image Matthew J Jun 07 '16 at 05:58 PM

As I mentioned before, the "Unknown Error" message is never indicative of what is actually wrong. It's always a good idea to hit ctrl+f and search for the word "Error" when you're sifting through a log like this. This pointed me toward a couple messages.

The first one is this:

ERROR: NOTE: Please ensure that 64bit Tools are installed with DevStudio - there is usually an option to install these during install

This means that there may be some parts of your Visual Studio install that need to be added. This can be done in the Visual Studio installer, which you can bring back up by selecting it in your Programs & Features section of the Control Panel in Windows. Anything under Visual C++ should be what you need to include.

The second one is:

Assertion failed: Pair != nullptr [File:D:\Build\++UE4+Release-4.12+Compile\Sync\Engine\Source\Runtime\Core\Public\Containers\Map.h] [Line: 520]

This error usually means that there is a level reference somewhere that shouldn't exist or is trying to point a level that no longer exists. This can also include attempting to reference a particular level's Level Blueprint. Please look out for these and see if you can find the culprit. Based off the context, it seems like it could be in your "kino_button_BP" asset.

avatar image SiCzech Jun 07 '16 at 08:01 PM

ok, I removed the empty variable of my kino_button_BP. I don't have Visual Studio installed at all, so shall I install it ?

avatar image Matthew J Jun 08 '16 at 01:16 PM

If you plan to use any plugins that require being recompiled. You shouldn't need to unless that Error (which is actually labeled as a warning) is stopping you from packaging. Are you still receiving the "Pair != nullptr" error after editing your blueprint?

avatar image SiCzech Jul 11 '16 at 05:30 PM

Hi, so it was because of broken plugin that I installed. Thank you so much for help

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

We haven't heard from you in a while, SiCzech. Are you still experiencing these issues? If so, could you provide the information I requested? We need more information from you to progress with this issue.

In the meantime I'll be marking this post as resolved for tracking purposes. Whenever you're available, please leave a comment and the post will reopen.

more ▼

answered May 09 '16 at 06:01 PM

avatar image SiCzech Jun 05 '16 at 08:21 AM

Hi, and sorry for my delay, I wasn't on AnswerHub for long time. Well, I solved this issue ! I've just migrated all maps to another new project, compiled everything and it worked :)

But, maybe I'd like to ask about another issue. I'm trying to package my new project on Windows 64-bit but instead of packaging it's asking me to install Visual Studio which I've never used, never needed because all my code is made in BP.! Also I've noticed the Project Launcher which I've never needed for packaging neither. Could you explain me what is it for ?

Thank you

alt textalt text

1.jpg (93.6 kB)
2.jpg (88.3 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question