x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

UMG On key down doesn't work since 4.11

Hi,

I just updated my project from 4.10 to 4.11. I have a pause menu, I used SetInputModeUIOnly and the SetGamePaused blueprint nodes to activate it. I overwrote the On Key Down function in the widget I used for the pause menu.

Everything worked fine before the update. Now OnKeyDown in the widget is not called. (I tried the same without pauseing the game, the widget still doesn't get any key down event).

Did something change about the way this overiddable function works, or is it a bug? Is there anything I should check, which may cause this problem?

Thanks,

Elathan

Product Version: UE 4.11
Tags:
more ▼

asked Apr 22 '16 at 07:50 PM in Using UE4

avatar image

Elathan
426 25 27 59

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Elathan,

I ran into this issue today, as well when upgrading from 4.10 to 4.11. The Widget had reset "IsFocusable" back to false during the 4.11 conversion process. Simply re-enabling this restored the OnKeyDown event to working status.

For reference, I have a PauseMenu child of User Widget. To enable "IsFocusable", I select [PauseMenu] in the Hierarchy panel, then in the Details panel, set "Is Focusable" (found under the Interaction tab) to true.

I hope it's this simple for you, too!

-Kelson

more ▼

answered Apr 22 '16 at 10:57 PM

avatar image

KGist
106 2 15 24

avatar image Elathan Apr 22 '16 at 11:57 PM

I have the same setting. Checking IsFocusable solved my problem. Thanks.

avatar image VSZ Jul 09 '16 at 07:59 PM

Thank you so much for sharing this KGist! I ran into the same thing today and if not for your post I don't know how I would have ever fixed this. You've saved me a lot of time and vain effort, thanks again!

avatar image KGist Jul 10 '16 at 04:43 AM

Glad to hear it!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question