x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Texture disappears when using opacity mask to create a hole

Hi

I want to create a hole in the landscape as a starting point to create a cave. I'm following the article at https://docs.unrealengine.com/latest/INT/Engine/Landscape/Editing/SculptMode/index.html#visibility

My 'Hole' material is exactly the same as my Landscape material, except for the Blend Mode set to Masked, and the new Landscape Visility Mask node:

alt text

When I tried to apply the 'hole' material to the landscape , the quad where I click loses the texture as you can see in the viewport:

alt text

Shutting down the editor and opening it again to recompile the shaders doesn't fix the issue. Does anybody know why is this happening? Is it a known issue?

Product Version: UE 4.11
Tags:
material.jpg (471.2 kB)
editor.jpg (254.4 kB)
more ▼

asked Apr 23 '16 at 05:15 PM in Bug Reports

avatar image

Almanzor
11 3 4 9

avatar image Adam Davis STAFF Apr 25 '16 at 05:17 PM

Hi Almanzor,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?

  • How many textures/layers do you have painted onto the landscape component?

  • Have you tried re-painting on the component to force an update?

  • Have you tried pressing the build button to force an update?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Almanzor,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

more ▼

answered Apr 29 '16 at 03:14 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question