x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Picking up objects doesn't work when changing levels

Hello,

I've got a blueprint on my First Person Character that I know works, it enables me to pick up objects with a set mass with the key press of 'E' and dropping objects with the release of the 'LMB'

This works in two out of three of my levels, why is it not working in one of the others? I am completely lost and have no idea how to debug this issue.

Product Version: UE 4.10
Tags:
more ▼

asked Apr 25 '16 at 01:27 AM in Using UE4

avatar image

MichaelNoyce
1 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It's very hard to tell without further information or context. Was a level created by copying the other and one was not? In that case it may be something in the level blueprint that is missing in the third level.

Or are you referring of changing level while holding an object? In that case it makes sense that it would not work as the player character is respawned in a new level.

more ▼

answered Apr 25 '16 at 02:06 AM

avatar image

keyle
1.8k 66 27 90

avatar image MichaelNoyce Apr 25 '16 at 04:29 PM

It was working before, I've loaded up a previous save and it has nothing in the level blueprint, but still allows me to interact with objects. It's all something in my First Character Controller.

And nope, not changing a level whilst holding. I used this video to get the result I wanted and it previously worked, I have no idea why it's not working, I even re-followed it to no avail.

https://www.youtube.com/watch?v=OltZ-xFz8IQ

avatar image MichaelNoyce Apr 25 '16 at 04:33 PM

Just to make sure I even copied the code from the previously working version and it still doesn't work. On any levels now.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question