x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to make separate part of level dark?

So, i have a well lit level. But, sadly the "cave" or dungeon i have created does not go dark. Infact, it stays VERY well lit. How would i fix this? Example shown: http://imgur.com/EGHvPyz

Product Version: UE 4.10
Tags:
more ▼

asked Apr 25 '16 at 02:17 AM in Using UE4

avatar image

XiloXiao
55 14 16 26

avatar image ryan20fun Apr 25 '16 at 07:30 AM

Your lights are too bright and or there attenuation radius is too large.

avatar image XiloXiao Apr 25 '16 at 07:31 PM

Yes, haha. That makes sense.. Thank you for your reply!

avatar image XiloXiao Apr 25 '16 at 07:47 PM

EDIT: It did nothing.. I changed the lights on the torches. Did nothing. Changed the attenuation radius. Did nothing. What should i do?

avatar image ryan20fun Apr 25 '16 at 07:53 PM

Have you tried rebuilding lighting? (It's under the "Build" button on the main tool bar)

avatar image XiloXiao Apr 25 '16 at 08:10 PM

Yes, lighting has been rebuilt every time i make a change with the lighting. My issue is that, the cave refuses to darken. I will go through and make sure there are no leaks :/

avatar image TorQueMoD Apr 25 '16 at 09:20 PM

What type of light are you using to light your level? A Dominant Light? Is there a skylight in the scene? My guess is its the Indirect lighting settings that are causing your problem. Indirect lighting will add light to all areas of your level preventing you from experiencing any areas with Pitch blackness. Also Eye Adaptation settings will greatly increase the brightness of a scene. You can use a Post Process Volume on your cave area and adjust or disable eye adapatation (Under Auto Exposure, set the Min and Max brightness values to the same number to disable it) and this will also help to adjust the brightness of the scene as Auto Exposure is trying to simulate your eyes adjusting to the different lighting level. If you set the Min and Max brightness to a value of 1 it would probably fix it. I'm not sure what results you'd get if you set them to less than 1 but its worth a try. 0.25 for both for example. Also make sure you've got a Lightmass Importance Volume around the playable area of the level to speed up lighting build times.

avatar image XiloXiao Apr 25 '16 at 09:24 PM

I have a Directional and Sky light. Both have no settings changed except for the color. I honestly have no idea what i could have done. :P

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question