x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Landscape/Character Collision issue

Hello everyone. I started working on my project on Unreal Engine 4.9. And recently updated it to 4.11. As the title says, I've now ran into a problem with the landscape collision, similar to what was happening on version <4.3. And for those who don't know, it's when you create a slope on your landscape with a smooth tool or retopologize tool and when you try to walk on that slope with the character, it falls through the landscape on that spot. For me this happened with the smooth tool.


I tried a few workarounds to fix this that I found from the internet, like ie.

  1. Resampling the landscape from the Landscape -> Manage -> Change Component Size image1

  2. Then I tried to use the Flatten tool from Landscape -> Sculpt -> Flatten, to fix the broken area, but that didn't work.

  3. And finally I tried to change the smooth tools settings to and reapply them to the scene but it did not work either.


The resampling of the landscape did work for the first time, but as soon as I made a change to the same area using the sculpt tool, the issue came back and this time resampling the landscape again did not work. I have absolutely no clue to what causes this and I've been hesitant to use any user made addons to try and fix this.


Here you can see what the spot looks like where the character falls through. image2

The area around the picture works perfectly fine even though it is made using the same settings on the smooth tool.

If there's anything else that I can provide, I'd be happy to do that.

-Jesse

Product Version: UE 4.11
Tags:
more ▼

asked Apr 25 '16 at 12:44 PM in Bug Reports

avatar image

Mechlul
12 1 3 5

avatar image Mechlul Apr 25 '16 at 04:07 PM

Update regarding the issue: It seems like I've been able to fix the issue once again by following the step nr.1. Once I apply the resampling process and the landscape turns kind of pale color, I save and quit the UE. Once I open it again, it fixes the pale effect away and the collision is working again. I won't mark this question as solved as I can simply reproduce the issue.

avatar image Adam Davis STAFF Apr 26 '16 at 08:24 PM

Hi Mechlul,

Unfortunately, I have not been able to reproduce this on my end thus far.

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?

  • What steps can I take to reproduce this error on my end?

  • Are you using a landscape created in editor or is it an imported heightmap?

avatar image Mechlul Apr 27 '16 at 12:28 PM

Hello Adam,

I created a new clean, blank project and was unable to reproduce this issue no matter what, which seems to point the finger to my main project. On my project where this occurs it seems like all I have to do to break the collision again on that specific spot, is to paint a new texture over it. The landscape was made in the editor and was created on version 4.9 and imported to 4.11.

Would you like me to send you the part of the landscape that is broken or is there some sort of debug tool where I could provide some additional information?

Kind regards, Jesse

avatar image Adam Davis STAFF Apr 27 '16 at 03:47 PM

If you feel comfortable with it, can you provide the landscape map with the material in question? I may be able to see what is occurring.

avatar image Mechlul Apr 27 '16 at 03:51 PM

I will duplicate the project now and delete everything that's unnecessary to keep the size small. Is there some place I can upload it to or shall I clean my dropbox?

avatar image Mechlul Apr 27 '16 at 06:55 PM

Hello Adam,

I've now packed the project into the smallest possible size and even tried to point you in the right direction by setting up a widget that shows you where the issue is present. Hopefully you'll find something useful regarding the issue from this! Good luck. :) https://www.dropbox.com/s/h3hflclgks6sym8/JTbugged.rar?dl=0

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Mechlul,

While I was not able to reproduce it on my end in a clean project, it clearly reproduces in the project sent. Unfortunately, I'm not certain what is occurring, but I have entered a bug report, UE-30032, to be assessed by the development staff. In the mean time, it would be best to use the Resampling feature frequently to ensure collision is maintained on your landscape while you work as a workaround until a fix can be implemented.

more ▼

answered Apr 27 '16 at 08:03 PM

avatar image Mechlul Apr 27 '16 at 08:44 PM

Hey Adam,

Thank you for that and hopefully they can find what's wrong with the collision! :)

Sincerely, Jesse

avatar image Gareth Martin STAFF Apr 28 '16 at 04:39 PM

I have examined the example project, and the issue is that you used the "visibility" tool, without having your material set-up for it. This is designed to cut holes in the landscape, both visibly and in the collision. Without the material being set-up, it ends up only cutting the collision.

If you add a "Landscape Visibility Mask" node to your material, and connect it to the (disabled, but that's fine) "opacity mask" output, you'll be able to see your hole :)

I'm going to see if I can add some hints/tips to the visibility tool about this, and maybe disable it altogether if you don't have a Visibility Mask node in your material.

avatar image Mechlul Apr 28 '16 at 05:06 PM

How comes the resampling process did fix it until I made a change to the scene?

But anyways, there are no words enough to thank you both for your awesome and quick help. I was literally struggling with this for a good amount of time! But like you said, some hints/tips would really be a nice addition to the visibility tool now after this incident. :D

The more odd question remains when and why did I even use the tool in the first place.. Maybe I'll just blame it on the cats.

But really, thank you both and till next time! :P

Sincerely, Jesse

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question